Re: OSPF

From: Godswill Oletu (oletu@inbox.lv)
Date: Tue Jul 04 2006 - 12:12:39 ART


Arun,

Have you considered tunnel, as been part of the solution?

Setup a GRE tunnel between sw1 & R4, you can use ip unnumbered on the
tunnels, when your tunnel is setup correctly, add the tunnels to AREA 0 and
then configure 'area 46 range x.x.x.x' on both sw1 & R4'.

At this point, you will see two routes for each of the loopbacks on each
device, then use a distribute-list to filter out the /32 route.

This is the result I got from labbing it between two routers...

***Caution! rather too lengthy***

R3640-R2#
interface Tunnel1
 ip unnumbered Loopback0
 ip ospf 1 area 0
 tunnel source 172.16.1.2
 tunnel destination 172.16.1.3
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface Serial0/1
 ip address 172.16.1.2 255.255.255.0
!
router ospf 1
 area 46 range 2.2.2.0 255.255.255.0
 network 2.2.2.0 0.0.0.255 area 46
 network 172.16.1.0 0.0.0.255 area 46
 distribute-list prefix 2 in
!
ip prefix-list 2 seq 5 deny 3.3.3.3/32
ip prefix-list 2 seq 10 permit 0.0.0.0/0 le 32

R3725-R3#
!
interface Tunnel1
 ip unnumbered Loopback0
 ip ospf 1 area 0
 tunnel source 172.16.1.3
 tunnel destination 172.16.1.2
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!
interface Serial0/0
 ip address 172.26.1.3 255.255.255.0
!
router ospf 1
 area 46 range 3.3.3.0 255.255.255.0
 network 3.3.3.0 0.0.0.255 area 46
 network 172.16.1.0 0.0.0.255 area 46
 distribute-list prefix 2 in
!
ip prefix-list 2 seq 5 deny 2.2.2.2/32
ip prefix-list 2 seq 10 permit 0.0.0.0/0 le 32
!
R3640-R2#sh ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
3.3.3.3 0 FULL/ - 00:00:31 3.3.3.3 Tunnel1
3.3.3.3 0 FULL/ - 00:00:31 172.16.1.3 Serial0/1
R3640-R2#

R3640-R2#sh ip route ospf 1
     3.0.0.0/24 is subnetted, 1 subnets
O IA 3.3.3.0 [110/11112] via 3.3.3.3, 00:00:50, Tunnel1
R3640-R2#

------
R3725-R3#sh ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ - 00:00:31 2.2.2.2 Tunnel1
2.2.2.2 0 FULL/ - 00:00:31 172.16.1.2 Serial0/1
R3725-R3#

R3725-R3#sh ip route ospf 1
     2.0.0.0/24 is subnetted, 1 subnets
O IA 2.2.2.0 [110/11112] via 2.2.2.2, 00:02:07, Tunnel1
R3725-R3#

HTH

Godswill Oletu
CCIE #16464

----- Original Message -----
From: "Arun Arumuganainar" <aarumuga@hotmail.com>
To: "Shi, Bindong" <bindong.shi@siemens.com>; "Sami" <sy1977@gmail.com>;
<ccielab@groupstudy.com>
Sent: Tuesday, July 04, 2006 5:00 AM
Subject: Re: OSPF

> Area Range Command will work only at AS boundaries !!! But both routers
( R4
> and sw1) are in area 46 . This is pottentially the problem here.
>
> Just wondering if there are any other solution !!!!
>
> Thanks and Regards
> Arun
> ----- Original Message -----
> From: "Shi, Bindong" <bindong.shi@siemens.com>
> To: "Sami" <sy1977@gmail.com>; <ccielab@groupstudy.com>
> Sent: Tuesday, July 04, 2006 9:16 AM
> Subject: RE: OSPF
>
>
> > Sami:
> > You can use "area range" to accomplish this.
> >
> >
> > Best Regards,
> > Shi, bindong
> > ........................................................................
> > .......................
> > Siemens Business Services Pte Ltd
> > The Siemens Center
> > 60 MacPherson Road
> > Singapore 348615
> > socsbssgp@siemens.com
> >
> > -----Original Message-----
> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> > Sami
> > Sent: Sunday, July 02, 2006 4:14 AM
> > To: ccielab@groupstudy.com
> > Subject: OSPF
> >
> > Group,
> >
> > R4 and SW1 both in Area 46 , task say make sure both of them see each
> > other loopback as /24 but do not use "ip ospf network" or
> > "redistribution" command for this ?
> >
> > What could be solution for this ?
> >
> > Thanks
> > Sami
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Tue Aug 01 2006 - 07:13:46 ART