RE: Ethernet subinterface

From: Scott Morris (swm@emanon.com)
Date: Wed Jun 28 2006 - 14:35:50 ART


What are you running this on? Shouldn't be a problem:
 
IPexpert-R8(config)#int fa0/0
IPexpert-R8(config-if)#no shut
*Jun 28 17:29:35.260: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed
state to up
*Jun 28 17:29:36.260: %LINEPROTO-5-UPDOWN: Line protocol on Interface
FastEthernet0/0, changed state to up
IPexpert-R8(config-if)#int fa0/0.1
IPexpert-R8(config-subif)#encap dot 1
IPexpert-R8(config-subif)#ip addr 10.10.1.1 255.255.255.0
IPexpert-R8(config-subif)#int fa0/0.188
IPexpert-R8(config-subif)#encap dot 188
IPexpert-R8(config-subif)#ip addr 10.10.188.1 255.255.255.0
IPexpert-R8(config-subif)#exit
IPexpert-R8(config)#class-map ICMP_TF
IPexpert-R8(config-cmap)#match access-group 101
IPexpert-R8(config-cmap)#access-list 101 permit icmp any any
IPexpert-R8(config)#class-map match-all VOIP
IPexpert-R8(config-cmap)#match protocol rtp
IPexpert-R8(config)#access-list 102 permit udp any any range 16384 32767
dscp ef
IPexpert-R8(config-pmap)#policy-map 64KVOIP
IPexpert-R8(config-pmap)#class VOIP
IPexpert-R8(config-pmap-c)#priority 64
IPexpert-R8(config-pmap-c)#exit
IPexpert-R8(config)#policy-map shape
IPexpert-R8(config-pmap)#class class-default
IPexpert-R8(config-pmap-c)#shape average 30000000
IPexpert-R8(config-pmap-c)#service-policy 64KVOIP
IPexpert-R8(config-pmap-c)#exit
IPexpert-R8(config-pmap)#exit
IPexpert-R8(config)#int fa0/0.188
IPexpert-R8(config-subif)#service-policy output shape
IPexpert-R8(config-subif)#exit
IPexpert-R8(config)#
IPexpert-R8(config)#
IPexpert-R8(config)#
IPexpert-R8(config)#
IPexpert-R8(config)#
IPexpert-R8(config)#policy-map shape
IPexpert-R8(config-pmap)#class ICMP_TF
IPexpert-R8(config-pmap-c)#police cir 16000
IPexpert-R8(config-pmap-c-police)#exit
IPexpert-R8(config-pmap-c)#exit
IPexpert-R8(config-pmap)#exit
IPexpert-R8(config)#exit
*Jun 28 17:37:46.016: %SYS-5-CONFIG_I: Configured from console by console

IPexpert-R8#show policy-map
  Policy Map 64KVOIP
    Class VOIP
      Strict Priority
      Bandwidth 64 (kbps) Burst 1600 (Bytes)
 
  Policy Map shape
    Class ICMP_TF
     police cir 16000 bc 1500
       conform-action transmit
       exceed-action drop
    Class class-default
      Traffic Shaping
         Average Rate Traffic Shaping
         CIR 30000000 (bps) Max. Buffers Limit 1000 (Packets)
      service-policy 64KVOIP
 
IPexpert-R8#
 
IPexpert-R8#show policy-map int fa0/0.188
 FastEthernet0/0.188
 
  Service-policy output: shape
 
    Class-map: ICMP_TF (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group 101
      police:
          cir 16000 bps, bc 1500 bytes
        conformed 0 packets, 0 bytes; actions:
          transmit
        exceeded 0 packets, 0 bytes; actions:
          drop
        conformed 0 bps, exceed 0 bps
 
    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
      Traffic Shaping
           Target/Average Byte Sustain Excess Interval Increment
             Rate Limit bits/int bits/int (ms) (bytes)
         30000000/30000000 187500 750000 750000 25 93750
 
        Adapt Queue Packets Bytes Packets Bytes Shaping
        Active Depth Delayed Delayed Active
        - 0 0 0 0 0 no
 
      Service-policy : 64KVOIP
 
        Class-map: VOIP (match-all)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: protocol rtp
          Match: access-group 102
          Queueing
            Strict Priority
            Output Queue: Conversation 264
            Bandwidth 64 (kbps) Burst 1600 (Bytes)
            (pkts matched/bytes matched) 0/0
            (total drops/bytes drops) 0/0
 
        Class-map: class-default (match-any)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any
IPexpert-R8#
 
HTH,
 
 
Scott Morris, CCIE4 (R&S/ISP-Dial/Security/Service Provider) #4713, JNCIE
#153, CISSP, et al.
CCSI/JNCI
IPExpert CCIE Program Manager
IPExpert Sr. Technical Instructor
smorris@ipexpert.com
http://www.ipexpert.com
 

  _____

From: Sami [mailto:sy1977@gmail.com]
Sent: Wednesday, June 28, 2006 1:20 PM
To: swm@emanon.com
Cc: Cisco certification
Subject: Re: Ethernet subinterface

Thanks Scott
 
Just noticed if shaping is enabled on default class but I want to police
another class in this case ICMP to 16K , it doesn't allow.
 
Can't we combine shaping and polcing ?
 
policy-map shape
 class ICMP_TF
 class class-default
  shape average 3000000
  service-policy 64KVOIP
 
R5(config-pmap)#class ICMP_TF
R5(config-pmap-c)#police cir 16000
Output rate-limit already configured, police not allowed
 
Thanks
Sami
 
On 6/28/06, Scott Morris <swm@emanon.com> wrote:

Subinterfaces do not have queues associated with them. You'll need to do a
nested policy to initiate shaping first (creating a queue), the initiate
queuing.

policy-map 64KVOIP
class VOIP
priority 64

policy-map shape
class class-default
shape average 3000000
service-policy 64KVOIP

Int fa0/0.1
service-policy output shape

HTH,

Scott Morris, CCIE4 (R&S/ISP-Dial/Security/Service Provider) #4713, JNCIE
#153, CISSP, et al.
CCSI/JNCI
IPExpert CCIE Program Manager
IPExpert Sr. Technical Instructor
smorris@ipexpert.com
http://www.ipexpert.com

-----Original Message-----
From: nobody@groupstudy.com [mailto: nobody@groupstudy.com
<mailto:nobody@groupstudy.com> ] On Behalf Of Sami
Sent: Wednesday, June 28, 2006 12:48 PM
To: Cisco certification
Subject: Ethernet subinterface

Group,

While doing some QoS stuff , Router complains it can't apply service policy
to subinterfaces.

Is MQC not supported on subinterfaces ?

policy-map 64KVOIP
class VOIP
priority 64

policy-map shape
class class-default
shape average 3000000

R5(config-subif)#service-policy output 64KVOIP CBWFQ : Not supported on
subinterfaces

Thanks
Sami



This archive was generated by hypermail 2.1.4 : Sat Jul 01 2006 - 07:57:33 ART