RE: voice prioritizing

From: David Bombal (davidbombal@davidbombal.com)
Date: Mon May 29 2006 - 18:27:18 ART


Hi Jens,

With QOS, a method to differentiate different types of traffic is required.
The best method for this is to mark the DSCP value within the IP TOS field.
The value for voice is normally set to 46 known as Expedited forwarding
(EF). A Cisco IP Phone will mark its traffic with EF by default. All other
network devices then need to trust this value. There are various ways to do
classification - below is an example.

The best way to prioritize voice on the WAN is using Low Latency Queuing
(LLQ). It has a priority queue to make sure that voice is always serviced
first. There are other things to consider though such as packet drops (WRED
is used to prevent this) and serialization delay (LFI is used to prevent
this).

On the LAN there are a few queuing methods, but on a 3550 for example,
Weighted Round Robin (WRR) with expedite queuing is normally used.

I hope this helps - see below an example config

David Bombal
CCIE (R&S), CCSI, CCIP, CCSP etc
http://www.ConfigureTerminal.com

Catalyst 3550Conditionally-Trusted IP Phone + PC + Scavenger (Basic) Model
Configuration

CAT3550(config)#mls qos map cos-dscp 0 8 16 24 32 46 48 56
! Modifies CoS-to-DSCP mapping to map CoS 5 to DSCP EF
CAT3550(config)#mls qos map policed-dscp 0 24 to 8
! Excess DVLAN & VVLAN traffic will be remarked to Scavenger (CS1)
CAT3550(config)#
CAT3550(config)#
CAT3550(config)#class-map match-all VOICE
CAT3550(config-cmap)# match ip dscp 46 ! DSCP EF (voice)
CAT3550(config-cmap)#class-map match-any CALL SIGNALING ! Need match-any
here
CAT3550(config-cmap)# match ip dscp 26 ! DSCP AF31 (old Call-Signaling)
CAT3550(config-cmap)# match ip dscp 24 ! DSCP CS3 (new Call-Signaling)
CAT3550(config-cmap)#
CAT3550(config-cmap)#class-map match-all VVLAN-VOICE
CAT3550(config-cmap)# match vlan 110 ! VLAN 110 is VVLAN
CAT3550(config-cmap)# match class-map VOICE ! Matches VVLAN DSCP EF
CAT3550(config-cmap)#
CAT3550(config-cmap)#class-map match-all VVLAN-CALL-SIGNALING
CAT3550(config-cmap)# match vlan 110 ! VLAN 110 is VVLAN
CAT3550(config-cmap)# match class-map CALL SIGNALING !Matches VVLAN AF31/CS3
CAT3550(config-cmap)#
CAT3550(config-cmap)#class-map match-all ANY
CAT3550(config-cmap)# match access-group name ANY ! Workaround ACL
CAT3550(config-cmap)#
CAT3550(config-cmap)#class-map match-all VVLAN-ANY
CAT3550(config-cmap)# match vlan 110 ! VLAN 110 is VVLAN
CAT3550(config-cmap)# match class-map ANY ! Matches any other VVLAN traffic
CAT3550(config-cmap)#
CAT3550(config-cmap)#class-map match-all DVLAN-ANY
CAT3550(config-cmap)# match vlan 10 ! VLAN 10 is DVLAN
CAT3550(config-cmap)# match class-map ANY ! Matches all DVLAN traffic
CAT3550(config-cmap)#
CAT3550(config-cmap)#policy-map IPPHONE+PC-BASIC
CAT3550(config-pmap)#class VVLAN-VOICE
CAT3550(config-pmap-c)# set ip dscp 46 ! DSCP EF (Voice)
CAT3550(config-pmap-c)# police 128000 8000 exceed-action drop
! Only one voice call is permitted per switchport VVLAN
CAT3550(config-pmap-c)#class VVLAN-CALL-SIGNALING
CAT3550(config-pmap-c)# set ip dscp 24 ! DSCP CS3 (Call-Signaling)
CAT3550(config-pmap-c)# police 32000 8000 exceed-action
policed-dscp-transmit
! Out-of-profile call signaling is marked down to Scavenger (CS1)
CAT3550(config-pmap-c)#class VVLAN-ANY
CAT3550(config-pmap-c)# set ip dscp 0
CAT3550(config-pmap-c)# police 32000 8000 exceed-action
policed-dscp-transmit
! Unauthorized VVLAN traffic is marked down to Scavenger (CS1)
CAT3550(config-pmap-c)#class DVLAN-ANY
CAT3550(config-pmap-c)# set ip dscp 0
CAT3550(config-pmap-c)# police 5000000 8000 exceed-action
policed-dscp-transmit
! Out-of-profile data traffic is marked down to Scavenger (CS1)
CAT3550(config-pmap-c)# exit
CAT3550(config-pmap)#exit
CAT3550(config)#
CAT3550(config)#interface FastEthernet0/1
CAT3550(config-if)# switchport access vlan 10 ! DVLAN
CAT3550(config-if)# switchport voice vlan 110 ! VVLAN
CAT3550(config-if)# mls qos trust device cisco-phone ! Conditional Trust
CAT3550(config-if)# service-policy input IPPHONE+PC-BASIC ! Attaches policy
CAT3550(config-if)#exit
CAT3550(config)#

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of Jens
Petter
Sent: 29 May 2006 16:29
To: ccielab@groupstudy.com
Subject: voice prioritizing

Hi group...

 

What are the best method to prioritize voice traffic over a wan...

 

Say this is the topology :

 

 

Switch-----router-(router-(wan)---router)----router-------switch

 

 

We have tree classes, voice-interactive and default. I am going to classify
the interactive traffic based on ip range and port.

So what I am trying to deside on is what the best method to classify the
voice traffic is going to be.. I am trying to decide both what to do on the
switches and also in the wan.

 

 

I know this is a basic Q, but I am not that familiar with QoS and need this
help now.

 

Let me know if you guys need more info about this

 

Thanks in advance



This archive was generated by hypermail 2.1.4 : Thu Jun 01 2006 - 06:33:22 ART