RE: FR DE

From: Marius Venter (marius@aict.co.za)
Date: Fri May 26 2006 - 03:05:48 ART


You now have traffic marked as DE=1 but the routers will still drop DE=0 as
the default behavior of the router is to IGNORE DE=1

Here is the configs I would have used

This was not labbed so please treat it as such

R4-----------------Frame Relay-------------------R5
10.1.1.4 405 504 10.1.1.5
Int S1/0 Int S1/0

Config

Use this link to understand the commands

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guid
e09186a0080087b91.html

R4

map-class frame-relay FRTS
 frame-relay adaptive-shaping foresight
 frame-relay adaptive-shaping interface-congestion
 service-policy output MYPOLICY

class-map match-any DE_1
  match not access-group 100
  match any

policy-map MYPOLICY
  class DE_1
   set fr-de

interface Serial1/0
 ip address 10.1.1.4 255.255.255.0
 encapsulation frame-relay
 no fair-queue
 frame-relay traffic-shaping
 frame-relay interface-dlci 405
  class FRTS
 frame-relay lmi-type cisco
end

access-list 100 permit TCP any any eq 80

R5

map-class frame-relay FRTS
 frame-relay adaptive-shaping foresight
 frame-relay adaptive-shaping interface-congestion
 service-policy output MYPOLICY

class-map match-any DE_1
  match not access-group 100
  match any

policy-map MYPOLICY
  class DE_1
   set fr-de

interface Serial1/0
 ip address 10.1.1.5 255.255.255.0
 encapsulation frame-relay
 no fair-queue
 frame-relay traffic-shaping
 frame-relay interface-dlci 405
  class FRTS
 frame-relay lmi-type cisco
end

access-list 100 permit TCP any any eq 80

Marius Venter

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Faryar Zabihi (fzabihi)
Sent: Friday, May 26, 2006 4:42 AM
To: ccielab@groupstudy.com
Subject: FR DE

 If I have a frame-relay connection from R1 to R2 and want to make sure
HTTP traffic is not DiscardElgible or discarded,
Would I?

!
 class-map match-all NOT_WEB
  match access-group 101
!
!
 policy-map SET_DE
  class NOT_WEB
   set fr-de

access-list 101 deny tcp any any eq www
access-list 101 permit ip any any

Ints0/0
service-policy output SET_DE

Thanks in advance,

 Faryar



This archive was generated by hypermail 2.1.4 : Thu Jun 01 2006 - 06:33:22 ART