RE: iBGP doesn't peer if the only route is 0.0.0.0 ?

From: Brian McGahan (bmcgahan@internetworkexpert.com)
Date: Mon May 08 2006 - 13:39:54 ART


        Having only a default route does not prevent a BGP neighbor from
peering, it only prevents the neighbor from *initiating* BGP peering.
Since BGP uses TCP for transport it uses the same client/server model
that TCP does. The TCP client initiates the BGP session with a TCP SYN
going to port 179. The TCP server replies with a SYN ACK with a source
port of 179. The client replies with an ACK going to port 179 and the
session is open. In order to initiate the first SYN the client must
have a longer match than /0, such as below, however the server does not:

R1:
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.1 255.0.0.0
!
router bgp 1
 neighbor 2.2.2.2 remote-as 1
 neighbor 2.2.2.2 update-source Loopback0
!
ip route 2.2.2.2 255.255.255.255 10.0.0.2

R2:
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.2 255.0.0.0
!
router bgp 1
 neighbor 1.1.1.1 remote-as 1
!
ip route 0.0.0.0 0.0.0.0 10.0.0.1

R1#debug ip packet detail
IP packet debugging is on (detailed)
IP: tableid=0, s=1.1.1.1 (local), d=2.2.2.2 (FastEthernet0/0), routed
via RIB

! R1 sends SYN

IP: tableid=0, s=2.2.2.2 (FastEthernet0/0), d=1.1.1.1 (Loopback0),
routed via RIB
IP: s=2.2.2.2 (FastEthernet0/0), d=1.1.1.1, len 44, rcvd 4
    TCP src=179, dst=11006, seq=174134177, ack=3491735978, win=16384 ACK
SYN

! R2 replies with SYN ACK

IP: tableid=0, s=1.1.1.1 (local), d=2.2.2.2 (FastEthernet0/0), routed
via RIB

! R1 replies with ACK, the session is open

R1#show ip bgp summary
BGP router identifier 1.1.1.1, local AS number 1
BGP table version is 1, main routing table version 1

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
State/PfxRcd
2.2.2.2 4 1 15 16 1 0 0 00:01:23
0

HTH,

Brian McGahan, CCIE #8593
bmcgahan@internetworkexpert.com

Internetwork Expert, Inc.
http://www.InternetworkExpert.com
Toll Free: 877-224-8987 x 705
Outside US: 775-826-4344 x 705
24/7 Support: http://forum.internetworkexpert.com
Live Chat: http://www.internetworkexpert.com/chat/

> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
Of
> Schulz, Dave
> Sent: Monday, May 08, 2006 9:44 AM
> To: johngibson1541@yahoo.com; ccielab@groupstudy.com
> Subject: RE: iBGP doesn't peer if the only route is 0.0.0.0 ?
>
> John - Are you able to ping the address that you are trying to peer
> with? And, are you able to do it from remote back to yourself?
>
>
> Dave Schulz
> Email: dschulz@dpsciences.com
>
>
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
Of
> johngibson1541@yahoo.com
> Sent: Monday, May 08, 2006 12:13 AM
> To: ccielab@groupstudy.com
> Subject: Re: iBGP doesn't peer if the only route is 0.0.0.0 ?
>
> I have verified this,
>
> -------------------------------------------
> If the only route to an iBGP peer's peering
> address (usually the loopback) is 0.0.0.0 ,
> it doesn't peer!
> -------------------------------------------
>
> Notice: univercd only says this is a problem
> for eBGP, but it is a problem for iBGP as well.
>
> John
>
>



This archive was generated by hypermail 2.1.4 : Thu Jun 01 2006 - 06:33:21 ART