Re: QoS/Class MAP

From: Chris Lewis (chrlewiscsco@gmail.com)
Date: Sat Mar 04 2006 - 11:08:27 GMT-3


As I said with my example, it is not the only way to do it.

Chris

On 3/3/06, imam@intikom.co.id <imam@intikom.co.id> wrote:
>
>
> ..so how about if service policy output applied on map- class like this
>
>
> interface Serial2/0.1 point-to-point
> ip address 12.12.12.1 255.255.255.0
> frame-relay interface-dlci 144
> Class Parent
>
> map- class frame-relay Parent
> service policy output Parrent
>
>
> because same time there are traffic want to fragment you can doit in map-
> class
>
>
>
>
>
>
> *"Chris Lewis" <chrlewiscsco@gmail.com>*
> Sent by: nobody@groupstudy.com
>
> 03/04/2006 11:12 AM
> Please respond to "Chris Lewis"
>
> To: KC <kanwal.chawla@gmail.com>
> cc: sameer.azam@gmail.com, ccielab@groupstudy.com
> Subject: Re: QoS/Class MAP
>
>
>
>
>
> OK,
>
> Configure this and experiment with it, it is not the only way to do it.
>
> class-map match-all decnet
> match protocol decnet
> class-map match-all bridge
> !
> policy-map child
> class bridge
> bandwidth percent 20
> class decnet
> bandwidth percent 30
> policy-map parent
> class class-default
> shape average percent 100
> service-policy child
> !
> interface Serial2/0
> ip address 10.1.1.1 255.255.255.0
> encapsulation frame-relay
> serial restart-delay 0
> frame-relay map ip 10.1.1.3 133
> frame-relay map ip 10.1.1.12 122
> !
> interface Serial2/0.1 point-to-point
> ip address 12.12.12.1 255.255.255.0
> frame-relay interface-dlci 144
> service-policy output parent
> !
>
> Router1(config-subif)#do sho policy-map int
> Serial2/0.1
>
> Service-policy output: parent
>
> Class-map: class-default (match-any)
> 4 packets, 1380 bytes
> 5 minute offered rate 0 bps, drop rate 0 bps
> Match: any
> Traffic Shaping
> Target/Average Byte Sustain Excess Interval Increment
> Rate Limit bits/int bits/int (ms) (bytes)
> 100 (%) 0 (ms) 0 (ms)
> 1544000/1544000 9650 38600 38600 25 4825
>
> Adapt Queue Packets Bytes Packets Bytes Shaping
> Active Depth Delayed Delayed Active
> - 0 4 1380 0 0 no
>
> Service-policy : child
>
> Class-map: bridge (match-all)
> 0 packets, 0 bytes
> 5 minute offered rate 0 bps, drop rate 0 bps
> Match: protocol bridge
> Queueing
> Output Queue: Conversation 73
> Bandwidth 20 (%)
> Bandwidth 308 (kbps) Max Threshold 64 (packets)
> (pkts matched/bytes matched) 0/0
> (depth/total drops/no-buffer drops) 0/0/0
>
> Class-map: decnet (match-all)
> 0 packets, 0 bytes
> 5 minute offered rate 0 bps, drop rate 0 bps
> Match: protocol decnet
> Queueing
> Output Queue: Conversation 74
> Bandwidth 30 (%)
> Bandwidth 463 (kbps) Max Threshold 64 (packets)
> (pkts matched/bytes matched) 0/0
> (depth/total drops/no-buffer drops) 0/0/0
>
> Class-map: class-default (match-any)
> 4 packets, 1380 bytes
> 5 minute offered rate 0 bps, drop rate 0 bps
> Match: any
> Router1(config-subif)#
> This shows shaping to 100% of interface bandwidth, and allocating
> bandwidth
> to classes on a sub-interface.
>
> Chris
>
> On 3/2/06, KC <kanwal.chawla@gmail.com> wrote:
> >
> > Chris,
> >
> > Can u tell the commands and syntax on this please. because i want to
> clear
> > my confusion
> >
> > Regards
> > KC
> >
> >
> > On 3/2/06, Chris Lewis <chrlewiscsco@gmail.com> wrote:
> > >
> > > Please see my previous reply to Sameer. To allocate bandwidth on a
> > > sub-interface requires a shaping policy be applied to the
> sub-interface
> with
> > > a nested child policy under the shaping policy to assign the
> bandwidth.
> > >
> > > Chris
> > >
> > >
> > > On 3/1/06, KC <kanwal.chawla@gmail.com > wrote:
> > > >
> > > > Hi Sameer
> > > >
> > > > I read your question and i am sure that if you are using CBWFQ with
> > > > the
> > > > Bandwidth command in Class-map , it will not show you on
> subinterface,
> > > >
> > > > because the reason is CBWFQ is not supported on Sub Interfaces.
> > > >
> > > > Tell me buddies , if i am wrong ??
> > > >
> > > >
> > > > On 2/28/06, sameer.azam@gmail.com < sameer.azam@gmail.com> wrote:
> > > > >
> > > > > Hi,
> > > > > I have a router with 2 FastEthernet Interfaces
> > > > > F0/0 & F0/1.
> > > > >
> > > > > F0/0 is directly connected with some other router.
> > > > > &
> > > > > F0/1 is subdidided in to 2 more Sub interface
> > > > >
> > > > > F0/1.1---- connected with R5.
> > > > > F0/1.2---- Connected with R6
> > > > >
> > > > > Now i need to make a class-map so that all the traffic that comes
> on
> > > > the
> > > > > F0/1.1 or all the traffic comming from R5 should be limited to
> 2Mb.
> > > > >
> > > > > and the policy-map i can only apply to the F0/0 ( as this is the
> > > > part of
> > > > > the Question which i can't change).
> > > > >
> > > > > Now there is a option with the class-map that is
> > > > >
> > > > > match input-interface
> > > > > so if i use this option i can simply select the input interface as
> > > > F0/1.1
> > > > > BUT
> > > > > the problem is when i see the running config i see
> > > > > CLASS-MAP match-all From_R5
> > > > > match input-interface FastEthernet0/1------> instead if
> > > > FastEthernet0/1.1
> > > > >
> > > > >
> > > > > So any idea about this problem or is there any other way to solve
> > > > this
> > > > > proble,.
> > > > >
> > > > > Regards
> > > > >
> > > > >
> > > >
> _______________________________________________________________________
> > > > > Subscription information may be found at:
> > > > > http://www.groupstudy.com/list/CCIELab.html
> > > >
> > > >
> > > >
> _______________________________________________________________________
> > > > Subscription information may be found at:
> > > > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Sat Apr 01 2006 - 10:07:38 GMT-3