From: Jens Petter Eikeland (jenseike@start.no)
Date: Sun Feb 12 2006 - 09:44:41 GMT-3
hi....
i am trying to shape per ip addres, and some times per ip range, so you are
correct... My question was not really if I should use shaping or policing. I
think in my case
that shaping on the outbound interface since this is a ethernet is the best
solution, and for the traffic inbound to customer I will also do outbound
shaping on the interface... this is a fastethernet interface with 100Mb
speed....
This was not really my Question I wanted to get answered though. My question
was really about what is the best method to set this up.. If I needed to make
a class in the policy for each ip address, or if I could make one policy map
for each rate that I am going to shape to, and then make a nested policy of
them... I was also asking how
I configured this nested policy in, and how the shaping (or queeue) will be
handled when using a nested policy
For discussion about using policing and shaping, I have got so many diferent
opinion on this that I am going to test it out in the IOS to find what will
work best for me my selfe... I have read a lot about this, and have an idea
about the difference and what to use.
So, if somebody could help me tell me how I can make a nested policy map, and
tell me how this would handel the outbound queue, that is what I am looking
for.... Also some tips if somebody knows of a better way to do this...
Thanks
JP
----- Original Message -----
From: Venkatesh Palani
To: Jens Petter Eikeland
Cc: ccielab@groupstudy.com
Sent: Sunday, February 12, 2006 2:59 AM
Subject: Re: order of operation
Hi Jens,
From you post I understand you are trying to shape per IP address ( correct
me If I am wrong). I am not sure what is ur topology, this looks more like
that of a Service provider environment where you want to shape per customer if
that is the case I woudl say do policing rather than shapping as close to the
customer (becasue as for as I could remember Shapping is not possible on the
Input ), meaning on their first entry into ur network. If this wont help you
give more information on ur topology, there are also other ways for you to
acheive QOS in the network that is using DSCP or IP pref markings to shape
them, any way this wont help you to acheive per IP address but will help you
to acheive per class. If this is just for a example and for understanding then
have you tried the above config on a router ?.
Thank you,
Venkatesh
On 2/12/06, Jens Petter Eikeland <jenseike@start.no> wrote:
I am setting up some shaping for diffrent group of classes...
I have several classes that are shaped to different values. my question is
what would be the more correct method to configure this...
My goal is to give the different access-groups restricted rate to the
outbound
link of
my fastethernet... I have some that needs 512 kbps and some that need 1024
kbps
I have problems seeing how this method differs, and how that output queue
would work for
each of the two different methods
my first example I have made a class that matches any, and the statement
in
there
is the different access-list match. then I make a policy for 512kbs and
one
for 1024 kbs
that I nest at the end in to a nested policy :
ip access-list extended set_to_512kbs-1
permit ip host 213.162.225.31 any
permit ip any host 213.162.225.31
ip access-list extended set_to_512kbs-2
permit ip host 213.162.225.32 any
permit ip any host 213.162.225.32
ip access-list extended set_to_1024kbs-1
permit ip host 213.162.224.41 any
permit ip any host 213.162.224.41
ip access-list extended set_to_1024kbs-2
permit ip host 213.162.224.42 any
permit ip any host 213..162.224.43
class-map match-any 512kbs
match access-group set_to_512kbs-1
match access-group set_to_512kbs-2
class-map match-any 1024kbs
match access-group set_to_1024kbs-1
match access-group set_to_1024kbs-2
class-map match-any 512kbs
match access-group set_to_512kbs-1
match access-group set_to_512kbs-2
class-map match-any 1024kbs
match access-group set_to_1024kbs-1
match access-group set_to_1024kbs-2
policy-map 512kbs
class 512kbs
shape 512000
policy-map 1024kbs
class 1024kbs
shape 1024000
policy-map SHAPE_OUT (nested)
policy-map 512kbs
policy-map 1024kbs
In my second example I have made a different class for each access-list
and
then set the shape command
on the different classes in one policy map
ip access-list extended set_to_512kbs-1
permit ip host 213.162.225.31 any
permit ip any host 213.162.225.31
ip access-list extended set_to_512kbs-
permit ip host 213.162.225.32 any
permit ip any host 213.162.225.32
ip access-list extended set_to_1024kbs-1
permit ip host 213.162.224.41 any
permit ip any host 213.162.224.41
ip access-list extended set_to_1024kbs-2
permit ip host 213.162.224.42 any
permit ip any host 213..162.224.43
class-map 512kbs-1
match access-group set_to_512kbs-1
class-map 512kbs-2
match access-group set_to_512kbs-2
class-map 1024kbs-1
match access-group set_to_1024kbs-1
class-map 1024kbs-2
match access-group set_to_1024kbs-2
policy-map SHAPE_OUT
class 512kbs-1
shape 512
class 512kbs-2
shape 512
class 1024kbs-1
shape 1024
class 1024kbs-2
shape 1024
second, say I had 512, 1024 and 2048 as the different rates, and I have
many
more ip-addresses
that need to have this different speeds. I am looing for a better way to
makingthis policies and configuring
this without doing so much config. f eks I could make a policy called
GOLD
(2048), one called
SILVER(1024), and one called BRONSE(512).. many ip adresses shoul match to
all
of this..
how could I best make the configuration so that it would be easies to
manage
for me? All of this is
happening on one interface...how would this be easiest to manage when I
need
to put in new access-list
to match as times go (new customers)
sorry for the length of this post, but I hope somwone can help me
though...
especially with the first problem..
thanks
jens petter
_______________________________________________________________________
Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Wed Mar 01 2006 - 11:28:17 GMT-3