RE: OT GLBP with 2 ISP's

From: Chris Cole (CCole@EPLUS.com)
Date: Sat Feb 04 2006 - 12:24:10 GMT-3


Yes, I have been messing around with it after my post and I found that
when you unplug or shut down either the LAN or WAN interface. The
convergence times of the host that are using the gateway vary. If a host
is pointing to a gateway that has a failed state on the WAN side it will
converge in like a few pings. If that same gateway has it's LAN side
shutdown, depending on if it is the AVG or not the ping time out vary
greatly. I changed the forward preempt delay to "5". I am running a IGBP
between both routers. This help's when the interface come backup.

Debbie, Thanks for you post.

<----------SNIP--------->
!
track 1 interface FastEthernet0/1 ip routing
!
track 2 interface FastEthernet0/0 ip routing
!
track 3 interface FastEthernet0/1 line-protocol
!
track 4 interface FastEthernet0/0 line-protocol
!
interface FastEthernet0/0
 description Connection to Remote LAN Side
 ip address 10.10.10.2 255.255.255.0
 duplex auto
 speed auto
 glbp 10 ip 10.10.10.1
 glbp 10 timers 1 3
 glbp 10 timers redirect 5 605
 glbp 10 preempt delay minimum 5
 glbp 10 weighting 100 lower 90
 glbp 10 weighting track 1 decrement 10
 glbp 10 weighting track 2 decrement 10
 glbp 10 weighting track 3 decrement 10
 glbp 10 weighting track 4 decrement 10
 glbp 10 forwarder preempt delay minimum 5
!
!
interface FastEthernet0/1
 description Connection to Remote WAN side
 ip address 200.1.10.2 255.255.255.0
 duplex auto
 speed auto
!
router bgp 65020
 no synchronization
 bgp log-neighbor-changes
 network 200.1.10.0
 redistribute connected
 neighbor 10.10.10.3 remote-as 65020
 neighbor 200.1.10.1 remote-as 65001
 no auto-summary
!
<---------END-SNIP------------->
-----Original Message-----
From: Debbie Westall [mailto:dwestall@debbie.coxfiber.net]
Sent: Friday, February 03, 2006 10:14 PM
To: Chris Cole
Cc: ccielab@groupstudy.com
Subject: Re: OT GLBP with 2 ISP's

Chris,

Here is a working GLBP config. I have changed the IP addresses to
private
nets for security reasons.
!
These routers are on the same LAN, 2 different ISPs to the Internet,
both
routers running BGP.
!
ROUTER A
interface FastEthernet0/0
  description Link to xxx
  ip address 192.168.63.1 255.255.255.0
  speed 10
  half-duplex
  glbp 10 ip 192.168.63.254
  glbp 10 priority 254
  glbp 10 preempt delay minimum 7
  glbp 10 weighting 100 lower 95
  glbp 10 authentication text xxx10
  glbp 10 weighting track 2 decrement 20
  glbp 10 forwarder preempt delay minimum 7
!
interface Serial0/0
  description Link to xxx
  ip address 192.168.1.1 255.255.255.252
  no fair-queue
!
interface FastEthernet0/1
  no ip address
  shutdown
  duplex auto
  speed auto
!
router bgp xxx
  no synchronization
  bgp log-neighbor-changes
  network 192.168.63.0
  neighbor 192.168.63.2 remote-as xxx
  neighbor 192.168.63.2 route-reflector-client
  neighbor 192.168.63.2 next-hop-self
  neighbor 192.168.63.2 soft-reconfiguration inbound
  no auto-summary
!
ROUTER B
interface Fastethernet0/0
ip address 192.168.63.2 255.255.255.0
  speed 100
  full-duplex
  no cdp enable
  glbp 10 ip 192.168.63.254
  glbp 10 preempt delay minimum 7
  glbp 10 weighting 100 lower 95
  glbp 10 authentication text xxx10
  glbp 10 weighting track 2 decrement 20
  glbp 10 forwarder preempt delay minimum 7
!
interface Serial0/0
  description xxx T-1 CONNECTION
  ip address 192.168.60.206 255.255.255.252
  encapsulation ppp
  fair-queue 256 256 0
  service-module t1 timeslots 1-24
!
router bgp xxx
  no synchronization
  bgp log-neighbor-changes
  network 192.168.63.0
  neighbor 192.168.60.205 remote-as xxx
  neighbor 192.168.60.205 route-map xxx out
  neighbor 192.168.63.1 remote-as xxxx
  neighbor 192.168.63.1 soft-reconfiguration inbound
  no auto-summary
!

On Tue, 31 Jan 2006, Chris Cole wrote:

> Hello all, has any one used GLBP with two ISP's. I have been looking
for
> an good example, I have not found one yet. If any one has dealt with
> this? I have not used GLBP before so just putting out the feelers.
>
>
>
>
>
> Basically I have a remote site connected to two ISP's it's a MPLS WAN
> for both ISP's.
>
> Remote sites have two routers one for each ISP connection.
>
> Two data centers, each with a connection to both ISP's
>
> The LAN side is a flat segment with no layer 3 switch (I know).
>
>
>
> Thanks for any input.
>
>
>
>
>
> Chris Cole
>
> Senior Network Engineer
>
> CCIE# 10561 R&S
> ePlus Technology, an ePlus Company
> 13595 Dulles Technology Drive
> Herndon, Virginia 20171
> (703) 984-8031 (office)
> (703) 675-3029 (cell)
> ccole@eplus.com <mailto:ccole@eplus.com>
> www.eplus.com <http://www.eplus.com>
>
> THE INFORMATION CONTAINED IN THIS ELECTRONIC TRANSMISSION AND ANY
> ATTACHMENTS HERETO IS CONSIDERED PROPRIETARY AND CONFIDENTIAL.
> DISTRIBUTION OF THIS MATERIAL TO ANYONE OTHER THAN THE ADDRESSED IS
> PROHIBITED. ANY DISCLOSURE, COPYING, DISTRIBUTION OR USE OF THE
CONTENTS
> OF THIS TRANSMISSION OR ANY ATTACHMENTS HERETO FOR ANY REASON OTHER
THAN
> THEIR INTENDED PURPOSE IS PROHIBITED. IF YOU HAVE RECEIVED THIS
> TRANSMISSION IN ERROR, PLEASE CONTACT THE SENDER
>
>



This archive was generated by hypermail 2.1.4 : Wed Mar 01 2006 - 11:28:17 GMT-3