From: Brian Dennis (bdennis@internetworkexpert.com)
Date: Fri Feb 03 2006 - 18:56:42 GMT-3
Look at the issue from a different angle. You are routing protocol
developer and are tasked with developing a solution using OSPF to solve
the problem with spoke to spoke reachability in a Frame Relay network.
Here are the given requirements:
1) All routers must be on the same logical IP subnet
2) All routers do not have direct layer 2 connectivity to each other
(aka hub and spoke)
3) All routers must use only their physical interfaces
4) Do not require N+1 "frame-relay map" statements on the spokes where N
= number of spokes
Now develop a solution using OSPF that will allow for spoke-to-spoke
reachability while at the same time met the given requirements.
Solution:
You develop the OSPF point-to-multipoint network type.
As a side note the point-to-multipoint OSPF network type was implemented
roughly around the same time subinterfaces were first supported in the
IOS. This is the reason for the 3rd requirement.
HTH,
Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
bdennis@internetworkexpert.com
Internetwork Expert, Inc.
http://www.InternetworkExpert.com
Toll Free: 877-224-8987
Direct: 775-745-6404 (Outside the US and Canada)
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
siegfried.droogmans@skynet.be
Sent: Friday, February 03, 2006 4:14 AM
To: ccielab@groupstudy.com
Subject: ospf network type & FR
Hi,
can someone explain following behaviour:
R2 is Hub
R4, R5 are spokes
only physical ports allowed
Hub ospf network type is PTMP
If I use OSPF network PTP on spokes I can NOT ping other spokes. (CASE
1)
If I use OSPF network PTMP on spokes I CAN ping other spokes. (CASE 2)
Is this expected behaviour? I wouldn't expect the 'ip ospf network'
command to have influence on icmp connectivity.
CASE1:
------
R4(config-router)#
router ospf 1
log-adjacency-changes
network 150.50.100.0 0.0.0.255 area 0
network 200.0.0.0 0.0.0.255 area 0
interface Serial0/0/0
ip address 150.50.100.4 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-point
frame-relay map ip 150.50.100.2 401 broadcast
no frame-relay inverse-arp
R5(config-router)#
router ospf 1
log-adjacency-changes
network 150.50.100.0 0.0.0.255 area 0
interface Serial0/1/0
ip address 150.50.100.5 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-point
frame-relay map ip 150.50.100.2 501 broadcast
no frame-relay inverse-arp
R2(config-router)#
router ospf 1
log-adjacency-changes
network 150.50.100.0 0.0.0.255 area 0
interface Serial0/1/0
ip address 150.50.100.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
ip ospf hello-interval 10
frame-relay map ip 150.50.100.4 104 broadcast
frame-relay map ip 150.50.100.5 105 broadcast
no frame-relay inverse-arp
end
R2(config-if)#do sfm
Serial0/1/0 (up): ip 150.50.100.4 dlci 104(0x68,0x1880), static,
broadcast,
CISCO, status defined, active
Serial0/1/0 (up): ip 150.50.100.5 dlci 105(0x69,0x1890), static,
broadcast,
CISCO, status defined, active
R4(config-if)#do sfm
Serial0/0/0 (up): ip 150.50.100.2 dlci 401(0x191,0x6410), static,
broadcast,
CISCO, status defined, active
R5(config-if)#do sfm
Serial0/1/0 (up): ip 150.50.100.2 dlci 501(0x1F5,0x7C50), static,
broadcast,
CISCO, status defined, active
R5(config-if)#do ping 150.50.100.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.50.100.4, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
CASE 2:
-------
R4(config-if)#
router ospf 1
log-adjacency-changes
network 150.50.100.0 0.0.0.255 area 0
network 200.0.0.0 0.0.0.255 area 0
interface Serial0/0/0
ip address 150.50.100.4 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
frame-relay map ip 150.50.100.2 401 broadcast
no frame-relay inverse-arp
R5(config-if)#
router ospf 1
log-adjacency-changes
network 150.50.100.0 0.0.0.255 area 0
interface Serial0/1/0
ip address 150.50.100.5 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
frame-relay map ip 150.50.100.2 501 broadcast
no frame-relay inverse-arp
R2(config-if)#
router ospf 1
log-adjacency-changes
network 150.50.100.0 0.0.0.255 area 0
interface Serial0/1/0
ip address 150.50.100.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
frame-relay map ip 150.50.100.4 104 broadcast
frame-relay map ip 150.50.100.5 105 broadcast
no frame-relay inverse-arp
R2(config-if)#do sfm
Serial0/1/0 (up): ip 150.50.100.4 dlci 104(0x68,0x1880), static,
broadcast,
CISCO, status defined, active
Serial0/1/0 (up): ip 150.50.100.5 dlci 105(0x69,0x1890), static,
broadcast,
CISCO, status defined, active
R4(config)#do sfm
Serial0/0/0 (up): ip 150.50.100.2 dlci 401(0x191,0x6410), static,
broadcast,
CISCO, status defined, active
R5(config-if)#do sfm
Serial0/1/0 (up): ip 150.50.100.2 dlci 501(0x1F5,0x7C50), static,
broadcast,
CISCO, status defined, active
R4(config)#do ping 150.50.100.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.50.100.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/19/20 ms
I have rebooted several times.
SW is 12.4(3a) on all routers.
R2 is 3825, R4 and R5 are 2811
cheers,
Siegfried
This archive was generated by hypermail 2.1.4 : Wed Mar 01 2006 - 11:28:17 GMT-3