From: Brian Dennis (bdennis@internetworkexpert.com)
Date: Tue Jan 10 2006 - 20:20:30 GMT-3
You should clear all of the routing tables as there are not any problems
with your configuration other then the fact you have "passive-interface
default" on R4 and in turn do not have any interfaces that are not
passive.
Rack1R1#sho ip rout rip
R 4.0.0.0/8 [120/4] via 172.16.14.4, 00:00:05, Serial0/0
R 40.0.0.0/8 [120/6] via 172.16.14.4, 00:00:05, Serial0/0
R 41.0.0.0/8 [120/2] via 172.16.14.4, 00:00:05, Serial0/0
Rack1R1#
Rack1R4:
interface Loopback0
ip address 4.4.4.4 255.255.255.0
!
interface Loopback1
ip address 40.40.40.40 255.255.255.0
!
interface Ethernet0/0
ip address 41.1.1.1 255.255.255.0
half-duplex
!
interface Serial0/0
ip address 172.16.14.4 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.16.14.1 401 broadcast
frame-relay map ip 172.16.14.4 401
no frame-relay inverse-arp
!
router eigrp 100
network 40.0.0.0
network 41.0.0.0
no auto-summary
!
router rip
redistribute connected route-map LOOP
redistribute eigrp 100 metric 9
network 172.16.0.0
neighbor 172.16.14.1
default-metric 1
no auto-summary
!
access-list 1 permit 40.0.0.0 0.255.255.255
access-list 2 permit 41.1.1.0 0.0.0.255
!
route-map LOOP permit 10
match interface Loopback0
set metric 4
!
route-map LOOP permit 15
match ip address 1
set metric 6
!
route-map LOOP permit 17
match ip address 2
set metric 2
!
route-map LOOP permit 20
Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
bdennis@internetworkexpert.com
Internetwork Expert, Inc.
http://www.InternetworkExpert.com
Toll Free: 877-224-8987
Direct: 775-745-6404 (Outside the US and Canada)
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Schulz, Dave
Sent: Tuesday, January 10, 2006 2:16 PM
To: Cisco certification
Subject: Redistribution issue - and applying different metrics
I have been working on some redistribution in the lab with RIP and
EIGRP. Here is the scenario....
R1 to R4 running RIP. There is link going to a switch that is running
EIGRP. I want to redistribute eigrp into rip and also have connected
routes (loopbacks) redistributed into rip. Here is where it gets a bit
strange. I understand the issues where we have a protocol redistributed
into another protocol and also have connected routes being
redistributed.....however, if I would want to apply different metrics to
different routes, without using an offset-list. I am not sure that this
is possible, but would think that it would using the following
route-map......However, on R1....all the metrics show up as a metric of
4. Strange? Any thoughts?
Here is the route table on R1....
R1#sh ip rou
R 4.0.0.0/8 [120/4] via 172.16.14.4, 00:00:18, Serial0/0.14
172.16.0.0/24 is subnetted, 2 subnets
C 172.16.14.0 is directly connected, Serial0/0.14
C 172.16.123.0 is directly connected, Serial0/0.123
R 40.0.0.0/8 [120/4] via 172.16.14.4, 00:00:18, Serial0/0.14
R 41.0.0.0/8 [120/4] via 172.16.14.4, 00:00:18, Serial0/0.14
R4 config is the key here......
!
interface Loopback0
ip address 4.4.4.4 255.255.255.0
!
interface Loopback1
ip address 40.40.40.40 255.255.255.0
!
interface Ethernet0
ip address 41.1.1.1 255.255.255.0
!
interface Serial0
ip address 172.16.14.4 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.16.14.1 401 broadcast
frame-relay map ip 172.16.14.4 401
no frame-relay inverse-arp
frame-relay lmi-type ansi
!
!
router eigrp 100
network 40.0.0.0
network 41.0.0.0
no auto-summary
!
router rip
redistribute connected route-map LOOP
redistribute eigrp 100 metric 9
passive-interface default
network 172.16.0.0
neighbor 172.16.14.1
default-metric 1
no auto-summary
!
!
access-list 1 permit 40.0.0.0 0.255.255.255
access-list 2 permit 41.1.1.0 0.0.0.255
!
route-map LOOP permit 10
match interface Loopback0
set metric 4
!
route-map LOOP permit 15
match ip address 1
set metric 6
!
route-map LOOP permit 17
match ip address 2
set metric 2
!
route-map LOOP permit 20
!
!
Dave Schulz
Email: dschulz@dpsciences.com <mailto:dschulz@dpsciences.com >
This archive was generated by hypermail 2.1.4 : Wed Feb 01 2006 - 07:45:48 GMT-3