Multicast Problem

From: Prio Utomo (rionaldi@gmail.com)
Date: Tue Jan 10 2006 - 05:49:58 GMT-3


I set 2 routers (r4 & r5) with 2 connections between them (through FR and also
Ethernet), I only enable ip pim sparse mode on the serial ONLY. R4 is the RP,
I join igmp on one of the R4 interface (239.1.1.1)
1. My concept this configuration will not be running due to RPF check since
the routing table will use ethernet due to better metric, but in reallity I
can ping 239.1.1.1 from r5, why?
2. When I sh ip mroute 239.1.1.1 in r5, the group 239.1.1.1 is not found, why
3. seems the r5 is running dense mode based on the mroute, why? I configure
sparse mode.

can anyone explain them to me?

--------------------------
r5#sh runn
Building configuration...

Current configuration : 1025 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 8.8.5.5 255.255.255.0
!
interface Ethernet0/0
 ip address 8.8.54.5 255.255.255.0
 half-duplex
!
interface Serial0/0
 ip address 8.8.45.5 255.255.255.0
 ip pim sparse-mode
 encapsulation frame-relay
 frame-relay map ip 8.8.45.4 504 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
interface Serial0/1
 no ip address
 shutdown
!
router eigrp 100
 network 0.0.0.0
 no auto-summary
!
ip http server
ip classless
!
!
ip pim rp-address 8.8.4.4 10 override
!
access-list 10 permit 239.1.1.1
!
!
!
control-plane
!
!
!
!

r5#sh ip mroute 239.1.1.1
Group 239.1.1.1 not found
r5#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 00:14:54/00:02:08, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0/0, Forward/Sparse, 00:14:54/00:02:08

r5#sh ip pim neigh
PIM Neighbor Table
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
8.8.45.4 Serial0/0 00:24:37/00:01:41 v2 1 / S

r5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static
route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     8.0.0.0/24 is subnetted, 5 subnets
D 8.8.4.0 [90/409600] via 8.8.54.4, 00:28:08, Ethernet0/0
C 8.8.5.0 is directly connected, Loopback0
D 8.8.44.0 [90/409600] via 8.8.54.4, 00:28:08, Ethernet0/0
C 8.8.45.0 is directly connected, Serial0/0
C 8.8.54.0 is directly connected, Ethernet0/0
r5#

------------------------------------------------------------------

r4#sh runn
Building configuration...

Current configuration : 1235 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 8.8.4.4 255.255.255.0
 ip pim sparse-mode
!
interface Loopback1
 ip address 8.8.44.4 255.255.255.0
 ip pim sparse-mode
 ip igmp join-group 239.1.1.1
!
interface Ethernet0/0
 ip address 8.8.54.4 255.255.255.0
 half-duplex
!
interface Serial0/0
 ip address 8.8.45.4 255.255.255.0
 ip pim sparse-mode
 encapsulation frame-relay
 frame-relay map ip 8.8.45.5 405 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 no frame-relay inverse-arp
!
router eigrp 100
 network 0.0.0.0
 no auto-summary
!
no ip http server
ip classless
!
!
ip pim rp-address 8.8.4.4 10 override
!
!
ip access-list standard ovveride
access-list 10 permit 239.1.1.1
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

r4#
r4#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.1.1.1), 00:18:12/00:02:05, RP 8.8.4.4, flags: SJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback1, Forward/Sparse, 00:18:12/00:02:05

(*, 224.0.1.40), 00:18:12/00:02:08, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:18:12/00:02:08

r4#sh ip pim neigh
PIM Neighbor Table
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
8.8.45.5 Serial0/0 00:29:07/00:01:39 v2 1 / DR S

r4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static
route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     8.0.0.0/24 is subnetted, 5 subnets
C 8.8.4.0 is directly connected, Loopback0
D 8.8.5.0 [90/409600] via 8.8.54.5, 00:28:36, Ethernet0/0
C 8.8.44.0 is directly connected, Loopback1
C 8.8.45.0 is directly connected, Serial0/0
C 8.8.54.0 is directly connected, Ethernet0/0



This archive was generated by hypermail 2.1.4 : Wed Feb 01 2006 - 07:45:48 GMT-3