From: Nick (seajay76@nate.com)
Date: Mon Jan 09 2006 - 22:54:43 GMT-3
Hi, John.
I think it's not a good configuration to leave the encapsulation difference
between the port channel and its member channel interfaces.
Here is the the real output. I just tried it with the rental tack :)
HTH
Regards,
Nick
############### CASE 1 ####################
IN THIS CASE, THE LINKS ARE WORKING
JUST AS THEY ARE NOT IN THE FEC.
STP BLOCKED ONE OF THE LINKS.
(1) SW1
interface FastEthernet0/23,24
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
(2) SW2
interface FastEthernet0/23,24
switchport mode dynamic desirable
(3) Result
Rack3SW1#show eth sum
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
u - unsuitable for bundling
U - in use f - failed to allocate aggregator
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SD) PAgP Fa0/23(I) Fa0/24(I)
Rack3SW1#show int trunk
Port Mode Encapsulation Status Native vlan
Fa0/23 on 802.1q trunking 1
Fa0/24 on 802.1q trunking 1
Port Vlans allowed on trunk
Fa0/23 1-4094
Fa0/24 1-4094
Port Vlans allowed and active in management domain
Fa0/23 1,11-14
Fa0/24 1,11-14
Port Vlans in spanning tree forwarding state and not pruned
Fa0/23 1,11-14
Fa0/24 none
Rack3SW2#show eth sum
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
u - unsuitable for bundling
U - in use f - failed to allocate aggregator
d - default port
Number of channel-groups in use: 0
Number of aggregators: 0
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
Rack3SW2#show
08:28:39: %SYS-5-CONFIG_I: Configured from console by console
Rack3SW2#show int trunk
Port Mode Encapsulation Status Native vlan
Fa0/23 desirable n-802.1q trunking 1
Fa0/24 desirable n-802.1q trunking 1
Port Vlans allowed on trunk
Fa0/23 1-4094
Fa0/24 1-4094
Port Vlans allowed and active in management domain
Fa0/23 1,11-14
Fa0/24 1,11-14
Port Vlans in spanning tree forwarding state and not pruned
Fa0/23 1,11-14
Fa0/24 1,11-14
############### CASE 2 ####################
IN THIS CASE, PO1 WAS MANUALLY MADE ON SW2,
WHICH IS NOT A GOOD WAY TO MAKE A PORT CHANNEL.
NO PORT CHANNEL FEATURES ARE OBSERVED.
(1) SW1
interface FastEthernet0/23
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
(2) SW2
interface FastEthernet0/23
switchport mode dynamic desirable
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
(3) Result
ack3SW1#show eth sum
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
u - unsuitable for bundling
U - in use f - failed to allocate aggregator
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SD) PAgP Fa0/23(I) Fa0/24(I)
Rack3SW1#show int trunk
Port Mode Encapsulation Status Native vlan
Fa0/23 on 802.1q trunking 1
Fa0/24 on 802.1q trunking 1
Port Vlans allowed on trunk
Fa0/23 1-4094
Fa0/24 1-4094
Port Vlans allowed and active in management domain
Fa0/23 1,11-14
Fa0/24 1,11-14
Port Vlans in spanning tree forwarding state and not pruned
Fa0/23 1,11-14
Fa0/24 none
Rack3SW2#show eth sum
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
u - unsuitable for bundling
U - in use f - failed to allocate aggregator
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SD) -
Rack3SW2#show int trunk
Port Mode Encapsulation Status Native vlan
Fa0/23 desirable n-802.1q trunking 1
Fa0/24 desirable n-802.1q trunking 1
Port Vlans allowed on trunk
Fa0/23 1-4094
Fa0/24 1-4094
Port Vlans allowed and active in management domain
Fa0/23 1,11-14
Fa0/24 1,11-14
Port Vlans in spanning tree forwarding state and not pruned
Fa0/23 1,11-14
Fa0/24 1,11-14
############### CASE 3 ####################
IN THIS CASE, THE FA0/23,24 ARE INCLUDED IN THE PORT CHANNEL1.
THE MEMBER INTERFACES ARE SUSPENDED DUT TO ENCAPSULATION MISMATCH.
(1) SW1
interface FastEthernet0/23
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
(2) SW2
interface FastEthernet0/23
switchport mode dynamic desirable
channel-group 1 mode desirable
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
(3) Result
Rack3SW1#show eth sum
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
u - unsuitable for bundling
U - in use f - failed to allocate aggregator
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SD) PAgP Fa0/23(I) Fa0/24(I)
Rack3SW1#show int trunk
Port Mode Encapsulation Status Native vlan
Fa0/23 on 802.1q trunking 1
Fa0/24 on 802.1q trunking 1
Port Vlans allowed on trunk
Fa0/23 1-4094
Fa0/24 1-4094
Port Vlans allowed and active in management domain
Fa0/23 1,11-14
Fa0/24 1,11-14
Port Vlans in spanning tree forwarding state and not pruned
Fa0/23 1,11-14
Fa0/24 1,11-14
Rack3SW2#show eth sum
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
u - unsuitable for bundling
U - in use f - failed to allocate aggregator
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SD) PAgP Fa0/23(s) Fa0/24(s)
Rack3SW2#show int trunk
08:31:36: %EC-5-CANNOT_BUNDLE2: Fa0/23 is not compatible with Po1 and will be suspended (trunk encap of Fa0/23 is auto, Po1 is dot1q)
08:31:36: %EC-5-CANNOT_BUNDLE2: Fa0/24 is not compatible with Po1 and will be suspended (trunk encap of Fa0/24 is auto, Po1 is dot1q)
Rack3SW2#show int status
.....
Fa0/23 notconnect trunk a-full a-100 10/100BaseTX
Fa0/24 notconnect trunk a-full a-100 10/100BaseTX
.....
Rack3SW2#show int fa0/23
FastEthernet0/23 is up, line protocol is down (notconnect)
.....
############### CASE 4 ####################
IN THIS CASE, THE PO 1 ON SW2 ARE CONFIGURED AS A TRUNK.
EVERYTHING IS OKAY.
(1) SW1
interface FastEthernet0/23
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
(2) SW2
interface FastEthernet0/23
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
(3) Result
Rack3SW1#show eth sum
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
u - unsuitable for bundling
U - in use f - failed to allocate aggregator
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) PAgP Fa0/23(P) Fa0/24(P)
Rack3SW1#show int trunk
Port Mode Encapsulation Status Native vlan
Po1 on 802.1q trunking 1
Port Vlans allowed on trunk
Po1 1-4094
Port Vlans allowed and active in management domain
Po1 1,11-14
Port Vlans in spanning tree forwarding state and not pruned
Po1 1,11-14
Rack3SW2#show eth sum
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
u - unsuitable for bundling
U - in use f - failed to allocate aggregator
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) PAgP Fa0/23(P) Fa0/24(P)
Rack3SW2#show int trunk
Port Mode Encapsulation Status Native vlan
Po1 on 802.1q trunking 1
Port Vlans allowed on trunk
Po1 1-4094
Port Vlans allowed and active in management domain
Po1 1,11-14
Port Vlans in spanning tree forwarding state and not pruned
Po1 1,11-14
----- Original Message -----
From: "John Matus" <John.Matus@tokiom.com>
To: <ccielab@groupstudy.com>
Sent: Tuesday, January 10, 2006 5:46 AM
Subject: trunking
> if you are creating an etherchannel w/ 2 ports and you want to have it
> negotiated via pagp.........
>
> int range fa0/13 - 14
> channel-g 1 mode desirable
> channel-g protocol pagp
>
> int po1
> switch trunk encap dot1q
> <switch mode trunk>
>
> does it matter if you leave off the "switch mode trunk" under the po1
> interface? i thought you needed this but i'm looking at an IE solution
> guide and it does not show "switch mode trunk"......i know that if you set
> it to "switchport nonegotiate" it stops DTP frame from being sent out, but
> i'm not sure if the "switch mode trunk" stops pagp from operating correctly
> <???>
>
> TIA
>
>
> Regards,
>
> John D. Matus
> Technical Support / PAS
> Fujitsu Consulting
> 626-568-7716
> John.Matus@tokiom.com
> ========================================================================================================
> This e-mail is intended solely for the individual to whom it is
> addressed. The information contained in this transmission contains
> confidential and/or proprietary information or is otherwise privileged. If
> the reader of this message is not the intended recipient, please be advised
> that any dissemination, distribution or copying of this transmission is
> strictly prohibited. If you have received this e-mail in error, please
> notify us immediately by returning it to the sender and deleting this copy
> from your system. Thank you for your cooperation.
> ========================================================================================================
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Wed Feb 01 2006 - 07:45:48 GMT-3