RE: Multicast helper map seems to work, but doesn't actually

From: Ashok M A (ashok_ccie@yahoo.co.in)
Date: Thu Oct 13 2005 - 14:28:27 GMT-3


I got the answer. "ip broacast-address" should be on
the outgoing interface. For example, for the config
mentioned below, it should be

R5#
Int e0
ip broadcast-address 20.1.1.255
R5#

Then debug at BB1 is

BB1#
2w0d: IP: s=22.22.22.8 (Ethernet0), d=20.1.1.255
(Ethernet0), len 44, rcvd 3
2w0d: UDP src=54239, dst=5000
BB1#
 

Thanks & Regards,

Ashok M A

-----Original Message-----
From: nobody@groupstudy.com
[mailto:nobody@groupstudy.com] On Behalf Of Ashok M A
Sent: Thursday, October 13, 2005 10:28 PM
To: Stefan Grey; ccielab@groupstudy.com
Subject: RE: Multicast helper map seems to work, but
doesn't actually forward mpacket to next hop router

Hi Stefan,

Doc says "If you need to send a directed broadcast to
the subnet, the outgoing interface of the last hop
router can be configured with an IP broadcast address
of x.x.x.255, where x.x.x.0 is the subnet that you are
trying to reach; otherwise the packet will be
converted to 255.255.255.255"

(http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123cgcr/ipras_r/ip1_i1g.htm#wp1080203)

But configured both the ways like given below:

~~~
R5#sri s0
Building configuration...

Current configuration : 422 bytes
!
interface Serial0
 ip address 10.1.1.5 255.255.255.0
 ip pim sparse-dense-mode
 ip multicast helper-map 225.5.5.5 20.1.1.255 100
encapsulation frame-relay no ip route-cache no ip
mroute-cache no arp frame-relay frame-relay map ip
10.1.1.2 502 broadcast frame-relay map ip 10.1.1.5
502 frame-relay map ip 10.1.1.6 502 broadcast no
frame-relay inverse-arp end ~~~ and

~~~
R5#sri s0
Building configuration...

Current configuration : 422 bytes
!
interface Serial0
 ip address 10.1.1.5 255.255.255.0
 ip broadcast-address 20.1.1.255
 ip pim sparse-dense-mode
 ip multicast helper-map 225.5.5.5 20.1.1.255 100
encapsulation frame-relay no ip route-cache ip ospf
priority 0 no ip mroute-cache no arp frame-relay
frame-relay map ip 10.1.1.2 502 broadcast frame-relay
map ip 10.1.1.5 502 frame-relay map ip 10.1.1.6 502
broadcast no frame-relay inverse-arp end ~~~

But i get the same broadcast address "255.255.255.255"
at the neighbor router. Not sure why?
~~~~
BB1#
BB1#2w0d: IP: s=22.22.22.8 (Ethernet0),
d=255.255.255.255, len 44, rcvd 2
2w0d: UDP src=51613, dst=5000
BB1#
BB1#
~~~~

Config at R5 e0 is:
~~~
R5#sri e0
Building configuration...

Current configuration : 105 bytes
!
interface Ethernet0
 ip address 20.1.1.5 255.255.255.0
 ip directed-broadcast
 no ip mroute-cache
end
~~~

Ashok

--- Stefan Grey <examplebrain@hotmail.com> wrote:

> Hello,
> I just wanted to ask here why was this used:
>
> ip broadcast-address 20.1.1.0
> ip multicast helper-map 224.5.5.5 20.1.1.0 100
>
> Why just not use this:
>
> ip multicast helper-map 224.5.5.5 20.1.1.255 100 ???
>
> what would do the thing like this ??
>
> ip broadcast address 20.1.1.1
> ip multicast helper-map 224.5.5.5 20.1.1.1 100
>
> This doesn't closely relate to the original
questions but ver
> interesting for me...
>
>
>
> >From: Ashok M A <ashok_ccie@yahoo.co.in>
> >Reply-To: Ashok M A <ashok_ccie@yahoo.co.in>
> >To: CCIELab@groupstudy.com,
> bmcgahan@internetworkexpert.com
> >Subject: RE: Multicast helper map seems to work,
> but doesn't actually
> >forward mpacket to next hop router
> >Date: Wed, 12 Oct 2005 17:16:10 +0100 (BST)
> >
> >Hi,
> >
> >I tried to create this scenario. I could see the
multicast packet at
> >R2 e0/0 interface being
> received
> >as 224.9.9.9 with source/dest port as 520. But
> looks
> >like this is not forwarded to beyond R2 e1
> interface
> >which is connected to BB1 over e0. What might be
> the
> >issue?
> >
> >Config is as follows:
> >
> >R2#sri e0/0
> >Building configuration...
> >
> >!
> >interface e0/0
> > ip address 10.1.1.5 255.255.255.0
> > ip broadcast-address 20.1.1.0
> > ip directed-broadcast
> > ip pim sparse-dense-mode
> > ip multicast helper-map 224.5.5.5 20.1.1.0 100
> > no ip mroute-cache
> >end
> >
> >ip forward-protocol udp rip
> >R2#
> >
> >R2#sri e1
> >Building configuration...
> >
> >interface Ethernet1
> > ip address 20.1.1.5 255.255.255.0
> > ip directed-broadcast
> > ip pim sparse-dense-mode
> > no ip route-cache
> > no ip mroute-cache
> >end
> >
> >R2#
> >
> >R2#al 100
> >Extended IP access list 100
> > permit udp any any eq rip (103 matches) R2#
> >
> >
> >Thanks & Regards,
> >
> >Ashok
> >
> >
> >-----Original Message-----
> >From: nobody@groupstudy.com
> >[mailto:nobody@groupstudy.com] On Behalf Of
> Edwards,
> >Andrew M
> >Sent: Friday, November 12, 2004 11:28 PM
> >To: Brian McGahan; CCIELab@groupstudy.com
> >Subject: RE: Multicast helper map seems to work,
> but
> >doesn't actually forward mpacket to next hop router
> >
> >You know I thought it might be a TTL issue with R4
> and
> >I did look into it by doing this...
> >
> >Ip multicast helper-map broadcast 224.9.9.9 100 ttl
> 5
> >
> >Now, my thoughts are that I have technically,
> stripped
> >and replaced the layer 3 header when I do the
helper-map unlike a
> >tunnel mode where its reencapsulating the entire
layer 3 packet.
> >This
> would
> >mean that the helper-map should replace the TTL in
> the
> >RIP broadcast when it recreates the L3 header.
> >
> >However, the output to R2 was still the same
> mroute...
> >It didn't get the multicastpacket. I even did a
straight debug with
> >debug ip packet and no
> conditions.
> > I did not see the packet being forwarded when
> debug
> >ip mpacket said it was mforwarded.
> >
> >Maybe a bug or did I set it up incorrectly?
> >
> >If you are familiar with the Cisco Press R&S lab
> book,
> >they gave an example of turning rip broadcast into
multicast and
> >sending to another router on a
> different
> >lan segment. I was simply trying to recreate that
scenario and
> >viola... It didn't work. 8)
> >
> >Andy
> >
> >-----Original Message-----
> >From: Brian McGahan
> >[mailto:bmcgahan@internetworkexpert.com]
> >Sent: Thursday, November 11, 2004 12:23 PM
> >To: Edwards, Andrew M; CCIELab@groupstudy.com
> >Subject: RE: Multicast helper map seems to work,
> but
> >doesn't actually forward mpacket to next hop router
> >
> >
> >Andy,
> >
> > IIRC RIP packets have a TTL of 1. This may be the
problem you're
> >seeing. Try generating UDP traffic by using the
SAA (rtr command on
> >the router). I'll take a look at this today and
let you know what I
> >find, but I'd bet that it relates to the TTL.
> >
> >HTH,
> >
> >Brian McGahan, CCIE #8593
> >bmcgahan@internetworkexpert.com
> >
> >Internetwork Expert, Inc.
> >http://www.InternetworkExpert.com
> >Toll Free: 877-224-8987 x 705
> >Outside US: 775-826-4344 x 705
> >24/7 Support: http://forum.internetworkexpert.com
> >Live Chat: http://www.internetworkexpert.com/chat/
> >
> > > -----Original Message-----
> > > From: nobody@groupstudy.com
> >[mailto:nobody@groupstudy.com] On Behalf Of
> > > Edwards, Andrew M
> > > Sent: Thursday, November 11, 2004 11:07 AM
> > > To: CCIELab@groupstudy.com
> > > Subject: Multicast helper map seems to work, but
> >doesn't actually
> >forward
> > > mpacket to next hop router
> > >
> > > Well, as is usual for most people, time is
> running
> >short to study for
> >my
> > > next lab attempt and I ran into a very specific
> >problem while digging
> > > into multicast...
> > >
> > > Normally I wont post so much output cause its
> hard
> >to dig through, but
> >
> > > this one really bothers me. If you have time,
> >please read on.
> > >
> > > Basically, multicast helper map is working and
> >forwarding multicast
> > > packets, but they are not actually being sent
> out
> >the interface (e.g.
> > > neighbor doensn't get the (*,G) entry because no
> >packets are being
> > > received).
>
=== message truncated ===

                



This archive was generated by hypermail 2.1.4 : Sun Nov 06 2005 - 22:00:50 GMT-3