From: Edwards, Andrew M (andrew.m.edwards@boeing.com)
Date: Thu Oct 13 2005 - 12:59:06 GMT-3
A few thoughts:
Seems like your provider doesn't want you to send this traffic. I've
heard of this and believe there are currently cases against incumbent
providers for blocking this traffic. Basically the telecom act of 1996
doesn't allow them (yet) to do it because VoIP is not yet classified
like normal voice communications which are taxed and levied accordingly
in the US. But without too much regression lets get out on the table
they don't want you to send VoIP (H323, SIP, whatever). Your provider
does not want to carry this traffic.
And, since VoIP is touchy for jitter, delay, loss, etc.... You might
want to reevaluate your provider and their contractual obligations.
That withstanding, I would hide the traffic via NAT support for H323, or
even better, tunnel the traffic over GRE. If tunneling causes delay
variation then I would set the TOS bits on the tunnel to inject into the
provider network (say CS5) or/and change my codec and compress the
voice.
HTH,
andy
-----Original Message-----
From: David Fuller [mailto:fullerdavid@hotmail.com]
Sent: Thursday, October 13, 2005 7:48 AM
To: ccielab@groupstudy.com
Subject: OT: VOICE on AS5300
Hi guys
Calling voice guys! We have an issue as follows:
We have a soft switch that sends voice calls to the AS5300 on one end
and the AS5300 sends this via IP over the internet, terminating at a GSM
gateway in the other country. GSM receives calls via IP and has SIMs
that it can use to route the calls to in country operators.
The problem is ISPs have blocked port 1720 used by H323. Since all the
calls were going via H323, all voice calls have stopped working. We want
to be able to route the calls out from AS5300 over a port other than
1720.
Would SIP do the trick? What config changes would be needed?
Thanks for your help
Dave
Here is the config:
AS5300-1#show run
Building configuration...
Current configuration : 2000 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname AS5300-1
!
boot-start-marker
boot-end-marker
!
enable secret <REMOVED>
enable password < REMOVED>
!
!
resource-pool disable
!
syscon address 218.39.25.203 d1g1t0ooo
syscon shelf-id 0
no aaa new-model
ip subnet-zero
!
!
isdn switch-type primary-net5
!
voice call send-alert
voice rtp send-recv
!
voice service voip
h323
!
controller E1 0
pri-group timeslots 1-31
!
controller E1 1
pri-group timeslots 1-31
!
controller E1 2
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 3
framing NO-CRC4
pri-group timeslots 1-31
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0:15
no ip address
isdn switch-type primary-net5
isdn protocol-emulate network
isdn incoming-voice modem
isdn send-alerting
isdn disconnect-cause 34
isdn sending-complete
no cdp enable
!
interface Serial1:15
no ip address
isdn switch-type primary-net5
no cdp enable
!
interface Serial2:15
no ip address
isdn switch-type primary-net5
no cdp enable
!
interface Serial3:15
no ip address
isdn switch-type primary-net5
no cdp enable
!
interface FastEthernet0
ip address 218.39.25.202 255.255.255.248
duplex auto
speed auto
h323-gateway voip interface
!
ip classless
ip route 0.0.0.0 0.0.0.0 218.39.25.206
no ip http server!
dialer-list 1 protocol ip permit
!
voice-port 0:D
!
voice-port 1:D
!
voice-port 2:D
!
voice-port 3:D
!
dial-peer voice 1 pots
incoming called-number .
direct-inward-dial
port 0:D
!
dial-peer voice 2 voip
huntstop
destination-pattern 92T
session target ipv4:204.145.230.234
no vad
!
num-exp 001 1
num-exp 002 2
num-exp 003 3
num-exp 004 4
num-exp 005 5
num-exp 006 6
num-exp 007 7
num-exp 008 8
num-exp 009 9
gateway
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
password <REMOVED>
6
login
!
scheduler interval 1000
end
This archive was generated by hypermail 2.1.4 : Sun Nov 06 2005 - 22:00:50 GMT-3