Re: Multicast issue: Auto-RP over Sparse-Dense mode

From: Matt Mullen (mullenm@gmail.com)
Date: Thu Sep 15 2005 - 17:51:30 GMT-3


Hi Dave,
 By default an interface in Sparse mode will not listen to AutoRP
advertisements because AutoRP uses dense mode for operation. To get around
this you can configure sparse-dense mode on the interface, or you can
override the behavior on a sparse-mode configured interface so that it does
listen to AutoRP advertisements with the 'ip pim autorp listener' command.
Interface s0.1 on R2 is configured for Sparse-mode, so it will not listen to
the Auto-RP advertisements being sent from R4 for the group
224.4.4.0<http://224.4.4.0>.
If you configure interface s0.1 on R2 as sparse-dense or use the above
mentioned command on the interface, you should start to see the AutoRP
advertisements being forwarded across the rest of your topology.
 HTH,
Matt

On 9/15/05, Schulz, Dave <DSchulz@dpsciences.com> wrote:
>
> Here is the situation.... I am doing multicast with Auto-RP over
> Sparse-Dense (configs below). R2 has a DLCI to R3 and R4 (multipoint
> subif), and, also a point-to-point subinterface on a separate dlci to
> R5.
>
> R2 is announcing itself as the RP for groups 224.2.2.0 <http://224.2.2.0>
> R4 is announcing itself as the RP for groups 224.4.4.0 <http://224.4.4.0>
>
> I believe the configurations are correct. However, when I do the show
> ip pim rp map, I get the following:
>
> R2#sh ip pim rp map
> PIM Group-to-RP Mappings
> This system is an RP (Auto-RP)
> This system is an RP-mapping agent (Serial0.2)
>
> Group(s) 224.2.2.0/24 <http://224.2.2.0/24>
> RP 20.20.20.1 <http://20.20.20.1> (?), v2v1
> Info source: 20.20.20.1 <http://20.20.20.1> (?), via Auto-RP
> Uptime: 23:19:40, expires: 00:02:15
>
> R3#sh ip pim rp map
> PIM Group-to-RP Mappings
>
> Group(s) 224.2.2.0/24 <http://224.2.2.0/24>
> RP 20.20.20.1 <http://20.20.20.1> (?), v2v1
> Info source: 172.16.1.2 <http://172.16.1.2> (?), via Auto-RP
> Uptime: 23:18:23, expires: 00:02:39
> R3#
>
> R4# sh ip pim rp map
> PIM Group-to-RP Mappings
> This system is an RP (Auto-RP)
>
> Group(s) 224.2.2.0/24 <http://224.2.2.0/24>
> RP 20.20.20.1 <http://20.20.20.1> (?), v2v1
> Info source: 172.16.1.2 <http://172.16.1.2> (?), via Auto-RP
> Uptime: 00:00:05, expires: 00:02:50
> Group(s) 224.4.4.0/24 <http://224.4.4.0/24>
> RP 40.40.40.1 <http://40.40.40.1> (?), v2v1
> Info source: 40.40.40.1 <http://40.40.40.1> (?), via Auto-RP
> Uptime: 23:06:44, expires: 00:01:17
>
>
> R5#sh ip pim rp map
> PIM Group-to-RP Mappings
>
> Group(s) 224.2.2.0/24 <http://224.2.2.0/24>
> RP 20.20.20.1 <http://20.20.20.1> (?), v2v1
> Info source: 172.16.1.2 <http://172.16.1.2> (?), via Auto-RP
> Uptime: 23:05:19, expires: 00:02:50
>
> Problem: for some reason, I cannot get the 224.4.40 group to be mapped
> throughout the network. I run the same scenario under BSR and it works
> fine. Also, running the MRM utility shows no errors. Thoughts? Here
> are the configs......
>
>
> hostname R2
> ip multicast-routing
> !
> interface Loopback0
> ip address 20.20.20.1 <http://20.20.20.1>
255.255.255.0<http://255.255.255.0>
> ip pim sparse-dense-mode
> !
> interface Serial0
> no ip address
> encapsulation frame-relay
> no frame-relay inverse-arp
> frame-relay lmi-type cisco
> !
> interface Serial0.1 multipoint
> ip address 192.168.1.2 <http://192.168.1.2>
255.255.255.0<http://255.255.255.0>
> ip pim nbma-mode
> ip pim sparse-mode
> frame-relay map ip 192.168.1.2 <http://192.168.1.2> 203
> frame-relay map ip 192.168.1.3 <http://192.168.1.3> 203 broadcast
> frame-relay map ip 192.168.1.4 <http://192.168.1.4> 204 broadcast
> no frame-relay inverse-arp
> !
> interface Serial0.2 point-to-point
> ip address 172.16.1.2 <http://172.16.1.2>
255.255.255.0<http://255.255.255.0>
> ip pim sparse-dense-mode
> ip igmp join-group 224.4.4.4 <http://224.4.4.4>
> frame-relay interface-dlci 205
> !
> router eigrp 1
> network 172.16.0.0 <http://172.16.0.0>
> network 192.168.1.0 <http://192.168.1.0>
> no auto-summary
> no eigrp log-neighbor-changes
> !
> ip pim send-rp-announce Loopback0 scope 16 group-list 1
> ip pim send-rp-discovery Serial0.2 scope 16
> !
> ip mrm manager TST
> manager Loopback0 group 224.4.4.4 <http://224.4.4.4>
> senders 8
> receivers 9 sender-list 8
> !
> access-list 1 permit 224.2.2.0 <http://224.2.2.0>
0.0.0.255<http://0.0.0.255>
> access-list 8 permit 50.50.50.1 <http://50.50.50.1>
> access-list 9 permit 40.40.40.1 <http://40.40.40.1>
> !
>
> R3
> hostname R3
> ip multicast-routing
> !
> interface Loopback0
> ip address 30.30.30.1 <http://30.30.30.1>
255.255.255.0<http://255.255.255.0>
> ip pim sparse-dense-mode
> !
> interface Serial0
> ip address 192.168.1.3 <http://192.168.1.3>
255.255.255.0<http://255.255.255.0>
> ip pim sparse-dense-mode
> encapsulation frame-relay
> frame-relay map ip 192.168.1.2 <http://192.168.1.2> 302 broadcast
> frame-relay map ip 192.168.1.3 <http://192.168.1.3> 302
> frame-relay map ip 192.168.1.4 <http://192.168.1.4> 302 broadcast
> no frame-relay inverse-arp
> frame-relay lmi-type cisco
> !
> router eigrp 1
> network 192.168.1.0 <http://192.168.1.0>
> no auto-summary
> no eigrp log-neighbor-changes
> !
>
> R4
>
> hostname R4
> ip multicast-routing
> !
> interface Loopback0
> ip address 40.40.40.1 <http://40.40.40.1>
255.255.255.0<http://255.255.255.0>
> ip pim sparse-dense-mode
> ip mrm test-receiver
> !
> interface Serial0
> ip address 192.168.1.4 <http://192.168.1.4>
255.255.255.0<http://255.255.255.0>
> ip pim sparse-dense-mode
> encapsulation frame-relay
> frame-relay map ip 192.168.1.2 <http://192.168.1.2> 402 broadcast
> frame-relay map ip 192.168.1.3 <http://192.168.1.3> 402 broadcast
> frame-relay map ip 192.168.1.4 <http://192.168.1.4> 402
> no frame-relay inverse-arp
> frame-relay lmi-type cisco
> !
> router eigrp 1
> network 192.168.1.0 <http://192.168.1.0>
> no auto-summary
> no eigrp log-neighbor-changes
> !
> ip pim send-rp-announce Loopback0 scope 16 group-list 1
> !
> access-list 1 permit 224.4.4.0 <http://224.4.4.0>
0.0.0.255<http://0.0.0.255>
> !
>
>
> R5
> hostname R5
> ip multicast-routing
> !
> interface Loopback0
> ip address 50.50.50.1 <http://50.50.50.1>
255.255.255.0<http://255.255.255.0>
> ip pim sparse-dense-mode
> ip mrm test-sender
> !
> interface Serial0
> ip address 172.16.1.5 <http://172.16.1.5>
255.255.255.0<http://255.255.255.0>
> ip pim sparse-dense-mode
> encapsulation frame-relay
> frame-relay interface-dlci 502
> frame-relay lmi-type cisco
> !
> router eigrp 1
> network 172.16.0.0 <http://172.16.0.0>
> no auto-summary
> no eigrp log-neighbor-changes
> !
> end
>
> Dave Schulz
> Email: dschulz@dpsciences.com <mailto:dschulz@dpsciences.com >
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Sun Oct 02 2005 - 14:40:15 GMT-3