BGP advertisement issue

From: Anh P Tran (anhtran81@optusnet.com.au)
Date: Mon Sep 05 2005 - 03:51:07 GMT-3


Hi groups,

 

My diagram is below which is lab 14 in IE workbook

 

 

Eth0/0----R4--------S0/0-----------------S1/1----R3

                                                             |

                                                             |

                                                           ETH0/0
----------------- FA0/0------R6-----------Dialer1 PPPoA ------------------
BB1

 

 

R3, R4, R6 is IBGP within AS 100

 

R3 is the Route reflector for R4 and R6

 

R6 has EBGP peer with BB1 which in AS 54

 

When R4 originate the its Eth0/0 route 167.1.4.0 to BGP, R6 received this
route via R3 and advertise to BB1 as EBGP routes.

 

I believed the BGP RFC states that when you advertise routes to EBGP peer,
the next hop should be set to the peering address which in this case should
be the dialer 1 ip .

 

However, this is not the case with my lab as R6 tried to advertise the route
and keep the next-hop as from R4 to BB1.

 

BB1 rejected the route as it complained the route is EBGP and NEXT-HOP
should be directly connected.

 

Is it the IOS bugs or I have done something wrong. I had included all the
relevant configuration and debug.

 

Thanks guys

 

Anh Tran

 

*************** R4 config ***************

 

Rack1R4#show run int eth0/0

Building configuration...

 

Current configuration : 78 bytes

!

interface Ethernet0/0

 ip address 167.1.4.4 255.255.255.0

 half-duplex

end

 

 

interface Serial0/0

 description *** PVC TO R3 ***

 bandwidth 64

 ip address 167.1.34.4 255.255.255.0

 ip router isis

 encapsulation frame-relay

 backup interface BRI0/0

 backup load 20 10

 load-interval 30

 isis network point-to-point

 frame-relay map clns 413 broadcast

 frame-relay map ip 167.1.34.3 413 broadcast

 frame-relay map ip 167.1.34.4 413

 no frame-relay inverse-arp

 

router bgp 100

 no synchronization

 bgp router-id 150.1.4.4

 bgp log-neighbor-changes

 network 167.1.4.0 mask 255.255.255.0

 neighbor 150.1.3.3 remote-as 100

 neighbor 150.1.3.3 update-source Loopback0

 

Rack1R4#show ip bgp regexp ^$

BGP table version is 60, local router ID is 150.1.4.4

Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

 

   Network Next Hop Metric LocPrf Weight Path

*> 167.1.4.0/24 0.0.0.0 0 32768 i

 

****** R3 CONFIG ******

 

interface Serial1/1

 description *** PVC TO R4 ***

 bandwidth 64

 ip address 167.1.34.3 255.255.255.0

 encapsulation frame-relay

 load-interval 30

 serial restart_delay 0

 no frame-relay inverse-arp

 

interface Ethernet0/0

 description *** CONNECT TO R6 ***

 ip address 204.12.1.3 255.255.255.0

 ip router isis

 half-duplex

 

router bgp 100

 no synchronization

 bgp router-id 150.1.3.3

 bgp log-neighbor-changes

 neighbor IBGP peer-group

 neighbor IBGP remote-as 100

 neighbor IBGP update-source Loopback0

 neighbor IBGP route-reflector-client

 neighbor IBGP send-community

 neighbor 150.1.4.4 peer-group IBGP

 neighbor 150.1.6.6 peer-group IBGP

 

Rack1R3#show ip bgp regexp ^$

BGP table version is 68, local router ID is 150.1.3.3

Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

 

   Network Next Hop Metric LocPrf Weight Path

*>i167.1.4.0/24 150.1.4.4 0 100 0 i

 

******* R6 CONFIG ******

 

interface Dialer1

 description *** CONNECT TO BB1 ***

 ip address 54.1.8.6 255.255.255.0

 ip router isis

 encapsulation ppp

 dialer pool 1

 dialer-group 1

 ppp chap refuse

 ppp pap sent-username ROUTER6 password 0 CISCO

 isis circuit-type level-1

 

interface FastEthernet0/0

 description *** CONNECT TO R3 ***

 ip address 204.12.1.6 255.255.255.0

 ip router isis

 duplex half

 isis circuit-type level-2-only

 

router bgp 100

 no synchronization

 bgp router-id 150.1.6.6

 bgp log-neighbor-changes

 neighbor 54.1.8.254 remote-as 54

neighbor 150.1.3.3 remote-as 100

 neighbor 150.1.3.3 update-source Loopback0

 

Rack1R6#show ip bgp summary

BGP router identifier 150.1.6.6, local AS number 100

BGP table version is 26, main routing table version 26

15 network entries using 1515 bytes of memory

17 path entries using 816 bytes of memory

6 BGP path attribute entries using 360 bytes of memory

2 BGP rrinfo entries using 48 bytes of memory

3 BGP AS-PATH entries using 72 bytes of memory

1 BGP community entries using 24 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 2835 total bytes of memory

BGP activity 16/1 prefixes, 18/1 paths, scan interval 60 secs

 

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
State/PfxRcd

54.1.8.254 4 54 34 45 26 0 0 00:27:12 8

150.1.3.3 4 100 48 45 26 0 0 00:27:13 7

 

Rack1R6#show ip bgp regexp ^$

BGP table version is 26, local router ID is 150.1.6.6

Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

 

   Network Next Hop Metric LocPrf Weight Path

*>i167.1.4.0/24 150.1.4.4 0 100 0 i

 

 

Debug on the BB1 router

BB1#show ip bgp summary | ex Active

BGP router identifier 212.18.3.1, local AS number 54

BGP table version is 25, main routing table version 25

8 network entries using 808 bytes of memory

8 path entries using 384 bytes of memory

2 BGP path attribute entries using 120 bytes of memory

1 BGP community entries using 24 bytes of memory

2 BGP route-map cache entries using 40 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 1376 total bytes of memory

BGP activity 22/10 prefixes, 25/13 paths, scan interval 60 secs

 

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
State/PfxRcd

54.1.8.6 4 100 145 112 25 0 0 00:29:34 0

 

BB1#debug ip bgp updates in

BGP updates debugging is on (inbound)

BB1#

Sep 4 23:28:25.021: BGP(0): 54.1.8.6 send UPDATE (format) 112.0.0.0/8, next
54.1.8.254, metric 0, path

Sep 4 23:28:25.021: BGP(0): 54.1.8.6 send UPDATE (prepend, chgflags: 0x0)
113.0.0.0/8, next 54.1.8.254, metric 0, path

Sep 4 23:28:25.021: BGP(0): 54.1.8.6 send UPDATE (format) 114.0.0.0/8, next
54.1.8.254, metric 0, path

Sep 4 23:28:25.021: BGP(0): 54.1.8.6 send UPDATE (prepend, chgflags: 0x0)
115.0.0.0/8, next 54.1.8.254, metric 0, path

Sep 4 23:28:25.021: BGP(0): 54.1.8.6 send UPDATE (format) 116.0.0.0/8, next
54.1.8.254, metric 0, path

Sep 4 23:28:25.025: BGP(0): 54.1.8.6 send UPDATE (prepend, chgflags: 0x0)
117.0.0.0/8, next 54.1.8.254, metric 0, path

Sep 4 23:28:25.025: BGP(0): 54.1.8.6 send UPDATE (prepend, chgflags: 0x0)
118.0.0.0/8, next 54.1.8.254, metric 0, path

Sep 4 23:28:25.025: BGP(0): 54.1.8.6 send UPDATE (prepend, chgflags: 0x0)
119.0.0.0/8, next 54.1.8.254, metric 0, path

Sep 4 23:28:25.025: BGP: 54.1.8.6 Advertised Nexthop 204.12.1.254: N

on-local or Nexthop and peer Not on same interface

Sep 4 23:28:25.025: BGP(0): 54.1.8.6 rcv UPDATE w/ attr: nexthop
204.12.1.254, origin i, originator 0.0.0.0, path 100 54, community ,
extended community

Sep 4 23:28:25.029: BGP(0): 54.1.8.6 rcv UPDATE about 28.119.16.0/24 --
DENIED due to: AS-PATH contains our own AS; non-connected NEXTHOP;

Sep 4 23:28:25.029: BGP(0): 54.1.8.6 rcv UPDATE about 28.119.17.0/24 --
DENIED due to: AS-PATH contains our own AS; non-connected NEXTHOP;

Sep 4 23:28:25.029: BGP: 54.1.8.6 Advertised Nexthop 192.10.1.254:
Non-local or Nexthop and peer Not on same interface

Sep 4 23:28:25.029: BGP(0): 54.1.8.6 rcv UPDATE w/ attr: nexthop
192.10.1.254, origin ?, originator 0.0.0.0, path 100 254, community ,
extended community

Sep 4 23:28:25.029: BGP(0): 54.1.8.6 rcv UPDATE about 205.90.31.0/24 --
DENIED due to: non-connected NEXTHOP;

Sep 4 23:28:25.029: BGP(0): 54.1.8.6 rcv UPDATE about 220.20.3.0/24 --
DENIED due to: non-connected NEXTHOP;

Sep 4 23:28:25.029: BGP(0): 54.1.8.6 rcv UPDATE about 222.22.2.0/24 --
DENIED due to: non-connected NEXTHOP;

Sep 4 23:28:25.029: BGP: 54.1.8.6 Advertised Nexthop 150.1.5.5: Non-local
or Nexthop and peer Not on same interface

Sep 4 23:28:25.029: BGP(0): 54.1.8.6 rcv UPDATE w/ attr: nexthop 150.1.5.5,
origin i, metric 10, originator 0.0.0.0, path 100, community , extended
community

Sep 4 23:28:25.029: BGP(0): 54.1.8.6 rcv UPDATE about 167.1.5.0/24 --
DENIED due to: non-connected NEXTHOP;

Sep 4 23:28:25.029: BGP: 54.1.8.6 Advertised Nexthop 150.1.4.4: Non-local
or Nexthop and peer Not on same interface <<<

Sep 4 23:28:25.029: BGP(0): 54.1.8.6 rcv UPDATE w/ attr: nexthop 150.1.4.4,
origin i, metric 10, originator 0.0.0.0, path 100, community , extended
community

Sep 4 23:28:25.029: BGP(0): 54.1.8.6 rcv UPDATE about 167.1.4.0/24 --
DENIED due to: non-connected NEXTHOP; <<<<<< This is got me confuse

BB1#



This archive was generated by hypermail 2.1.4 : Sun Oct 02 2005 - 14:40:14 GMT-3