Re: CBWFQ

From: ashwin kohli (ashwin_kohli1@yahoo.com)
Date: Wed Aug 03 2005 - 09:09:48 GMT-3


Hi Rajib,
 
It depends what you want to do. Here is an ideal template for LLQ (change the syntax for CBWFQ) to apply it to per PVC and use traffing shaping. Here is an example I put together for you that will work in production:
 
========================xxxx=========================
 
class-map ftp
access-group 101
!
class-map telnet
access-gorup 102
!
policy-map QUEUEING
description Queue based on DSCP labels
class ftp
  bandwidth percent 40
  random-detect dscp-based
class telnet
 bandwidth percent 50
 random-detect dscp-based
!
!
map-class frame-relay FR-QUEUEING-512kbps
   Description <<<In production allow 5% extra for overhead 512 *0.95 = 486.4>>>
   frame-relay cir 486400
   frame-relay bc 4864
   frame-relay mincir 486400
   frame-relay Tc 10
   no frame-relay adaptive-shaping
   service-policy output QUEUEING
!
int s1/0
 bandwidth XXX
 max-reserved-bandwidth 100
 frame-relay traffic-shaping
 ip route-cache flow
!
int s1/0.1
 <<< sub-interface to apply the policy for that pvc if required>>>
 bandwidth xxx
 frame-relay interface-dlci 101
  class FR-QUEUEING-512kbps
 !
access-list 101 per any any eq ftp
access-list 101 per any any eq ftp-data
access-list 101 per any eq ftp any
access-list 101 per any eq ftp-data any
!
access-list 102 per any any eq telnet
 
========================xxxx=========================

I hope that helps buddy. Let me know.
 
Thanks.

 

Rajib Khan <rajib56666@yahoo.com> wrote:
Hi Group,

I want to assign telnet traffic 50% and ftp traffic 40% of 512kb bandwidth of interface s1

Following is my config

Ip cef

class-map ftp
access-group 101
or
match proto ftp

class-map telnet
access-gorup 102
or
match pro telnet

policy-map bandwidth
class-map ftp
bandw per 40
class-map telnet
bandw per 50

map-class frame-realy cisco
frame-relay cir 512000
frame-realy mincir 512000
no fram adaptive-shaping
service-policy output bandwidth

int s1
fram traffic-shaping
frame-realy class cisco
max-reserve bandwidth 90

or

int s1
bandwidth 512
service-poilicy output cisco
max-reserve bandwidth 90

access-list 101 per any any eq ftp
access-list 101 per any any eq ftp-data
access-list 101 per any eq ftp any
access-list 101 per any eq ftp-data any

access-list 102 per any any eq telnet

I have following questions

1. Can i assign service-policy directily under frame-raly interface rather than in map-class. If I assign directly under interface then it applies to all pvc right? In this case do I need to use frame-realy traffic shaping command

2. If I want to assign CBWFQ to a specific PVC then map-class is absoulutly neccessary right?

Could any one please help me out with this

Thanks

Raj

---------------------------------
Start your day with Yahoo! - make it your home page



This archive was generated by hypermail 2.1.4 : Sun Sep 04 2005 - 17:01:18 GMT-3