From: Jongsoo.Kim@Intelsat.com
Date: Sat Mar 05 2005 - 12:32:25 GMT-3
Yang
I saw some problems.
In R2 and R4, you are not announcing 3.3.24.0/24 to R3 and R6.
When you redistribute ISIS to other protocols, I believe it behaves a little
different.
Other protocol will redistribute all ISIS route except for
directly-connected ISIS, which is the case of 3.3.24.0/24 here.
And believe or not, this is default behavior of Ipv6 redistribution.
So your route-map for connect should also permit 3o.3.24.0/24.
Let me know how it goes.
Regards
Jongsoo
-----Original Message-----
From: Dillon Yang [mailto:gzdillon@hotmail.com]
Sent: Saturday, March 05, 2005 7:38 AM
To: ccie2be
Cc: Group Study
Subject: Re: Redistribution in 3 protocols
Hi, all:
I'm doing a loop+loadbalance test with full-mesh.
There are 3 version:
YangTestV1# 3nodes+1protocol
You know, the IGP use the lowest cost path to prevent loops, meanwhile it
waste the bandwidth of other links. My original intention is obtaining the
most bandwidth sum of all links just like eigrp's non-equal balance. I
successed in the case with static route.
YangTestV2# 4nodes+1protocol
The topology is too complex to finish with static route.
YangTestV3# 4nodes+3protocol
( all nodes are full mesh in each )
I met the big trouble in redistribution though I tried the "distance",
"route-map".
I want help to resolve the loops.
Thanks in advance.
dillon
ps.
neighborhood of YangTestV3
r2: e0/0 to testing pc
r2: s1/1.203 r3 ospf
r2: s1/2.214 r4 isis
r2: s1/2.216 r6 ospf
r3: s0/0.302 r2 ospf
r3: s0/0.304 r4 eigrp
r3: s0/0.306 r6 ospf
r4: s1/1.403 r3 eigrp
r4: s1/1.406 r6 eigrp
r4: s1/2.412 r2 isis
r4: f0/0 to testing pc
r6: s1.612 r2 ospf
r6: s0.603 r3 ospf
r6: s0.604 r4 eigrp
Configuration of YangTestV3
!
hostname r2
!
interface Loopback0
ip address 3.3.2.2 255.255.255.0
ip ospf network point-to-point
!
interface Ethernet0/0
ip address 3.3.28.2 255.255.255.0
!
interface Serial1/1.203 multipoint
bandwidth 125
ip address 3.3.23.2 255.255.255.0
ip ospf priority 0
delay 100
frame-relay map ip 3.3.23.3 203 broadcast
no frame-relay inverse-arp
!
interface Serial1/2.214 multipoint
bandwidth 125
ip address 3.3.24.2 255.255.255.0
ip router isis is24
delay 100
isis metric 60 level-2
frame-relay map clns 214 broadcast
frame-relay map ip 3.3.24.4 214 broadcast
no frame-relay inverse-arp
!
interface Serial1/2.216 multipoint
bandwidth 125
ip address 3.3.26.2 255.255.255.0
ip ospf priority 0
delay 100
frame-relay map ip 3.3.26.6 216 broadcast
no frame-relay inverse-arp
!
router ospf 3
router-id 3.3.2.2
log-adjacency-changes
redistribute connected subnets route-map conn2ospf
redistribute isis is24 level-2 subnets
network 3.3.2.2 0.0.0.0 area 0
network 3.3.23.2 0.0.0.0 area 0
network 3.3.26.2 0.0.0.0 area 26
!
router isis is24
net 47.0001.2222.2222.2222.00
is-type level-2-only
redistribute ospf 3
!
ip prefix-list conn28 seq 5 permit 3.3.28.0/24
!
route-map conn2ospf permit 10
match ip address prefix-list conn28
set metric 2000
!
end
r2#s ip route
3.0.0.0/24 is subnetted, 11 subnets
C 3.3.2.0 is directly connected, Loopback0
O 3.3.3.0 [110/801] via 3.3.23.3, 00:50:11, Serial1/1.203
O E2 3.3.4.0 [110/20] via 3.3.26.6, 00:07:19, Serial1/2.216
[110/20] via 3.3.23.3, 00:07:19, Serial1/1.203
O IA 3.3.6.0 [110/1601] via 3.3.23.3, 00:14:53, Serial1/1.203
C 3.3.23.0 is directly connected, Serial1/1.203
C 3.3.24.0 is directly connected, Serial1/2.214 <-------changed
C 3.3.26.0 is directly connected, Serial1/2.216
C 3.3.28.0 is directly connected, Ethernet0/0
O E2 3.3.34.0 [110/20] via 3.3.23.3, 00:14:54, Serial1/1.203
[110/20] via 3.3.26.6, 00:14:54, Serial1/2.216
O IA 3.3.36.0 [110/1600] via 3.3.23.3, 00:14:54, Serial1/1.203
O E2 3.3.46.0 [110/20] via 3.3.26.6, 00:07:21, Serial1/2.216
[110/20] via 3.3.23.3, 00:07:21, Serial1/1.203
150.100.0.0/24 is subnetted, 1 subnets
O E2 150.100.2.0 [110/20] via 3.3.26.6, 00:07:21, Serial1/2.216
[110/20] via 3.3.23.3, 00:07:21, Serial1/1.203
< after shutdown link between R2 and R4 >
r2#s ip route
3.0.0.0/24 is subnetted, 10 subnets
C 3.3.2.0 is directly connected, Loopback0
O 3.3.3.0 [110/801] via 3.3.23.3, 00:54:42, Serial1/1.203
O E2 3.3.4.0 [110/20] via 3.3.26.6, 00:11:50, Serial1/2.216
[110/20] via 3.3.23.3, 00:11:50, Serial1/1.203
O IA 3.3.6.0 [110/1601] via 3.3.23.3, 00:19:25, Serial1/1.203
C 3.3.23.0 is directly connected, Serial1/1.203
C 3.3.26.0 is directly connected, Serial1/2.216
C 3.3.28.0 is directly connected, Ethernet0/0
O E2 3.3.34.0 [110/20] via 3.3.23.3, 00:19:26, Serial1/1.203
[110/20] via 3.3.26.6, 00:19:26, Serial1/2.216
O IA 3.3.36.0 [110/1600] via 3.3.23.3, 00:19:26, Serial1/1.203
O E2 3.3.46.0 [110/20] via 3.3.26.6, 00:11:51, Serial1/2.216
[110/20] via 3.3.23.3, 00:11:51, Serial1/1.203
150.100.0.0/24 is subnetted, 1 subnets
O E2 150.100.2.0 [110/20] via 3.3.26.6, 00:11:52, Serial1/2.216
[110/20] via 3.3.23.3, 00:11:52, Serial1/1.203
!
hostname r3
interface Loopback0
ip address 3.3.3.3 255.255.255.0
ip ospf network point-to-point
!
interface Serial0.302 multipoint
bandwidth 125
ip address 3.3.23.3 255.255.255.0
delay 100
frame-relay map ip 3.3.23.2 302 broadcast
no frame-relay inverse-arp
!
interface Serial0.304 multipoint
bandwidth 125
ip address 3.3.34.3 255.255.255.0
delay 100
frame-relay map ip 3.3.34.4 304 broadcast
no frame-relay inverse-arp
!
interface Serial0.306 multipoint
bandwidth 125
ip address 3.3.36.3 255.255.255.0
delay 100
frame-relay map ip 3.3.36.6 306 broadcast
no frame-relay inverse-arp
!
router eigrp 3
redistribute ospf 3 metric 100 100 255 1 1500
network 3.3.34.3 0.0.0.0
distance 111 3.3.46.6 0.0.0.0 66
no auto-summary
!
router ospf 3
router-id 3.3.3.3
log-adjacency-changes
redistribute eigrp 3 subnets
network 3.3.3.3 0.0.0.0 area 0
network 3.3.23.3 0.0.0.0 area 0
network 3.3.36.3 0.0.0.0 area 36
neighbor 3.3.23.2
neighbor 3.3.36.6
distance 171 3.3.6.6 0.0.0.0 66
!
access-list 33 deny 3.3.3.0 0.0.0.255
access-list 33 deny 3.3.23.0 0.0.0.255
access-list 33 deny 3.3.34.0 0.0.0.255
access-list 33 permit any
access-list 66 deny 3.3.46.0 0.0.0.255
access-list 66 permit any
end
r3#s ip route
3.0.0.0/24 is subnetted, 10 subnets
O 3.3.2.0 [110/801] via 3.3.23.2, 00:47:33, Serial0.302
C 3.3.3.0 is directly connected, Loopback0
D 3.3.4.0 [90/20633600] via 3.3.34.4, 00:12:35, Serial0.304
D 3.3.6.0 [90/20659200] via 3.3.34.4, 00:12:35, Serial0.304
C 3.3.23.0 is directly connected, Serial0.302
D 3.3.26.0 [90/20556800] via 3.3.34.4, 00:12:35, Serial0.304
O E2 3.3.28.0 [110/2000] via 3.3.23.2, 00:20:04, Serial0.302
C 3.3.34.0 is directly connected, Serial0.304
C 3.3.36.0 is directly connected, Serial0.306
D 3.3.46.0 [90/20531200] via 3.3.34.4, 00:12:36, Serial0.304
150.100.0.0/24 is subnetted, 1 subnets
D EX 150.100.2.0 [170/20531200] via 3.3.34.4, 00:12:36, Serial0.304
< after shutdown link between R2 and R4 , no change >
3.0.0.0/24 is subnetted, 10 subnets
O 3.3.2.0 [110/801] via 3.3.23.2, 00:35:00, Serial0.302
C 3.3.3.0 is directly connected, Loopback0
D 3.3.4.0 [90/20633600] via 3.3.34.4, 00:00:02, Serial0.304
D 3.3.6.0 [90/20659200] via 3.3.34.4, 00:00:02, Serial0.304
C 3.3.23.0 is directly connected, Serial0.302
D 3.3.26.0 [90/20556800] via 3.3.34.4, 00:00:02, Serial0.304
O E2 3.3.28.0 [110/2000] via 3.3.23.2, 00:07:32, Serial0.302
C 3.3.34.0 is directly connected, Serial0.304
C 3.3.36.0 is directly connected, Serial0.306
D 3.3.46.0 [90/20531200] via 3.3.34.4, 00:00:03, Serial0.304
150.100.0.0/24 is subnetted, 1 subnets
D EX 150.100.2.0 [170/20531200] via 3.3.34.4, 00:00:03, Serial0.304
!
hostname r4
!
interface Loopback0
ip address 3.3.4.4 255.255.255.0
!
interface FastEthernet0/0
ip address 150.100.2.3 255.255.255.0
!
interface Serial1/1.403 multipoint
bandwidth 125
ip address 3.3.34.4 255.255.255.0
delay 100
frame-relay map ip 3.3.34.3 403 broadcast
no frame-relay inverse-arp
!
interface Serial1/1.406 multipoint
bandwidth 125
ip address 3.3.46.4 255.255.255.0
delay 100
frame-relay map ip 3.3.46.6 406 broadcast
no frame-relay inverse-arp
!
interface Serial1/2.412 multipoint
bandwidth 125
ip address 3.3.24.4 255.255.255.0
ip router isis is24
delay 100
isis metric 60 level-2
frame-relay map clns 412 broadcast
frame-relay map ip 3.3.24.2 412 broadcast
no frame-relay inverse-arp
!
router eigrp 3
redistribute connected metric 1000 100 255 1 1500 route-map conn150
redistribute isis is24 level-2 metric 100 100 255 1 1500 <-no policy to
generate loop
network 3.3.4.4 0.0.0.0
network 3.3.34.4 0.0.0.0
network 3.3.46.4 0.0.0.0
no auto-summary
!
ip prefix-list conn150 seq 5 permit 150.100.2.0/24
route-map conn150 permit 10
match ip address prefix-list conn150
!
end
r4#s ip rou
3.0.0.0/24 is subnetted, 11 subnets
i L2 3.3.2.0 [115/60] via 3.3.24.2, Serial1/2.412
i L2 3.3.3.0 [115/60] via 3.3.24.2, Serial1/2.412 <--------loop here
C 3.3.4.0 is directly connected, Loopback0
D 3.3.6.0 [90/20633600] via 3.3.46.6, 00:08:56, Serial1/1.406
i L2 3.3.23.0 [115/60] via 3.3.24.2, Serial1/2.412 <--------loop here
C 3.3.24.0 is directly connected, Serial1/2.412
D 3.3.26.0 [90/20531200] via 3.3.46.6, 00:08:58, Serial1/1.406
D EX 3.3.28.0 [170/25651200] via 3.3.46.6, 00:04:56, Serial1/1.406
[170/25651200] via 3.3.34.3, 00:04:57, Serial1/1.403
C 3.3.34.0 is directly connected, Serial1/1.403
D 3.3.36.0 [90/20531200] via 3.3.46.6, 00:04:57, Serial1/1.406
C 3.3.46.0 is directly connected, Serial1/1.406
150.100.0.0/24 is subnetted, 1 subnets
C 150.100.2.0 is directly connected, FastEthernet0/0
r4#traceroute 3.3.3.3
Type escape sequence to abort.
Tracing the route to 3.3.3.3
1 3.3.24.2 20 msec 20 msec 16 msec
2 3.3.24.2 20 msec 20 msec 20 msec
3 * * *
4 * * * <---problem
5 * * *
6 * * *
r4#tr ip
Target IP address: 3.3.28.2
Source address: 150.100.2.3
Numeric display [n]:
Timeout in seconds [3]:
Probe count [3]:
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Port Number [33434]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Type escape sequence to abort.
Tracing the route to 3.3.28.2
1 3.3.46.6 16 msec
3.3.34.3 20 msec
3.3.46.6 16 msec
2 3.3.34.3 20 msec
3.3.46.6 20 msec
3.3.34.3 20 msec
3 3.3.26.2 36 msec
3.3.23.2 44 msec *
r4#
< after shutdown link between R2 and R4 >
r4#s ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
3.0.0.0/24 is subnetted, 10 subnets
D EX 3.3.2.0 [170/25651200] via 3.3.34.3, 00:01:23, Serial1/1.403
[170/25651200] via 3.3.46.6, 00:01:23, Serial1/1.406
D EX 3.3.3.0 [170/25651200] via 3.3.34.3, 00:01:23, Serial1/1.403
[170/25651200] via 3.3.46.6, 00:01:23, Serial1/1.406
C 3.3.4.0 is directly connected, Loopback0
D 3.3.6.0 [90/20633600] via 3.3.46.6, 00:15:24, Serial1/1.406
D EX 3.3.23.0 [170/25651200] via 3.3.34.3, 00:01:23, Serial1/1.403
[170/25651200] via 3.3.46.6, 00:01:24, Serial1/1.406
D 3.3.26.0 [90/20531200] via 3.3.46.6, 00:15:28, Serial1/1.406
D EX 3.3.28.0 [170/25651200] via 3.3.46.6, 00:11:26, Serial1/1.406
[170/25651200] via 3.3.34.3, 00:11:26, Serial1/1.403
C 3.3.34.0 is directly connected, Serial1/1.403
D 3.3.36.0 [90/20531200] via 3.3.46.6, 00:11:26, Serial1/1.406
C 3.3.46.0 is directly connected, Serial1/1.406
150.100.0.0/24 is subnetted, 1 subnets
C 150.100.2.0 is directly connected, FastEthernet0/0
!
hostname r6
!
interface Loopback0
ip address 3.3.6.6 255.255.255.0
ip ospf network point-to-point
!
interface Serial0.603 multipoint
bandwidth 125
ip address 3.3.36.6 255.255.255.0
no ip directed-broadcast
ip ospf priority 0
delay 100
frame-relay map ip 3.3.36.3 603 broadcast
no frame-relay inverse-arp
!
interface Serial0.604 multipoint
bandwidth 125
ip address 3.3.46.6 255.255.255.0
no ip directed-broadcast
delay 100
frame-relay map ip 3.3.46.4 604 broadcast
no frame-relay inverse-arp
!
interface Serial1.612 multipoint
bandwidth 125
ip address 3.3.26.6 255.255.255.0
no ip directed-broadcast
delay 100
frame-relay map ip 3.3.26.2 612 broadcast
no frame-relay inverse-arp
!
router eigrp 3
redistribute ospf 3 metric 100 100 255 1 1500
passive-interface default
no passive-interface Loopback0
no passive-interface Serial0.604
network 3.0.0.0
distance 111 3.3.46.4 0.0.0.0 33
eigrp log-neighbor-changes
!
router ospf 3
router-id 3.3.6.6
log-adjacency-changes
redistribute eigrp 3 subnets
network 3.3.6.6 0.0.0.0 area 36
network 3.3.26.6 0.0.0.0 area 26
network 3.3.36.6 0.0.0.0 area 36
neighbor 3.3.26.2
distance 171 3.3.3.3 0.0.0.0 33
!
access-list 33 deny 3.3.3.0 0.0.0.255
access-list 33 deny 3.3.23.0 0.0.0.255
access-list 33 deny 3.3.34.0 0.0.0.255
access-list 33 permit any
access-list 66 deny 3.3.26.0 0.0.0.255
access-list 66 deny 3.3.6.0 0.0.0.255
access-list 66 deny 3.3.46.0 0.0.0.255
access-list 66 deny 3.3.36.0 0.0.0.255
access-list 66 permit any
!
end
r6#
r6#s ip route
3.0.0.0/24 is subnetted, 10 subnets
O IA 3.3.2.0 [110/801] via 3.3.26.2, 00:15:42, Serial1.612
O IA 3.3.3.0 [110/801] via 3.3.36.3, 00:15:43, Serial0.603
D 3.3.4.0 [111/20633600] via 3.3.46.4, 00:17:09, Serial0.604
C 3.3.6.0 is directly connected, Loopback0
O IA 3.3.23.0 [110/1600] via 3.3.36.3, 00:15:43, Serial0.603
[110/1600] via 3.3.26.2, 00:15:43, Serial1.612
C 3.3.26.0 is directly connected, Serial1.612
O E2 3.3.28.0 [110/2000] via 3.3.26.2, 00:15:43, Serial1.612
D 3.3.34.0 [90/20531200] via 3.3.46.4, 00:17:09, Serial0.604
C 3.3.36.0 is directly connected, Serial0.603
C 3.3.46.0 is directly connected, Serial0.604
150.100.0.0/24 is subnetted, 1 subnets
D EX 150.100.2.0 [170/20531200] via 3.3.46.4, 00:11:58, Serial0.604
r6#
< after shutdown link between R2 and R4 , no change >
r6#s ip route
3.0.0.0/24 is subnetted, 10 subnets
O IA 3.3.2.0 [110/801] via 3.3.26.2, 00:19:45, Serial1.612
O IA 3.3.3.0 [110/801] via 3.3.36.3, 00:19:45, Serial0.603
D 3.3.4.0 [111/20633600] via 3.3.46.4, 00:21:12, Serial0.604
C 3.3.6.0 is directly connected, Loopback0
O IA 3.3.23.0 [110/1600] via 3.3.36.3, 00:19:45, Serial0.603
[110/1600] via 3.3.26.2, 00:19:45, Serial1.612
C 3.3.26.0 is directly connected, Serial1.612
O E2 3.3.28.0 [110/2000] via 3.3.26.2, 00:19:45, Serial1.612
D 3.3.34.0 [90/20531200] via 3.3.46.4, 00:21:12, Serial0.604
C 3.3.36.0 is directly connected, Serial0.603
C 3.3.46.0 is directly connected, Serial0.604
150.100.0.0/24 is subnetted, 1 subnets
D EX 150.100.2.0 [170/20531200] via 3.3.46.4, 00:16:01, Serial0.604
----- Original Message -----
From: "ccie2be" <ccie2be@nyc.rr.com>
To: "'Dillon Yang'" <gzdillon@hotmail.com>; "'Group Study'"
<ccielab@groupstudy.com>
Sent: Friday, March 04, 2005 11:58 PM
Subject: RE: Redistribution in 3 protocols
> Dillon,
>
> GS people could help you better if you posted your config's and the output
> of some show ip route commands.
>
> But, in general, it's a good idea to clear your ip route tables after
making
> routing configuration changes. Sometimes, that clears up an apparent
> problem.
>
> HTH, Tim
>
>
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> Dillon Yang
> Sent: Friday, March 04, 2005 10:43 AM
> To: Group Study
> Subject: Redistribution in 3 protocols
>
> Hi, dear all:
>
>
> I'm confused by this topology:
>
> |ospf----------(s0/1)R3(s0/2)-----------isis-
> | | ospf |
> | | |
> | |------eigrp------R1(s0/2)---------isis| |
> | | | |
> (1)(2) (s0/1)(s0/2)
>
R2(3)-----eigrp-----------------------(s0/1)R4------150.100.2.3-------Ethern
> et
>
>
> Though I shutdown the e0 of R4, the address 150.100.2.0/24 is still seen
in
> the 3 protocol.
> I can not prevent routing loop in the case by using "distance xxx
> address/mask <acl>".
> Any advice?
>
> dillon
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Sun Apr 03 2005 - 17:56:41 GMT-3