Re: Redistribute BGP into an IGP(OSPF/EIGRP)!

From: Vazman@aol.com
Date: Thu Jan 20 2005 - 02:09:08 GMT-3


Couple of things to remember -

1.R2 needs to be a route reflector, since you cannot have full mesh and cannot use confederation.
2. You need to mutually redistribute between OSPF and EIGRP.
3. Set the router id's on all routers in OSPF and BGP ..to be the same.
4. You dont need next hop self on R2 since you are mutually redistributing.
5. R3 is going to learn the route via external EIGRP (AD=170) and iBGP (AD=200), so it will prefer EIGRP. If you need to learn it via iBGP, then you need to modify the distance of EIGRP or BGP.

 
This is what i got on my lab. The addressing is different.

r1

interface Loopback1
 ip address 192.168.1.1 255.255.255.0
 ip ospf network point-to-point
!
interface Serial1
 ip address 12.12.12.1 255.255.255.0
 clockrate 2000000
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 12.12.12.0 0.0.0.255 area 0
 network 192.168.1.0 0.0.0.255 area 0
!
router bgp 1
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 network 192.168.1.0
 neighbor 12.12.12.2 remote-as 1

r2

interface Serial0
 ip address 12.12.12.2 255.255.255.0
!
interface Serial1
 ip address 23.23.23.2 255.255.255.0
 clockrate 2000000
!
router eigrp 1
 redistribute ospf 1 metric 1500 10 255 10 1500
 network 23.23.23.0 0.0.0.255
 no auto-summary
 no eigrp log-neighbor-changes
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 redistribute eigrp 1 subnets
 network 12.12.12.0 0.0.0.255 area 0
!
router bgp 1
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 12.12.12.1 remote-as 1
 neighbor 12.12.12.1 route-reflector-client
 neighbor 23.23.23.3 remote-as 1
 neighbor 23.23.23.3 route-reflector-client
 neighbor 23.23.23.3 next-hop-self

r3

interface Serial1
 ip address 23.23.23.3 255.255.255.0
!
router eigrp 1
 network 23.23.23.0 0.0.0.255
 no auto-summary
 no eigrp log-neighbor-changes
!
router bgp 1
 bgp router-id 3.3.3.3
 bgp cluster-id 387389187
 bgp log-neighbor-changes
 neighbor 23.23.23.2 remote-as 1

R3#sh ip route eigrp
     12.0.0.0/24 is subnetted, 1 subnets
D EX 12.12.12.0 [170/2221056] via 23.23.23.2, 00:07:53, Serial1
D EX 192.168.1.0/24 [170/2221056] via 23.23.23.2, 00:07:53, Serial1
R3#sh ip bgp sum
BGP router identifier 3.3.3.3, local AS number 1
BGP table version is 2, main routing table version 2
1 network entries and 1 paths using 133 bytes of memory
1 BGP path attribute entries using 60 bytes of memory
1 BGP rrinfo entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 1/22 prefixes, 2/1 paths, scan interval 15 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
23.23.23.2 4 1 36 32 2 0 0 00:09:19 1
R3#
R3#
R3#sh ip bgp
BGP table version is 2, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
*>i192.168.1.0 23.23.23.2 0 100 0 i
R3#
R3#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
R3#



This archive was generated by hypermail 2.1.4 : Wed Feb 02 2005 - 22:10:24 GMT-3