Re: Multicasting ping test(pim sparse-dense-mode) -> config &

From: cm1231@hic.co.kr
Date: Fri Dec 24 2004 - 01:08:25 GMT-3


thank you for interesting my problem.

check Following configuration and ip mroute table

################################################
############ below r1 configuration ########
################################################
r1#sh run
Building configuration...

Current configuration : 927 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
enable password hic
!
!
!
!
!
ip subnet-zero
!
ip multicast-routing
!
!interface Ethernet0
 ip address 172.16.0.1 255.255.255.0
 ip pim sparse-dense-mode
 ip igmp join-group 231.1.1.1
 no keepalive
!
interface Serial0
 ip address 10.0.0.2 255.255.255.252
 ip pim sparse-dense-mode
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
router eigrp 100
 network 10.0.0.0
 network 172.16.0.0
 no auto-summary
 no eigrp log-neighbor-changes
!
router rip
 network 10.0.0.0
  network 172.16.0.0
!
ip classless
ip http server
ip pim rp-address 1.1.1.1
ip pim spt-threshold infinity
!
access-list 110 deny tcp any eq telnet any
access-list 110 deny tcp any any eq telnet
access-list 110 permit ip any any
!
line con 0
line aux 0
line vty 0 4
 no login
!
end

r1#

################################################
############ below RP configuration ########
################################################
RP#sh run
Building configuration...

Current configuration : 1561 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RP
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
ip host r1 10.0.0.2
!
ip multicast-routing
ip cef
!
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.255
!
interface ATM0/0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface Serial4/0
 ip address 10.0.0.1 255.255.255.252
 ip pim sparse-dense-mode
 no ip mroute-cache
 serial restart-delay 0
 clockrate 2000000
!
interface Serial4/1
 no ip address
 ip pim sparse-dense-mode
 no ip mroute-cache
 shutdown
 serial restart-delay 0
  clockrate 2000000
!
interface Serial4/2
 no ip address
 ip pim sparse-dense-mode
 shutdown
 serial restart-delay 0
!
interface Serial4/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial5/0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial5/0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial5/0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial5/0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet5/1/0
 no ip address
 shutdown
 half-duplex
!
router eigrp 100
 network 1.1.1.1 0.0.0.0
 network 1.0.0.0
 network 0.0.0.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
no ip http server
ip pim rp-address 1.1.1.1
!
access-list 110 deny tcp any eq telnet any
access-list 110 deny tcp any any eq telnet
access-list 110 permit ip any any
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

RP#

########################################################
############ show ip mroute table - before ping ########
############ below mroute table is r1 ########
########################################################
r1# s ip mro
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned
       R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT
       M - MSDP created entry, X - Proxy Join Timer Running
       A - Candidate for MSDP Advertisement
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 00:00:29/00:00:00, RP 1.1.1.1, flags: SCL
  Incoming interface: Serial0, RPF nbr 10.0.0.1
  Outgoing interface list:
    Ethernet0, Forward/Sparse-Dense, 00:00:29/00:02:30

(*, 231.1.1.1), 00:00:29/00:00:00, RP 1.1.1.1, flags: SCL
  Incoming interface: Serial0, RPF nbr 10.0.0.1
  Outgoing interface list:
    Ethernet0, Forward/Sparse-Dense, 00:00:29/00:02:30

############ below mroute table is RP ########
RP#sh ip mro
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned
       R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT
       M - MSDP created entry, X - Proxy Join Timer Running
       A - Candidate for MSDP Advertisement
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 00:00:59/00:00:00, RP 1.1.1.1, flags: SJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial4/0, Forward/Sparse-Dense, 00:00:59/00:02:47

(*, 231.1.1.1), 00:00:42/00:02:47, RP 1.1.1.1, flags: S
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial4/0, Forward/Sparse-Dense, 00:00:42/00:02:47

########################################################
############ show ip mroute table - after ping ########
############ below mroute table is r1 ########
########################################################
r1#p ip
Target IP address: 231.1.1.1
Repeat count [1]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Interface [All]: serial0
Time to live [255]:
Source address: 10.0.0.2
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 231.1.1.1, timeout is 2 seconds:
.
r1#
2d00h: %CI-3-PSFAIL: Power supply 1 failures ip mro
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned
       R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT
       M - MSDP created entry, X - Proxy Join Timer Running
       A - Candidate for MSDP Advertisement
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 00:02:22/00:00:00, RP 1.1.1.1, flags: SCL
  Incoming interface: Serial0, RPF nbr 10.0.0.1
  Outgoing interface list:
    Ethernet0, Forward/Sparse-Dense, 00:02:22/00:02:13

(*, 231.1.1.1), 00:02:22/00:00:00, RP 1.1.1.1, flags: SCL
  Incoming interface: Serial0, RPF nbr 10.0.0.1
  Outgoing interface list:
    Ethernet0, Forward/Sparse-Dense, 00:02:22/00:02:19

(10.0.0.2, 231.1.1.1), 00:00:22/00:03:07, flags: CLT
  Incoming interface: Serial0, RPF nbr 10.0.0.1, Registering
  Outgoing interface list:
    Ethernet0, Forward/Sparse-Dense, 00:00:23/00:02:37

############ below mroute table is RP ########
RP#s ip mro
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned
       R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT
       M - MSDP created entry, X - Proxy Join Timer Running
       A - Candidate for MSDP Advertisement
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 00:03:01/00:00:00, RP 1.1.1.1, flags: SJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial4/0, Forward/Sparse-Dense, 00:03:01/00:02:44

(*, 231.1.1.1), 00:02:44/00:02:59, RP 1.1.1.1, flags: S
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial4/0, Forward/Sparse-Dense, 00:02:44/00:02:43

(10.0.0.2, 231.1.1.1), 00:01:24/00:01:35, flags: PTX
  Incoming interface: Serial4/0, RPF nbr 10.0.0.2
  Outgoing interface list: Null

############################################################################
############ show ip mroute table - ping and after a few minutes ########
############ below mroute table is r1 ########
############################################################################

r1#ip mro
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned
       R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT
       M - MSDP created entry, X - Proxy Join Timer Running
       A - Candidate for MSDP Advertisement
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 00:05:19/00:00:00, RP 1.1.1.1, flags: SCL
  Incoming interface: Serial0, RPF nbr 10.0.0.1
  Outgoing interface list:
    Ethernet0, Forward/Sparse-Dense, 00:05:19/00:02:21

(*, 231.1.1.1), 00:05:19/00:00:00, RP 1.1.1.1, flags: SCL
  Incoming interface: Serial0, RPF nbr 10.0.0.1
  Outgoing interface list:
    Ethernet0, Forward/Sparse-Dense, 00:05:19/00:02:20

(10.0.0.2, 231.1.1.1), 00:03:19/00:00:10, flags: CLT
  Incoming interface: Serial0, RPF nbr 10.0.0.1, Registering
  Outgoing interface list:
    Ethernet0, Forward/Sparse-Dense, 00:03:19/00:02:20
 

############ below mroute table is RP ########
RP#s ip mro
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned
       R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT
       M - MSDP created entry, X - Proxy Join Timer Running
       A - Candidate for MSDP Advertisement
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 00:05:18/00:00:00, RP 1.1.1.1, flags: SJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial4/0, Forward/Sparse-Dense, 00:05:18/00:03:26

(*, 231.1.1.1), 00:05:02/00:03:24, RP 1.1.1.1, flags: S
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial4/0, Forward/Sparse-Dense, 00:05:02/00:03:24

(10.0.0.2, 231.1.1.1), 00:00:05/00:03:24, flags: PT
  Incoming interface: Serial4/0, RPF nbr 10.0.0.2, Registering
  Outgoing interface list: Null



This archive was generated by hypermail 2.1.4 : Mon Jan 03 2005 - 10:31:30 GMT-3