From: alsontra@hotmail.com
Date: Thu Dec 16 2004 - 05:33:34 GMT-3
Andrew,
Completely reconfigured the tunnel using adjacent interfaces and removed
"tunnel mode ipv6ip". ISIS then finally formed an adjacency. Apparently ISIS
runs over the L2 so I had to passive interface the adjacent interfaces and
use the same adj interfaces to build the tunnel. Same as CLNS for IPv4...
Additional information that lead to the solution:
"IS-IS for IPv6 on an IPv6 tunnel requires GRE tunnel, it can't work with
IPv6 configured tunnel as ISIS runs directly over the data link layer"
http://www.cisco.com/warp/public/732/Tech/ipv6/docs/is-isv6.ppt
!
R3***
interface Tunnel0
no ip address
ipv6 address 2001:CC1E:1:4545::3/64
ipv6 rip CISCO enable
ipv6 rip CISCO summary-address 2001:4444::/48
ipv6 router isis CISCO
tunnel source Ethernet0/1
tunnel destination 190.1.1.5
router isis CISCO
net 12.0003.0003.0003.00
is-type level-2-only
log-adjacency-changes
passive-interface Ethernet0/1
!
R5***
!
interface Tunnel0
no ip address
ipv6 address 2001:CC1E:1:4545::5/64
ipv6 rip CISCO enable
ipv6 router isis CISCO
tunnel source Ethernet0/1
tunnel destination 190.1.1.3
!
router isis CISCO
net 23.0005.0005.0005.00
is-type level-2-only
passive-interface Ethernet0/1
*******R5 output
R5#sh clns nei
System Id Interface SNPA State Holdtime Type
Protocol
R3 Tu0 190.1.1.3 Up 27 L2 IS-IS
R5#sh isis da de
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R3.00-00 0x00000003 0x4D1D 1197 0/0/0
Area Address: 12
NLPID: 0x8E
Hostname: R3
IPv6 Address: 2001:EEEE:EEEE::3
Metric: 10 IS R5.00
Metric: 0 IPv6 2001::/64
Metric: 10 IPv6 2001:CC1E:1:4545::/64
Metric: 10 IPv6 2001:EEEE:EEEE::3/128
R5.00-00 * 0x00000003 0xDC3E 687 0/0/0
Area Address: 23
NLPID: 0x8E
Hostname: R5
IPv6 Address: 2001:CC1E:1:4545::5
Metric: 10 IS R3.00
Metric: 0 IPv6 2001::/64
Metric: 10 IPv6 2001:CC1E:1:4545::/64
********R3 output
R3#sh clns nei
System Id Interface SNPA State Holdtime Type
Protocol
R5 Tu0 190.1.1.5 Up 29 L2 IS-IS
R3#sh isis da de
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R3.00-00 * 0x00000003 0x4D1D 1153 0/0/0
Area Address: 12
NLPID: 0x8E
Hostname: R3
IPv6 Address: 2001:EEEE:EEEE::3
Metric: 10 IS R5.00
Metric: 0 IPv6 2001::/64
Metric: 10 IPv6 2001:CC1E:1:4545::/64
Metric: 10 IPv6 2001:EEEE:EEEE::3/128
R5.00-00 0x00000003 0xDC3E 639 0/0/0
Area Address: 23
NLPID: 0x8E
Hostname: R5
IPv6 Address: 2001:CC1E:1:4545::5
Metric: 10 IS R3.00
Metric: 0 IPv6 2001::/64
Metric: 10 IPv6 2001:CC1E:1:4545::/64
ISIS plagues me no more!
TIA
Al
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Edwards, Andrew M
Sent: Wednesday, December 15, 2004 2:02 PM
To: alsontra@hotmail.com; Group Study
Subject: RE: IPV6 Recursive Routing - ATM FRAME ISDN?
Yes, that is what I experienced....
I couldn't get ISIS or OSPF over the tunnels. I think its something to
do with the tunnel thinking behaving like an NBMA interface (at least
that's what the doccd says). Only problem is I'm not sure how to tacle
the link-local mappings for tunnel interfaces....?
-----Original Message-----
From: alsontra@hotmail.com [mailto:alsontra@hotmail.com]
Sent: Wednesday, December 15, 2004 2:08 PM
To: Edwards, Andrew M; 'Group Study'
Subject: RE: IPV6 Recursive Routing - ATM FRAME ISDN?
Cool. Statically defining the local-link addresses would seem prudent. I
will do so in the future.
I've used the following protocols over v4 tunnels.
NAT-PT v4v6, v6v4 <---good
MP BGP IPV6 <---good
RIPng <---good
ISIS <--- can't seem to get it run over a tunnel
OSPFv3 <---haven't tried
TIA
Al
-----Original Message-----
From: Edwards, Andrew M [mailto:andrew.m.edwards@boeing.com]
Sent: Wednesday, December 15, 2004 9:33 AM
To: alsontra@hotmail.com; Group Study
Subject: RE: IPV6 Recursive Routing - ATM FRAME ISDN?
Alsontra,
I have found that link-local addresses combined with the neighbor
discovery process (ICMP) in IPv6 is the equivalent of ARP in IPv4.
Basically you don't have ARP for IPv6. Instead you get the combined
action of neighbor discovery and link-local addresses.
It is my opinion when you look at NBMA interfaces for IPv6, that you
statically set the link-local address so that the remote router doesn't
change it on you after a reboot (remember that the link-local address
setting procedure is dynamic to a device). And, since frame relay
interfaces/serial/atm don't have a mac address associated with them,
they will have to take one from the local router pool thereby meaning it
could change. And statically mapping link-local addresses on one end
that can change on the other is a bad idea and something I think you
might be enticed to do in a lab environment.
My 2cents.
Anyone had any luck with the various IPv6 over ipv4 tunneling
technologies and running IGPs across them?
andy
-----Original Message-----
From: alsontra@hotmail.com [mailto:alsontra@hotmail.com]
Sent: Tuesday, December 14, 2004 7:49 PM
To: 'Group Study'
Subject: IPV6 Recursive Routing - ATM FRAME ISDN?
All
When IPv6 is configured on a frame-relay interface the address is
recursively resolved to the local-link address of the serial interface.
I'm finding that it's almost always necessary to map the local link
address. Is this the case with all media requiring L2 resolution?
How does ATM handle this type of behavior?
TIA
Alsontra
--- Outgoing mail is certified Virus Free. Checked by AVG anti-virus system (http://www.grisoft.com). Version: 6.0.725 / Virus Database: 480 - Release Date: 7/20/2004
This archive was generated by hypermail 2.1.4 : Mon Jan 03 2005 - 10:31:27 GMT-3