Re: How to enable DNS request forward? [Cisco Gurus Help]

From: Larry Roberts (Groupstudy@american-hero.com)
Date: Thu Dec 16 2004 - 00:20:55 GMT-3


I will take a stab at it, however I don't think I complete understand
your question, or what your wanting to accomplish.

I'm assuming your running routing on this PC that separates your
Internet connection from your L2 switch. ( Make double sure its properly
locked down, or your PC will soon be "owned" if you don't have a
Firewall on it )

To get the router to act as a DNS client, you simply need to do 2 things.

First, enable dns lookups.

R1(config)#ip domain-lookup

Secondly, specify your DNS server

R1(config)#ip name-server 192.168.0.2

Your configuration already had step 2, so you should be able to just
enable dns lookups and get the router to work as a client.

Your configuration only shows 1 interface, so I don't understand what
you mean by "forward" dns request/replies?

Assuming that you just cut part of the configuration out:

interface Ethernet0/0
  ip address x.y.z.a 255.255.255.0 ( or whatever mask you use )
  ip helper-address 192.168.0.2
!
interface Ethernet0/1
  ip address 192.168.0.4 255.255.255.0
  ip helper-address 192.168.0.2

The ip helper-address on E0/1 isn't needed since its the DNS/DHCP server
  is on this interface.
DNS requests/replies aren't broadcasts (normally) so the helper address
is only needed for DHCP req's and ack's.

On the clients off of Ethernet0/0, you should have a default-gateway
pointing to the ip address of the router's e0/0 interface. If your using
DHCP for this subnet, then just set the default-gateway to be the IP of
the routers E0/0 interface on the DHCP server scope.

On the server, add a route for this e0/0 subnet pointing to 192.168.0.4
This will tell the server how to get to those clients. ( via R1 )

Finally, on the clients, just set the DNS server to be 192.168.0.2

I may be WAY off base on what you are asking though.

zc521@msn.com wrote:
> Good morning to all Cisco gurus on the list
> Would you take couple of mins when you drink your coffee to have a look this plz?
>
> I have a server connecting to Internet using usb modem. This server link to a layer-2 unmanaged switch to provide Internet access to me and my flatmate. Now I want to config a cisco 3620 router to stand in the middle of my pc and that layer-2 switch to forward dns request and reply from the server.
>
> I tried to search on groupstudy and cisco website for configuration example or something useful, but with no luck. Also I didn!/t found anything useful in IOS documentation.
>
> My first question for all Cisco gurus here is;
> Where you can find useful information about an unfamiliar task, for example, find something about configure cisco 3550switch/3600 router to forward dns request/reply. I find myself lost in thousands of lines of commands in IOS documentation.
>
> Second question is how could I enable dns request/reply on cisco 3620?
> --------------------
> Config on my PC
> IP ADD 192.168.0.1/24
> Default-gateway 192.168.0.4
> DNS Server 192.168.0.4
> ----------------
> Config on Server
> IP ADD 192.168.0.2/24
> ----------------
> Config on Cisco
> R1#sh run
> Building configuration...
>
> Current configuration : 1074 bytes
> !
> version 12.2
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname R1
> !
> !
> ip subnet-zero
> !
> !
> no ip domain-lookup
> ip name-server 192.168.0.2
> !
> ip audit notify log
> ip audit po max-events 100
> !
> call rsvp-sync
> !
> interface Ethernet0/1
> ip address 192.168.0.4 255.255.255.0
> ip helper-address 192.168.0.2
> half-duplex
> !
> !
> ip default-gateway 192.168.0.2
> ip classless
> ip forward-protocol udp bootpc
> ip forward-protocol udp bootps
> ip http server
> !
> dial-peer cor custom
> !
> line con 0
> exec-timeout 0 0
> line aux 0
> line vty 0 4
> exec-timeout 0 0
> no login
> transport input lat pad v120 lapb-ta mop telnet rlogin udptn nasi ssh
> !
> end
>
> Anyone can help me to figure out this? Thanks to you all for your time.
> Have a nice day and happy working. :#
>
> Chen
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Mon Jan 03 2005 - 10:31:27 GMT-3