Re: How to enable DNS request forward? [Cisco Gurus Help]

From: Larry Roberts (groupstudy@american-hero.com)
Date: Thu Dec 16 2004 - 13:19:02 GMT-3


OK, couple of issues.

1) Your router won't let your assign IP's on the same subnet to
different router interfaces so your configuration won't work.
2) you have two interfaces e0/1. I assumed the second is actuall e1/0

Lets do this:

interface e0/0
ip address 10.0.3.1 255.255.255.0
ip helper-address 192.168.0.2

interface e0/1
ip address 10.0.4.1 255.255.255.0
ip helper-address 192.168.0.2

interface e1/0
ip address 192.168.0.4 255.255.255.0

the PC off off E0/0 should have an IP address in the range of
10.0.3.2->10.0.3.254 with a default-gateway of 10.0.3.1

the PC off of E0/1 should have an IP address in the range of
10.0.4.2->10.0.4.254 with a default-gateway of 10.0.4.1

on the server, drop to a command prompt and type "route" without the
quotes obviously.

this will give you the options you need. to make this route persistant,
add -p

route -p add 10.0.3.0 mask 255.255.255.0 192.168.0.4
route -p add 10.0.4.0 mask 255.255.255.0 192.168.0.4

Your more likely to get a response if you post questions like this to
the general security list. This list, as well as the "security" list is
for people who have already passed the CCIE written. Most people on this
list tend to ignore requests that don't directly relate to CCIE
certification.

zc521@msn.com wrote:
> Hi Larry thank you for your answer in first place.
> Sorry for that Layer-2 switch brings more complexity to this problem. Forget that switch let me simplify this.

The server links to internet via a USB modem [Not RJ-45]. I installed
sygate home network software to share the connection.
Now what I want to do is link 2 pcs to this R1s E0/0 and E0/1
interface, and have R1s E1/0 interface link to server. In
order to allow this 2 pcs to surf the internet, I need to enable dns
forward/reply on R1(I use static ip addressing).
>
> According to your answer. I assume R1 have the following configuration.
>
> R1#
> ip domain-lookup
> ip name-server 192.168.0.2
> ip default-gateway 192.168.0.2
>
> interface Ethernet0/0 ---- this to pc 1 [DNS point to 192.168.0.2]
> ip address 10.0.0.3 255.255.255.0
> !
> interface Ethernet0/1 ---- this to pc 2 [DNS point to 192.168.0.2]
> ip address 10.0.0.4 255.255.255.0
> !
> interface Ethernet0/1 ---- this to server [ server ip 192.168.0.2/24]
> ip address 192.168.0.4 255.255.255.0
> ip helper-address 192.168.0.2
> !
>
> Hope this configuration works.
>
> Last thing, On the server, add a route for this e0/0 subnet pointing to 192.168.0.4
> This will tell the server how to get to those clients. ( via R1 )
> Any idea how to do this on windows 2003 ?
>
> Thanks again larry, this really helps.
> Chen
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

-- 
Thanks,

Larry



This archive was generated by hypermail 2.1.4 : Mon Jan 03 2005 - 10:31:27 GMT-3