Re: ISIS L1 and L2 route

From: Wei Zou (wzou) (wzou@cisco.com)
Date: Tue Aug 31 2004 - 16:03:25 GMT-3


Hi,
I have attached my configurations, could you tell me why the route in R2 is L1?

Thanks
Wei

At 08:04 AM 8/31/2004 -0400, gladston@br.ibm.com wrote:
>Are you redistributing into ISIS?
>Where the L2 routes come from?
>
>_______________________________________________________________________
>Please help support GroupStudy by purchasing your study materials from:
>http://shop.groupstudy.com
>
>Subscription information may be found at:
>http://www.groupstudy.com/list/CCIELab.html
Topology:

R1 --- R2

************ R1 **************

interface Loopback0
 ip address 200.0.0.1 255.255.255.255

interface Loopback1
 ip address 150.50.18.1 255.255.255.0

interface Ethernet0/0
 ip address 150.50.200.1 255.255.255.0

interface Ethernet1/0
 ip address 150.50.17.1 255.255.255.0
 ip router isis
 isis password ipexpert level-1
 isis hello-multiplier 5
 isis hello-interval 15
!

router isis
 net 49.0001.0000.0000.000a.00
 redistribute connected route-map conet2isis
 passive-interface Ethernet0/0
 passive-interface Loopback0
 set-overload-bit
!

access-list 2 permit 200.0.0.1
access-list 2 permit 150.50.200.0 0.0.0.255
access-list 2 permit 150.50.18.0 0.0.0.255
route-map conet2isis permit 10
 match ip address 2
!

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     200.0.0.0/32 is subnetted, 7 subnets
C 200.0.0.1 is directly connected, Loopback0
i L2 200.0.0.2 [115/10] via 150.50.17.2, Ethernet1/0

     150.50.0.0/16 is variably subnetted, 9 subnets, 4 masks
C 150.50.200.0/24 is directly connected, Ethernet0/0
C 150.50.17.0/24 is directly connected, Ethernet1/0
C 150.50.18.0/24 is directly connected, Loopback1
i L2 150.50.24.0/24 [115/10] via 150.50.17.2, Ethernet1/0
i L2 150.50.100.0/27 [115/10] via 150.50.17.2, Ethernet1/0

************* R2 *********************

interface Loopback0
 ip address 200.0.0.2 255.255.255.255
!
interface Ethernet1/0
 ip address 150.50.17.2 255.255.255.0
 ip router isis
 isis password ipexpert level-1
 isis hello-multiplier 5
 isis hello-interval 15

interface Serial2/0.256 multipoint
 ip address 150.50.100.2 255.255.255.224
 ip ospf authentication-key ipexpert
 frame-relay map ip 150.50.100.2 105
 frame-relay map ip 150.50.100.5 105 broadcast
 frame-relay map ip 150.50.100.6 106 broadcast
!

router isis
 net 49.0001.0000.0000.000b.00
 redistribute connected route-map conet2isis
 redistribute rip metric 20 route-map rip2isis
 redistribute ospf 100 metric 20
 set-overload-bit

R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     200.0.0.0/32 is subnetted, 7 subnets

i L1 200.0.0.1 [115/10] via 150.50.17.1, Ethernet1/0
C 200.0.0.2 is directly connected, Loopback0
     150.50.0.0/16 is variably subnetted, 9 subnets, 4 masks
i L1 150.50.200.0/24 [115/10] via 150.50.17.1, Ethernet1/0
C 150.50.17.0/24 is directly connected, Ethernet1/0
i L2 150.50.18.0/24 [115/10] via 150.50.17.1, Ethernet1/0
C 150.50.24.0/24 is directly connected, Serial2/0.24
C 150.50.100.0/27 is directly connected, Serial2/0.256



This archive was generated by hypermail 2.1.4 : Fri Sep 03 2004 - 07:02:51 GMT-3