PBR w/ MULTICAST and BROADCAST

From: trouse@cisco.com
Date: Thu Jul 15 2004 - 12:36:00 GMT-3


Guys can you PBR multicast and broadcast?

Trying to send UNICAST RIP UPDATES without using neighbor command, NAT or anything special just PBR. Will it work? if not why now?

interface Ethernet0
 ip address 172.16.16.6 255.255.255.0
 media-type 10BaseT
!
interface Ethernet1
 no ip address
 media-type 10BaseT
!
interface TokenRing0
 no ip address
 shutdown
!
interface FastEthernet0
 no ip address
 half-duplex
!
router rip
 version 2
 passive-interface default
 no passive-interface Ethernet0
 network 172.16.0.0
!
ip local policy route-map LOCALRIP
ip nat pool RIP 172.16.16.1 172.16.16.1 netmask 255.255.255.0
ip nat inside destination list 1 pool RIP
ip classless
no ip http server
!
access-list 1 permit 224.0.0.9 log
access-list 101 permit udp any any eq rip
access-list 101 permit udp any any eq rip log
access-list 101 permit udp any host 224.0.0.9 log
access-list 102 permit udp any host 224.0.0.9 log
route-map LOCALRIP permit 10
 match ip address 101
 set interface Ethernet0
 set ip next-hop 172.16.16.1
!
route-map LOCALRIP permit 20
 match ip address 102
 set interface Ethernet0
 set ip next-hop 172.16.16.1

DEBUGS
nm6#debug ip packet
IP packet debugging is on
nm6#debug ip ri
nm6#debug ip rip
RIP protocol debugging is on
nm6#debug ip po
nm6#debug ip policy
Policy routing debugging is on

nm6#sh debug
Generic IP:
  IP packet debugging is on
IP routing:
  RIP protocol debugging is on
Policy Routing:
  Policy routing debugging is on
nm6#
06:33:03: RIP: sending v2 update to 224.0.0.9 via Ethernet0 (172.16.16.6)
06:33:03: RIP: build update entries
06:33:03: 172.16.100.0/24 via 0.0.0.0, metric 1, tag 0
06:33:03: IP: s=172.16.16.6 (local), d=224.0.0.9 (Ethernet0), len 52, sending broad/multicast

PING IS PBRed... but then it default to normal forwarding.
===========================================
nm6#ping 172.16.16.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.16.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
nm6#
06:36:51: IP: s=172.16.16.6 (local), d=172.16.16.1, len 100, policy rejected -- normal forwarding
06:36:51: ICMP type=8, code=0
06:36:51: IP: s=172.16.16.6 (local), d=172.16.16.1 (Ethernet0), len 100, sending
06:36:51: ICMP type=8, code=0
06:36:51: IP: s=172.16.16.1 (Ethernet0), d=172.16.16.6 (Ethernet0), len 100, rcvd 3
06:36:51: ICMP type=0, code=0
06:36:51: IP: s=172.16.16.6 (local), d=172.16.16.1, len 100, policy rejected -- normal forwarding
06:36:51: ICMP type=8, code=0
06:36:51: IP: s=172.16.16.6 (local), d=172.16.16.1 (Ethernet0), len 100, sending
06:36:51: ICMP type=8, code=0
06:36:51: IP: s=172.16.16.1 (Ethernet0), d=172.16.16.6 (Ethernet0), len 100, rcvd 3
06:36:51: ICMP type=0, code=0
06:36:51: IP: s=172.16.16.6 (local), d=172.16.16.1, len 100, policy rejected -- normal forwarding
06:36:51: ICMP type=8, code=0
06:36:51: IP: s=172.16.16.6 (local), d=172.16.16.1 (Ethernet0), len 100, sending
06:36:51: ICMP type=8, code=0
06:3
6:51: IP: s=172.16.16.1 (Ethernet0), d=172.16.16.6 (Ethernet0), len 100, rcvd 3
06:36:51: ICMP type=0, code=0
06:36:51: IP: s=172.16.16.6 (local), d=172.16.16.1, len 100, policy rejected -- normal forwarding
06:36:51: ICMP type=8, code=0
06:36:51: IP: s=172.16.16.6 (local), d=172.16.16.1 (Ethernet0), len 100, sending
06:36:51: ICMP type=8, code=0
06:36:51: IP: s=172.16.16.1 (Ethernet0), d=172.16.16.6 (Ethernet0), len 100, rcvd 3
06:36:51: ICMP type=0, code=0
06:36:51: IP: s=172.16.16.6 (local), d=172.16.16.1, len 100, policy rejected -- normal forwarding
06:36:51: ICMP type=8, code=0
06:36:51: IP: s=172.16.16.6 (local), d=172.16.16.1 (Ethernet0), len 100, sending
06:36:51: ICMP type=8, code=0
06:36:51: IP: s=172.16.16.1 (Ethernet0), d=172.16.16.6 (Ethernet0), len 100, rcvd 3
06:36:51: ICMP type=0, code=0nm6#

RIP IS NOT PBR at all
=================
nm6#
06:37:15: RIP: sending v2 update to 224.0.0.9 via Ethernet0 (172.16.16.6)
06:37:15: RIP: build update entries
06:37:15: 172.16.100.0/24 via 0.0.0.0, metric 1, tag 0
06:37:15: IP: s=172.16.16.6 (local), d=224.0.0.9 (Ethernet0), len 52, sending broad/multicast
06:37:15: UDP src=520, dst=520
nm6#
06:37:40: RIP: sending v2 update to 224.0.0.9 via Ethernet0 (172.16.16.6)
06:37:40: RIP: build update entries
06:37:40: 172.16.100.0/24 via 0.0.0.0, metric 1, tag 0
06:37:40: IP: s=172.16.16.6 (local), d=224.0.0.9 (Ethernet0), len 52, sending broad/multicast
06:37:40: UDP src=520, dst=520
nm6#
06:38:06: RIP: sending v2 update to 224.0.0.9 via Ethernet0 (172.16.16.6)
06:38:06: RIP: build update entries
06:38:06: 172.16.100.0/24 via 0.0.0.0, metric 1, tag 0
06:38:06: IP: s=172.16.16.6 (local), d=224.0.0.9 (Ethernet0), len 52, sending broad/multicast
06:38:06: UDP src=520, dst=520
nm6#
06:38:34: RIP: sending v2 update to 224.0.0.9 via Ethernet0 (172.16.16.6)
06:38:34: RIP: build update entries
06:38:34: 172.16.100.0/24 via 0.0.0.0, metric 1, tag 0
06:38:34: IP: s=172.16.16.6 (local), d=224.0.0.9 (Ethernet0), len 52, sending broad/multicast
06:38:34: UDP src=520, dst=520
nm6#
06:39:01: RIP: sending v2 update to 224.0.0.9 via Ethernet0 (172.16.16.6)
06:39:01: RIP: build update entries
06:39:01: 172.16.100.0/24 via 0.0.0.0, metric 1, tag 0
06:39:01: IP: s=172.16.16.6 (local), d=224.0.0.9 (Ethernet0), len 52, sending broad/multicast
06:39:01: UDP src=520, dst=520
nm6#
06:39:30: RIP: sending v2 update to 224.0.0.9 via Ethernet0 (172.16.16.6)
06:39:30: RIP: build update entries
06:39:30: 172.16.100.0/24 via 0.0.0.0, metric 1, tag 0
06:39:30: IP: s=172.16.16.6 (local), d=224.0.0.9 (Ethernet0), len 52, sending broad/multicast
06:39:30: UDP src=520, dst=520



This archive was generated by hypermail 2.1.4 : Sun Aug 01 2004 - 10:11:56 GMT-3