From: Vazman@aol.com
Date: Sat May 15 2004 - 02:00:00 GMT-3
Hello,
I am working on a lab, which has R5 and R6 connected via a frame-relay link and isdn as backup. I have configured dialer-watch on R5 to watch the loopback on R6 (129.6.6.6/32). When I shut down the serial interface on R6, R5 DOES NOT trigger the call. I know my ISDN is working as I can ping the remote interface and bring the link up. Also, ran a debug dialer on R5 and it sees that the watched network is down but does not place the call. I think I have all the required config for dialer watch on R5 (dialer watch-group, dialer watch-list and the dialer map for the watched network). I also checked the network that I am watching via show ip route (see below)
Any advice?
Here is my config for R5 and R6 and output from debug dialer
R5#
01:00:29: DDR: Dialer Watch: watch-group = 1
01:00:29: DDR: network 129.6.6.6/255.255.255.255 DOWN,
01:00:29: DDR: primary DOWN
01:00:29: DDR: Dialer Watch: Dial Reason: Primary of group 1 DOWN
01:00:29: DDR: Dialer Watch: watch-group = 1,
R5#
R5#sir os
129.3.0.0/32 is subnetted, 1 subnets
O 129.3.3.3 [110/11] via 192.168.4.3, 01:10:24, Ethernet0
129.6.0.0/32 is subnetted, 1 subnets
O IA 129.6.6.6 [110/65] via 192.168.2.6, 00:00:18, Serial0.2
129.13.0.0/32 is subnetted, 1 subnets
O 129.13.13.13 [110/65] via 192.168.5.13, 00:00:18, Serial0.1
62.0.0.0/24 is subnetted, 1 subnets
O E2 62.9.1.0 [110/20] via 192.168.2.6, 00:00:18, Serial0.2
R5#
R5#sh run
Building configuration...
Current configuration : 2913 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R5
!
logging rate-limit console 10 except errors
!
username R6 password 0 cisco
ip subnet-zero
no ip finger
no ip domain-lookup
!
isdn switch-type basic-ni
cns event-service server
!
!
!
!
!
interface Loopback0
ip address 129.5.5.5 255.255.255.0
!
interface Ethernet0
ip address 192.168.4.5 255.255.255.0
!
interface Serial0
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
frame-relay lmi-type cisco
!
interface Serial0.1 point-to-point
ip address 192.168.5.5 255.255.255.240
ip ospf message-digest-key 1 md5 cisco
frame-relay interface-dlci 504
!
interface Serial0.2 point-to-point
ip address 192.168.2.5 255.255.255.128
ip ospf message-digest-key 1 md5 cisco
frame-relay interface-dlci 506
!
interface Serial1
no ip address
shutdown
!
interface BRI0
ip address 192.168.6.1 255.255.255.252
encapsulation ppp
dialer map ip 129.6.6.6 name R6 broadcast 4930622
dialer map ip 129.6.6.6 name R6 broadcast 4930623
dialer map ip 192.168.6.2 name R6 broadcast 4930622
dialer map ip 192.168.6.2 name R6 broadcast 4930623
dialer load-threshold 1 either
dialer watch-group 1
dialer-group 1
isdn switch-type basic-ni
isdn spid1 81049306240101 4930624
isdn spid2 81049306250101 4930625
ppp authentication chap
ppp chap hostname cisco
ppp chap password 7 00071A150754
ppp multilink
!
router ospf 10
router-id 129.5.5.5
log-adjacency-changes
area 0 authentication message-digest
area 1 authentication message-digest
area 1 virtual-link 129.6.6.6 message-digest-key 1 md5 cisco
area 2 virtual-link 129.6.6.6 authentication message-digest
area 2 virtual-link 129.6.6.6 message-digest-key 10 md5 cisco
network 129.5.5.5 0.0.0.0 area 0
network 192.168.2.5 0.0.0.0 area 1
network 192.168.4.5 0.0.0.0 area 3
network 192.168.5.5 0.0.0.0 area 0
network 192.168.6.1 0.0.0.0 area 2
!
ip kerberos source-interface any
ip classless
no ip http server
!
access-list 175 deny ospf any any
access-list 175 permit ip any any
dialer watch-list 1 ip 129.6.6.6 255.255.255.255
dialer-list 1 protocol ip list 175
!
alias configure ro router ospf
alias configure re router eigrp
alias configure rb router bgp
alias configure ri router isis
alias configure rr router rip
alias exec siib show ip interface brief
alias exec ct config term
alias exec sr show run
alias exec sion show ip ospf neighbor
alias exec sir show ip route
alias exec cir clear ip route *
alias exec cib clear ip bgp *
alias exec cior clear ip ospf redistribution
alias exec sibs show ip bgp summary
alias exec sib show ip bgp
alias exec sien show ip eigrp neighbor
!
line con 0
exec-timeout 0 0
password cisco
login
transport input none
line aux 0
R6
R6#sh run
01:09:13: %SYS-5-CONFIG_I: Configured from console by console
Building configuration...
Current configuration : 2865 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R6
!
logging rate-limit console 10 except errors
!
username cisco password 0 cisco
ip subnet-zero
no ip finger
no ip domain-lookup
!
isdn switch-type basic-ni
!
key chain RIP
key 1
key-string cisco
cns event-service server
!
!
!
!
!
interface Loopback0
ip address 129.6.6.6 255.255.255.0
!
interface Ethernet0
ip address 62.9.1.6 255.255.255.0
ip rip authentication mode md5
ip rip authentication key-chain RIP
!
interface Serial0
ip address 192.168.2.6 255.255.255.128
encapsulation frame-relay
ip ospf message-digest-key 1 md5 cisco
ip ospf network point-to-point
shutdown
no fair-queue
frame-relay map ip 192.168.2.5 605 broadcast
no frame-relay inverse-arp
!
interface Serial1
no ip address
!
interface BRI0
ip address 192.168.6.2 255.255.255.252
encapsulation ppp
dialer map ip 192.168.6.1 name cisco broadcast
dialer load-threshold 1 either
dialer-group 1
isdn switch-type basic-ni
isdn spid1 81049306220101 4930622
isdn spid2 81049306230101 4930623
ppp authentication chap
ppp multilink
!
router ospf 10
router-id 129.6.6.6
log-adjacency-changes
area 0 authentication message-digest
area 1 authentication message-digest
area 1 virtual-link 129.5.5.5 message-digest-key 1 md5 cisco
area 2 virtual-link 129.5.5.5 authentication message-digest
area 2 virtual-link 129.5.5.5 message-digest-key 10 md5 cisco
redistribute connected subnets route-map con2ospf
network 129.6.6.6 0.0.0.0 area 4
network 192.168.2.6 0.0.0.0 area 1
network 192.168.6.2 0.0.0.0 area 2
!
router rip
version 2
redistribute ospf 10 metric 1
passive-interface default
no passive-interface Ethernet0
offset-list SETHOP out 9
network 62.0.0.0
no auto-summary
!
ip kerberos source-interface any
ip classless
no ip http server
!
!
ip access-list standard SETHOP
permit 192.168.2.0 0.0.0.255
permit 192.168.6.0 0.0.0.255
access-list 175 deny ospf any any
access-list 175 permit ip any any
dialer-list 1 protocol ip list 175
route-map con2ospf permit 10
match interface Ethernet0
!
!
alias configure ro router ospf
alias configure re router eigrp
alias configure rb router bgp
alias configure ri router isis
alias configure rr router rip
alias exec siib show ip interface brief
alias exec ct config term
alias exec sr show run
alias exec sion show ip ospf neighbor
alias exec sir show ip route
alias exec cir clear ip route *
alias exec cib clear ip bgp *
alias exec cior clear ip ospf redistribution
alias exec sibs show ip bgp summary
alias exec sib show ip bgp
alias exec sien show ip eigrp neighbor
!
line con 0
exec-timeout 0 0
password cisco
login
transport input none
line aux 0
exec-timeout 0 0
password cisco
login
line vty 0 4
exec-timeout 0 0
password cisco
login
!
end
R6#
This archive was generated by hypermail 2.1.4 : Wed Jun 02 2004 - 11:12:12 GMT-3