Etherchannel on 3550 and 3500XL

From: Charles T. Alexander (charles.t.alexander@verizon.net)
Date: Sun Apr 25 2004 - 22:45:41 GMT-3


I have connected a 3550 and 3500XL together.

All works well with just one connection using dot1q.
    fa0/23 to fa0/11.

When I add a port-channel to the 3550 and port group to 3500XL. It
seems that the interfaces work but flap.
    fa0/23 to fa0/11
    fa0/24 to fa0/12.

Below are the two configs.
=========================
Cat 3550
Building configuration...

Current configuration : 3243 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c1
!
logging buffered 10000 debugging
enable password radnor
!
ip subnet-zero
ip routing
ip tcp synwait-time 5
no ip domain-lookup
ip dhcp relay information option
!
!
!
spanning-tree extend system-id
spanning-tree vlan 40 max-age 30
system mtu 1518
!
!
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no ip address
!
interface FastEthernet0/1
 switchport access vlan 125
 no ip address
!
interface FastEthernet0/2
 switchport access vlan 125
 no ip address
!
interface FastEthernet0/3
 no ip address
!
interface FastEthernet0/4
 no ip address
!
interface FastEthernet0/5
 switchport access vlan 125
 no ip address
!
interface FastEthernet0/6
 no ip address
!
interface FastEthernet0/7
 no ip address
!
interface FastEthernet0/8
 switchport access vlan 192
 no ip address
!
interface FastEthernet0/9
 no ip address
!
interface FastEthernet0/10
 no ip address
!
interface FastEthernet0/11
 switchport access vlan 125
 no ip address
!
interface FastEthernet0/12
 switchport access vlan 192
 no ip address
!
interface FastEthernet0/13
 no ip address
!
interface FastEthernet0/14
 no ip address
!
interface FastEthernet0/15
 no ip address
!
interface FastEthernet0/16
 switchport access vlan 14
 switchport mode dot1q-tunnel
 no ip address
 duplex full
 speed 100
 l2protocol-tunnel cdp
 l2protocol-tunnel stp
 l2protocol-tunnel vtp
 no cdp enable
!
interface FastEthernet0/17
 no ip address
!
interface FastEthernet0/18
 no ip address
!
interface FastEthernet0/19
 no ip address
!
interface FastEthernet0/20
 no ip address
!
interface FastEthernet0/21
 no switchport
 no ip address
!
interface FastEthernet0/22
 no ip address
!
interface FastEthernet0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no ip address
 channel-group 1 mode desirable
!
interface FastEthernet0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no ip address
 channel-group 1 mode desirable
!
interface GigabitEthernet0/1
 no ip address
!
interface GigabitEthernet0/2
 no ip address
!
interface Vlan1
 ip address 138.10.10.1 255.255.255.0
!
interface Vlan30
 ip address 138.10.30.10 255.255.255.0
!
interface Vlan40
 ip address 138.10.40.10 255.255.255.0
!
interface Vlan70
 ip address 138.10.70.10 255.255.255.0
!
interface Vlan96
 ip address 138.10.96.10 255.255.255.224
!
interface Vlan125
 ip address 138.10.125.10 255.255.255.0
!
interface Vlan192
 ip address 192.168.30.10 255.255.255.0
!
router rip
 version 2
 network 138.10.0.0
 network 192.168.20.0
 network 192.168.30.0
 no auto-summary
!
ip classless
ip http server
!
!
!
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
alias exec w write
!
line con 0
 exec-timeout 0 0
 logging synchronous
 escape-character 27
line vty 0 4
 exec-timeout 0 0
 password bp
 login
line vty 5 15
 exec-timeout 0 0
 password bp
 login
!
!
monitor session 1 source interface Fa0/17
monitor session 1 filter vlan 10
monitor session 1 destination interface Fa0/18 encapsulation dot1q
end
=====================================
Cat 3500XL
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2
!
logging buffered 10000 debugging
enable password radnor
!
!
!
!
!
!
ip subnet-zero
ip tcp synwait-time 5
no ip domain-lookup
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 switchport access vlan 30
!
interface FastEthernet0/4
 switchport access vlan 40
!
interface FastEthernet0/5
!
interface FastEthernet0/6
 switchport access vlan 96
!
interface FastEthernet0/7
 switchport access vlan 70
!
interface FastEthernet0/8
!
interface FastEthernet0/9
 switchport access vlan 96
!
interface FastEthernet0/10
!
interface FastEthernet0/11
 port group 1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/12
 port group 1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
 ip address 138.10.10.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec s show ip int brief
alias exec w write
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
 escape-character 27
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 password bp
 login
line vty 5 15
 exec-timeout 0 0
 password bp
 login
!
end

c2#



This archive was generated by hypermail 2.1.4 : Mon May 03 2004 - 19:48:55 GMT-3