Re: bgp queston [bcc][faked-from][bayes]

From: john matus (jmatus@pacbell.net)
Date: Mon Mar 15 2004 - 21:36:47 GMT-3


they are ibgp peers. here are the configs

r4#sh run
Building configuration...

Current configuration : 1641 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r4
!
logging queue-limit 100
no logging console
!
memory-size iomem 10
ip subnet-zero
!
!
no ip domain lookup
!
ip audit notify log
ip audit po max-events 100
mpls ldp logging neighbor-changes
!
!
!
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface Loopback0
 ip address 192.168.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.40.4 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no fair-queue
!
interface Serial0/0.1 point-to-point
 ip address 150.50.24.4 255.255.255.0
 ip router isis
 frame-relay interface-dlci 422
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
!
router isis
 net 49.0001.1921.6800.4004.00
 is-type level-1
 redistribute connected
!
router bgp 8888
 no synchronization
 bgp log-neighbor-changes
 network 192.168.40.0
 neighbor 192.168.2.2 remote-as 888
 neighbor 192.168.2.2 update-source Loopback0
 neighbor 192.168.2.2 next-hop-self
 no auto-summary
!
ip http server
no ip http secure-server
ip classless
!
!
!

r2#sh run
Building configuration...

Current configuration : 2319 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r2
!
logging queue-limit 100
no logging console
!
memory-size iomem 10
ip subnet-zero
!
!
no ip domain lookup
!
ip audit notify log
ip audit po max-events 100
mpls ldp logging neighbor-changes
frame-relay de-list 1 protocol ip gt 512
!
!
!
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface Loopback0
 ip address 192.168.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 172.16.137.2 255.255.255.0
 ip router isis
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no fair-queue
!
interface Serial0/0.1 point-to-point
 ip address 150.50.24.2 255.255.255.0
 ip router isis
 frame-relay de-group 1 224
 frame-relay interface-dlci 224
!
interface Serial0/0.2 multipoint
 ip address 150.50.100.2 255.255.255.0
 ip router isis
 isis priority 100
 frame-relay de-group 1 225
 frame-relay de-group 1 226
 frame-relay map clns 226 broadcast
 frame-relay map clns 225 broadcast
 frame-relay map ip 172.16.100.5 225 broadcast
 frame-relay map ip 172.16.100.6 226 broadcast
!
interface BRI0/0
 ip address 172.16.25.2 255.255.255.0
!
router isis
 net 49.0001.1921.6800.2002.00
 net 49.0002.1921.6800.2002.00
 redistribute connected
!
router bgp 8888
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.1.1 remote-as 8888
 neighbor 192.168.1.1 update-source Loopback0
 neighbor 192.168.1.1 route-reflector-client
 neighbor 192.168.1.1 next-hop-self
 neighbor 192.168.4.4 remote-as 8888
 neighbor 192.168.4.4 update-source Loopback0
 neighbor 192.168.4.4 route-reflector-client
 neighbor 192.168.4.4 next-hop-self
 neighbor 192.168.5.5 remote-as 8888
 neighbor 192.168.5.5 update-source Loopback0
 neighbor 192.168.5.5 route-reflector-client
 neighbor 192.168.5.5 next-hop-self
 no auto-summary
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
call rsvp-sync
!
!
mgcp profile default
!
!

Regards,

John D. Matus
MCSE, CCNP
818.782.2061 office
818.430.8372 mobile
jmatus@pacbell.net

----- Original Message -----
From: "Bill Lijewski" <bill@eccie.com>
To: "'john matus'" <jmatus@pacbell.net>; <ccielab@groupstudy.com>
Sent: Monday, March 15, 2004 4:27 PM
Subject: RE: bgp queston [bcc][faked-from][bayes]

> Here are a couple of quick things to check:
>
> 1) Are the IP addresses you are using to neighbor up the BGP reachable?
> (Can you PING them?)
>
> 2) Are the neighbors Internal or External? If they are internal BGP
> should go 255 hops to find it's neighbor, however if you are using
> Loopbacks you will need to use the 'update-source' command. If they are
> external BGP, external BGP will only go 1 hop by default. So if you are
> using Loopbacks you will need the 'update-source' command as well as the
> 'ebgp-multihop' command to allow external BGP to go more than one hop to
> find it's neighbor.
>
> Can you post the configs for your two routers?
>
> - Bill Lijewski
> CCIE#8642
> Network Learning Inc
> 5 Day R&S CCIE Bootcamp Instructor
> bill@eccie.com
>
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> john matus
> Sent: Monday, March 15, 2004 4:17 PM
> To: ccielab@groupstudy.com
> Subject: bgp queston [bcc][faked-from][bayes]
> Importance: Low
>
> what do you have to do too get 2 bgp peer that are stuck in active/idle
> w/
> an up/down of never to connect (under 'sh ip b sum')?
> i cant figure this out!....or what is it indicative of?
>
> Regards,
>
> John D. Matus
> MCSE, CCNP
> 818.782.2061 office
> 818.430.8372 mobile
> jmatus@pacbell.net
>
>
> ----- Original Message -----
> From: "Sergio Jimenez Arguedas" <sejimenez@its.co.cr>
> To: <ccielab@groupstudy.com>
> Sent: Monday, March 15, 2004 2:41 PM
> Subject: Fw: REDISTRIBUTE IN OSPF
>
>
> > Sure,
> >
> >
> > R3_sh run
> >
> >
> > !
> > interface Loopback0
> > ip address 130.10.31.1 255.255.255.224
> > !
> > interface Loopback1
> > ip address 130.10.31.33 255.255.255.224
> > !
> > interface Loopback33
> > ip address 33.33.33.3 255.255.255.0
> > !
> > interface Ethernet0/0
> > ip address 130.10.30.3 255.255.255.0
> > half-duplex
> > !
> > interface TokenRing0/0
> > no ip address
> > shutdown
> > ring-speed 16
> > !
> > interface Serial1/0
> > bandwidth 128
> > ip address 130.10.134.3 255.255.255.0
> > encapsulation frame-relay
> > ip ospf priority 0
> > no arp frame-relay
> > frame-relay map ip 130.10.134.1 100 broadcast
> > frame-relay map ip 130.10.134.4 100 broadcast
> > no frame-relay inverse-arp
> > frame-relay lmi-type ansi
> > !
> > interface Serial1/1
> > no ip address
> > shutdown
> > !
> > interface Serial1/2
> > no ip address
> > shutdown
> > !
> > interface Serial1/3
> > no ip address
> > shutdown
> > !
> > router ospf 1
> > log-adjacency-changes
> > redistribute connected metric 10 subnets
> > network 130.10.30.0 0.0.0.255 area 3
> > network 130.10.134.0 0.0.0.255 area 0
> > !
> >
> >
> > R4_sh run
> >
> >
> > !
> > !
> > interface Loopback0
> > ip address 130.10.41.1 255.255.255.252
> > !
> > interface Loopback1
> > ip address 130.10.41.5 255.255.255.252
> > !
> > interface Ethernet0/0
> > ip address 130.10.40.4 255.255.255.0
> > half-duplex
> > !
> > interface TokenRing0/0
> > no ip address
> > shutdown
> > ring-speed 16
> > !
> > interface Serial1/0
> > bandwidth 128
> > ip address 130.10.134.4 255.255.255.0
> > encapsulation frame-relay
> > ip ospf network non-broadcast
> > ip ospf priority 0
> > no arp frame-relay
> > frame-relay map ip 130.10.134.1 110 broadcast
> > frame-relay map ip 130.10.134.3 110 broadcast
> > no frame-relay inverse-arp
> > frame-relay lmi-type ansi
> > !
> > interface Serial1/1
> > no ip address
> > shutdown
> > !
> > interface Serial1/2
> > no ip address
> > shutdown
> > !
> > interface Serial1/3
> > no ip address
> > shutdown
> > !
> > router ospf 1
> > log-adjacency-changes
> > summary-address 130.10.41.0 255.255.255.0
> > redistribute connected metric 5 subnets route-map LOOPBACKS
> > network 130.10.40.0 0.0.0.255 area 4
> > network 130.10.134.0 0.0.0.255 area 0
> > !
> > ip classless
> > ip http server
> > !
> > access-list 10 permit 130.10.41.0 0.0.0.3
> > access-list 10 permit 130.10.41.4 0.0.0.3
> > route-map LOOPBACKS permit 10
> > match ip address 10
> > !
> > !
> > !
> >
> >
> >
> >
> >
> >
> >
> >
> > ----- Original Message -----
> > From: "Kenneth Wygand" <KWygand@customonline.com>
> > To: "Sergio Jimenez Arguedas" <sejimenez@its.co.cr>;
> > <ccielab@groupstudy.com>
> > Sent: Monday, March 15, 2004 4:32 PM
> > Subject: RE: REDISTRIBUTE IN OSPF
> >
> >
> > > Sergio,
> > >
> > > Seems as if you have a problem with your route-map / access list
> > configuration. Can you post your configurations for at least these
> sections
> > (entire configs would be even better!)
> > >
> > > Thanks!
> > > Ken
> > >
> > > -----Original Message-----
> > > From: nobody@groupstudy.com on behalf of Sergio Jimenez Arguedas
> > > Sent: Mon 3/15/2004 3:32 PM
> > > To: ccielab@groupstudy.com
> > > Cc:
> > > Subject: REDISTRIBUTE IN OSPF
> > >
> > >
> > >
> > > Hi Group,
> > >
> > >
> > > I have a big problem with the following scenario:
> > >
> > > E0/0: Net in OSPF AREA 4
> > > |
> > > |
> > > R4--s1/0--------------------FR_SW---------------s0/0--R1
> > > FR_SW
> > > R3--s1/0--------------------FR_SW
> > > |
> > > |
> > > E0/0: Net in OSPF AREA 3
> > >
> > >
> > > * AREA 0: OSPF Netw: point-to-multipoint //// Subnet:
> 130.10.134.0/24
> > > R1, S0/0
> > > R4, S1/0
> > > R3, S1/0
> > >
> > >
> > > *Loopbacks in R4:
> > >
> > > Lo0: 130.10.41.1/30
> > > Lo1: 130.10.41.5/30
> > >
> > > *Loopbacks in R3
> > >
> > > Lo0: 130.10.31.1/27
> > > Lo1: 130.10.31.33/27
> > > Lo33: 33.33.33.3/27
> > >
> > >
> > > ****Problem: In both R3/R4 I redistribute connected (Only int
> loopbacks,
> > I
> > > used a route-map to avoid E0/0 to be redistribute), but R1 only
> received
> > > Type-5: 33.33.33.0/27.
> > >
> > > R1 didn4t receive R3`s/R4`s Lo0, Lo1. However R1 receives Subnets of
> the
> > Area
> > > 3 and Area 4.(130.10.40.0/24&130.10.30.0/24)
> > >
> > >
> > > Could somebody help me?
> > >
> > >
> > > Note: I changed the ospf network type by non-broadcast but the
> problem
> > > continue!!!
> > >
> > >
> > >
> > > Thanks,
> > >
> > >
> > >
> > > Sergio Jiminez A.
> > >
> > >
> _______________________________________________________________________
> > > Please help support GroupStudy by purchasing your study materials
> from:
> > > http://shop.groupstudy.com
> > >
> > > Subscription information may be found at:
> > > http://www.groupstudy.com/list/CCIELab.html
> >
> >
> _______________________________________________________________________
> > Please help support GroupStudy by purchasing your study materials
> from:
> > http://shop.groupstudy.com
> >
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Please help support GroupStudy by purchasing your study materials from:
> http://shop.groupstudy.com
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Thu Apr 01 2004 - 08:15:31 GMT-3