Re: Transparent Bridging over DDR

From: William Chen (kwchen@netvigator.com)
Date: Thu Nov 27 2003 - 23:24:41 GMT-3


Dear all,

   Here is the configuration of the two routers, and the testing result:

**********
R2#sh run
Building configuration...

Current configuration : 1196 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
logging queue-limit 100
!
memory-size iomem 10
ip subnet-zero
!
!
!
ip audit notify log
ip audit po max-events 100
mpls ldp logging neighbor-changes
!
!
!
isdn switch-type basic-ni
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface BRI0/0
 ip address 192.168.25.2 255.255.255.0
 encapsulation ppp
 dialer map bridge name R5 broadcast 8358662
 dialer map ip 192.168.25.5 name R5 broadcast 8358662
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 0835866101 8358661
 isdn spid2 0835866301 8358663
 bridge-group 1
!
ip http server
no ip http secure-server
ip classless
!
!
!
access-list 201 permit 0x0000 0xFFFF
dialer-list 1 protocol ip permit
dialer-list 1 protocol bridge permit
!
!
bridge 1 protocol ieee
call rsvp-sync
!
!
mgcp profile default
!
!
!
dial-peer cor custom
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

R5#sh run
Building configuration...

Current configuration : 1175 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
logging queue-limit 100
!
ip subnet-zero
!
!
!
ip audit notify log
ip audit po max-events 100
mpls ldp logging neighbor-changes
!
!
!
isdn switch-type basic-ni
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface BRI0/0
 ip address 192.168.25.5 255.255.255.0
 encapsulation ppp
 dialer map bridge name R2 broadcast 8358661
 dialer map ip 192.168.25.2 name R2 broadcast 8358661
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 0835866201 8358662
 isdn spid2 0835866401 8358664
 bridge-group 1
!
ip http server
no ip http secure-server
ip classless
!
!
!
access-list 201 permit 0x0000 0xFFFF
dialer-list 1 protocol ip permit
dialer-list 1 protocol bridge permit
!
!
bridge 1 protocol ieee
call rsvp-sync
!
!
mgcp profile default
!
!
!
dial-peer cor custom
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
**********

Before the BRI line is connected, both router think it is the root bridge. Obviously, the topology is disconnected. I just don't know why BPDU messages would bring the line up.

**********
R2#sh spanning-tree bri

Bridge group 1
  Spanning tree enabled protocol ieee
  Root ID Priority 32768
             Address 0000.0cd8.c4b2
             This bridge is the root
             Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

  Bridge ID Priority 32768
             Address 0000.0cd8.c4b2
             Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
             Aging Time 300

Interface Designated
Name Port ID Prio Cost Sts Cost Bridge ID Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
BRI0/0 128.5 128 15625 FWD 0 32768 0000.0cd8.c4b2 128.5

R5#sh spanning-tree bri

Bridge group 1
  Spanning tree enabled protocol ieee
  Root ID Priority 32768
             Address 0000.0c14.2e93
             This bridge is the root
             Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

  Bridge ID Priority 32768
             Address 0000.0c14.2e93
             Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
             Aging Time 300

Interface Designated
Name Port ID Prio Cost Sts Cost Bridge ID Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
BRI0/0 128.5 128 15625 FWD 0 32768 0000.0c14.2e93 128.5
**********

Afterward, I bring the BRI line up by IP packets.

**********
R2#ping 192.168.25.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.25.5, timeout is 2 seconds:
.!!!
*Mar 1 12:15:34.091: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up!
Success rate is 80 percent (4/5), round-trip min/avg/max = 32/32/32 ms
R2#
*Mar 1 12:15:35.109: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed state to up
R2#
*Mar 1 12:15:40.093: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 8358662 R5

R2#sh spanning-tree bri

Bridge group 1
  Spanning tree enabled protocol ieee
  Root ID Priority 32768
             Address 0000.0c14.2e93
             Cost 15625
             Port 5 (BRI0/0)
             Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

  Bridge ID Priority 32768
             Address 0000.0cd8.c4b2
             Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
             Aging Time 300

Interface Designated
Name Port ID Prio Cost Sts Cost Bridge ID Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
BRI0/0 128.5 128 15625 FWD 0 32768 0000.0c14.2e93 128.5
R5#sh spanning-tree bri

Bridge group 1
  Spanning tree enabled protocol ieee
  Root ID Priority 32768
             Address 0000.0c14.2e93
             This bridge is the root
             Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

  Bridge ID Priority 32768
             Address 0000.0c14.2e93
             Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
             Aging Time 300

Interface Designated
Name Port ID Prio Cost Sts Cost Bridge ID Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
BRI0/0 128.5 128 15625 FWD 0 32768 0000.0c14.2e93 128.5
**********

The topology now is connected and R5 is the root bridge. However, without IP packets, the line will timeout and disconnect automatially.

**********
R2#
*Mar 1 12:17:35.847: %ISDN-6-DISCONNECT: Interface BRI0/0:1 disconnected from 8358662 R5, call lasted 121 seconds
*Mar 1 12:17:35.935: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down
*Mar 1 12:17:36.937: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed state to down
**********

I know there are several ways to make the line permanent (e.g. configure a large idle-timeout value, or dialer persistent). However, I just don't understand why BPDU
do not prevent the line from idle. BPDU is not a kind of bridge protocol???

- William Chen



This archive was generated by hypermail 2.1.4 : Fri Dec 12 2003 - 12:29:19 GMT-3