RE: Redist. Eigrp into OSPF with route map blocking connected

From: Brian Dennis (bdennis@internetworkexpert.com)
Date: Fri Oct 03 2003 - 12:48:48 GMT-3


This is the expected behavior between OSPF, IS-IS, EIGRP and RIP. I
haven't tried it with any other protocols.

Think of route redistribution as being two steps. The first step is to
get the routes that the other routing protocol is sending to the routing
table. The second step is to get the connected interfaces that are
being advertised by the other protocol.

router ospf 1
 redistribute connected subnets route-map DEFAULT <-- Second Step
 redistribute eigrp 100 subnets tag 100 <-- First Step
 network 172.16.123.0 0.0.0.255 area 0
!
route-map DEFAULT permit 10
 match interface FastEthernet0/1

Now because this second step involves getting the connected interfaces
that show up (show ip route x.x.x.x) as being "advertised by" the other
routing protocol, IS-IS connected interfaces do not get redistributed
in. Why? Because unlike other routing protocols, connected interfaces
that are being advertised by IS-IS do not show up as being "advertised
by IS-IS". So this breaks the second step for IS-IS and is the reason we
have to manually redistribute the connected interfaces that are running
IS-IS when redistributing IS-IS into another routing protocol.

Here we can see what protocols these interfaces are being advertised by.
Notice that the interface running IS-IS does not say "advertised by".

Rack1R6#sho run int atm0/0/0.4
interface ATM0/0/0.4 point-to-point
 ip address 54.1.2.6 255.255.255.0
 ip router isis
 pvc 1/100
!
end

Rack1R6#sho ip route 54.1.2.6
Routing entry for 54.1.2.0/24
  Known via "connected", distance 0, metric 0 (connected, via interface)
  Routing Descriptor Blocks:
  * directly connected, via ATM0/0/0.4
      Route metric is 0, traffic share count is 1

Rack1R6#

Rack1R3#sho run int s1/2
interface Serial1/2
 ip address 163.1.13.3 255.255.255.0
end

Rack1R3#sho ip route 163.1.13.0 255.255.255.0
Routing entry for 163.1.13.0/24
  Known via "connected", distance 0, metric 0 (connected, via interface)
  Advertised by ospf 100 <-- ADVERTISED BY
  Routing Descriptor Blocks:
  * directly connected, via Serial1/2
      Route metric is 0, traffic share count is 1

Rack1R3#

Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
bdennis@internetworkexpert.com
Toll Free: 877-224-8987
Direct: 775-745-6404 (Outside the US and Canada)
Internetwork Expert, Inc.
http://www.InternetworkExpert.com

-----Original Message-----
From: kasturi cisco [mailto:kasturi_cisco@hotmail.com]
Sent: Friday, October 03, 2003 8:00 AM
To: bdennis@internetworkexpert.com; ta_levin@yahoo.com;
ccielab@groupstudy.com
Subject: RE: Redist. Eigrp into OSPF with route map blocking connected
interface

Brian,
Just a quick question. Is this the expected behaviour between any 2
routing protcols when connected interfaces are involved OR is it only
between some of them.

Thanks for your answers.

Good Luck,
Kasturi.
>From: "Brian Dennis"
>Reply-To: "Brian Dennis"
>To: "'Troy'" ,
>Subject: RE: Redist. Eigrp into OSPF with route map blocking connected
interface
>Date: Thu, 2 Oct 2003 20:44:15 -0700
>
>This is normal behavior. Think of it like this: When you redistribute
>EIGRP into OSPF you are also redistributing the connected interfaces
>that are being advertised via EIGRP.
>
>interface Loopback0
> ip address 172.16.103.1 255.255.255.255
>!
>interface FastEthernet0/1
> ip address 172.16.35.3 255.255.255.0
>!
>router eigrp 100
> network 172.16.35.0 0.0.0.255
>!
>router ospf 1
> redistribute connected subnets route-map DEFAULT <--
> redistribute eigrp 100 subnets tag 100
> network 172.16.123.0 0.0.0.255 area 0
>!
>route-map DEFAULT permit 10
> match interface FastEthernet0/1
>
>Of course this "redistribute connected subnets route-map DEFAULT" does
>not show up in the configuration. The way you can tell it is there is
>because once you actually add the "redistribute connected" command
under
>"router ospf" you lose this "default" redistribution of the connected
>EIGRP interfaces.
>
>When you configure redistribution for the loopback 0 interface you will

>overwrite the "default" redistribution command that redistributed the
>interface that were being advertised via EIGRP.
>
>interface Loopback0
> ip address 172.16.103.1 255.255.255.255
>!
>interface FastEthernet0/1
> ip address 172.16.35.3 255.255.255.0
>!
>router eigrp 100
> network 172.16.35.0 0.0.0.255
>!
>router ospf 1
> redistribute connected subnets route-map LOOPBACK0
> redistribute eigrp 100 subnets tag 100
> network 172.16.123.0 0.0.0.255 area 0
>!
>route-map LOOPBACK0 permit 10
> match interface Loopback0
>
>So the solution is to add the interface advertised via EIGRP to the
same
>route-map that is allowing the loopback interface:
>
>interface Loopback0
> ip address 172.16.103.1 255.255.255.255
>!
>interface FastEthernet0/1
> ip address 172.16.35.3 255.255.255.0
>!
>router eigrp 100
> network 172.16.35.0 0.0.0.255
>!
>router ospf 1
> redistribute connected subnets route-map LOOPBACK0
> redistribute eigrp 100 subnets tag 100
> network 172.16.123.0 0.0.0.255 area 0
>!
>route-map LOOPBACK0 permit 10
> match interface Loopback0
> match interface FastEthernet0/1 <--- Needed
>
>Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
>bdennis@internetworkexpert.com
>Toll Free: 877-224-8987
>Direct: 775-745-6404 (Outside the US and Canada)
>Internetwork Expert, Inc.
>http://www.InternetworkExpert.com
>
>
>-----Original Message-----
>From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of

>Troy
>Sent: Thursday, October 02, 2003 8:22 PM
>To: ccielab@groupstudy.com
>Subject: Redist. Eigrp into OSPF with route map blocking connected
>interface
>
>I am confused as to why a route map designed to block all connected
>interfaces except the lo 0
>would prevent a network specified under the EIGRP process from being
>redistributed into OSPF
>I am missing something fundamental. I would think that since fa 0/1 it
>is a part of the EIGRP
>process then it would be redistributed into OSPF even though a route
map
>may block the connected
>interface. Is this incorrect?
>
>This config works:
>interface Loopback0
> ip address 172.16.103.1 255.255.255.255
>interface FastEthernet0/1
> ip address 172.16.35.3 255.255.255.0
> duplex auto
> speed auto
>router eigrp 100
> network 172.16.35.0 0.0.0.255
> no auto-summary
>!
>router ospf 1
> log-adjacency-changes
> redistribute eigrp 100 subnets tag 100
> network 172.16.123.0 0.0.0.255 area 0
>
> Type-5 AS External Link States
>Link ID ADV Router Age Seq# Checksum Tag
>172.16.20.0 172.16.102.1 1455 0x80000010 0x007AA9 120
>172.16.35.0 172.16.103.1 20 0x80000001 0x0082B4 100
>172.16.105.0 172.16.103.1 1617 0x80000001 0x0080EF 100
>172.16.120.0 172.16.102.1 1456 0x80000010 0x002A95 120
>The 172.16.35.0 is redistributed correctly
>
>However why is the same network blocked with this config?
>
>this config fails to redistribute lo 0:
>interface Loopback0
> ip address 172.16.103.1 255.255.255.255
>
>interface FastEthernet0/1
> ip address 172.16.35.3 255.255.255.0
> duplex auto
> speed auto
>router eigrp 100
> network 172.16.35.0 0.0.0.255
> no auto-summary
>!
>router ospf 1
> log-adjacency-changes
> redistribute connected subnets route-map advertiselo0
> redistribute eigrp 100 subnets tag 100
> network 172.16.123.0 0.0.0.255 area 0
>!
>access-list 1 permit 172.16.103.1
>route-map advertiselo0 permit 10
> match ip address 1
>
> Type-5 AS External Link States
>Link ID ADV Router Age Seq# Checksum Tag
>172.16.20.0 172.16.102.1 1670 0x80000010 0x007AA9 120
>172.16.103.1 172.16.103.1 33 0x80000001 0x007ADB 0
>172.16.105.0 172.16.103.1 1832 0x80000001 0x0080EF 100
>172.16.120.0 172.16.102.1 1671 0x80000010 0x002A95 120
>
>
>---------------------------------
>Do you Yahoo!?
>The New Yahoo! Shopping - with improved product search
>
>***Get your CCIE and a FREE vacation: Shop.GroupStudy.com***
>_______________________________________________________________________

>Please help support GroupStudy by purchasing your study materials from:

>shop.groupstudy.com
>
>Subscription information may be found at:
>http://www.groupstudy.com/list/CCIELab.html
>
>***Get your CCIE and a FREE vacation: Shop.GroupStudy.com***
>_______________________________________________________________________

>Please help support GroupStudy by purchasing your study materials from:

>shop.groupstudy.com
>
>Subscription information may be found at:
>http://www.groupstudy.com/list/CCIELab.html

Contact brides & grooms FREE! Only on www.shaadi.com. Register now!

***Get your CCIE and a FREE vacation: Shop.GroupStudy.com***



This archive was generated by hypermail 2.1.4 : Mon Nov 24 2003 - 07:52:56 GMT-3