From: Hemant_Kumar@BERLEX.COM
Date: Thu Oct 02 2003 - 19:55:59 GMT-3
Now, things are getting more complicated.
What you doing the configuration is preventing route feedback..right.
Ok there is complete picture of the problem
on the opposite side of serial 1of R2 we have another router (R3, also in
AS 20). Router R3 is connected to another router (R4) via ethernet.
Furthermore, R4 's Serial 2 is connected to another Router R5's serial 5.
R5 has ethernet connection to R2. see the picture.
(AS3)R2(AS20)----T1-----R3 (AS20) ---E0----(AS20)R4(AS2)
------T1------(AS3)R5(AS100)
--------------E0-------------------(AS100)R1(AS3)-----DS3 to R2
Now we have R2,R3,R4 in AS20
R5,R1 in AS100
R2,R1 in AS3
R4 ,R5 in AS2
We have 10.0.0.0/12 subnets attached to R2 and 10.16.0.0/12 attached to R3.
both of them in AS 20. These routes will get redistributed to AS3 & AS 2
by R2 and R3 as follows.
Routers R2 and R3 is doing mutual redistribution.
This means R2 is redistributing 10.0.0.0/12 and 10.16.0.0/12 to AS3.
Also R3 is redistributing 10.0.0.0/12 and 10.16.0.0/12 to AS2.
A footnote.
We have this configuration for redundancy. The primary connection is
between R2 and R3. We want 10.0.0.0/12 to be propagate to R3 from R2 with
AS20 (AD=90) and 10.16.0.0/12 from R3 to R2. If the link between R2 and R3
fails, 10.16.0.0 should be reached via R1 from R2 etc.
Now if prevent the route feedback (that is on R2 stop routes entering AS20
that are originated from AS20 , i.e 10.0.0.0/12 and 10.16.0.0/12). This
will completely kill our redundancy.
I would like to find a way that i can manipulate the 10.0.0.0/12 --->null
route so that it looks like it is originating from AS20. Right now due to
the summary route on the serial , it is making it look like its coming from
AS3 hence making this route as a external route in AS20. Therefore all
the traffic destine for 10.0.0.0/12 from R3,R4 is taking R5toR1toR2 route
rather than R3toR5.
Cisco is saying that i should remove the summary route on the AS3 domain
(serial 3). But then i will i propagate 10.0.0.0/12 to R1.
I am thinking of putting a static route of 10.0.0.0/12 null and
redistribute this into AS20. Since this route will have AD=1, it will get
installed in the routing table (overriding the summary route which as
AD=5).
But is there any better way of doing this???
Thanks
Hemant
thanks
Hemant
chipn@intraworx.
net
To: Hemant_Kumar@BERLEX.COM
10/02/2003 01:20 cc:
PM Subject:
RE: Route Selection with EIGRP ----- multiple summary addresses involved
The solution is simple.
Prevent the summary route from being redistributed between the AS's.
You could explicitly deny the route in the redistribution. Just be careful
about using a distribute-list because the access-list will block the more
SPECIFIC routes also (if you use a standard access-list).
I put together a quick lab to test out using a route-map/prefix-list combo
to filter out the summary:
R2(AS 20)--->R1--->R6(AS 3)
Here is the config on R1:
interface Serial0/0.1 multipoint
Description Connection to R2
ip address 172.16.124.1 255.255.255.0
ip summary-address eigrp 20 10.0.0.0 255.240.0.0 5
frame-relay map ip 172.16.124.2 102 broadcast
interface Serial0/1
Description Connection to R6
ip address 172.16.16.1 255.255.255.0
ip summary-address eigrp 3 10.0.0.0 255.240.0.0 5
router eigrp 20
redistribute eigrp 3 route-map BlockSummary
network 10.10.0.0 0.0.3.255
network 172.16.124.0 0.0.0.255
no auto-summary
no eigrp log-neighbor-changes
!
router eigrp 3
redistribute eigrp 20 route-map BlockSummary
network 172.16.16.0 0.0.0.255
no auto-summary
no eigrp log-neighbor-changes
ip prefix-list Summary seq 5 permit 10.0.0.0/12
!
route-map BlockSummary deny 10
match ip address prefix-list Summary
!
route-map BlockSummary permit 20
The route tables on R2 and R6:
R2#sho ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 2 subnets
D EX 172.16.16.0 [170/21024000] via 172.16.124.1, 00:06:22, Serial0/0
C 172.16.124.0 is directly connected, Serial0/0
10.0.0.0/12 is subnetted, 1 subnets
D 10.0.0.0 [90/20640000] via 172.16.124.1, 00:06:22, Serial0/0
R6#sho ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 2 subnets
C 172.16.16.0 is directly connected, Serial0/0
D EX 172.16.124.0 [170/21024000] via 172.16.16.1, 00:02:29, Serial0/0
10.0.0.0/12 is subnetted, 1 subnets
D 10.0.0.0 [90/2297856] via 172.16.16.1, 00:02:29, Serial0/0
Obviously, I did this in a lab environment.. making these types of changes
in production without prior testing could be a bad idea. :)
Hope that helps.
> Yes, i am summarizing the networks into 10.0.0.0/12 out two serial
> interfaces which are on the same router but different AS. Note Ethernet
> interface is in AS20 (same as serial 1). Serial 3 is in AS3
>
> The issuation is little bit more complicated. We are doing mutual
> redistribution between the two AS.
>
> Therefore any routes learned from AS 20 will be redistributed into AS 3
> and
> verse versa.
> Assume that the summarize route on serial 3 (AS3) is intalled in the
> router
> routing table (10.0.0.0/12 --> null). Now this route will be
> redistributed to AS20 and thus becoming a external route (AD=170) in AS
20
> domain. This is exactly what's happening to my router.
>
> I do'nt want this to happen. I want the summary route of serial 1 to be
> installed in the routing table.
>
> So again i want to find out whats the criteria the routers uses to select
> which one of these routes it places into its routing table.
>
>
> Thanks
> Hemant
***Get your CCIE and a FREE vacation: Shop.GroupStudy.com***
This archive was generated by hypermail 2.1.4 : Mon Nov 24 2003 - 07:52:56 GMT-3