From: Charles T. Alexander (charles.t.alexander@verizon.net)
Date: Sun Sep 28 2003 - 14:11:23 GMT-3
Still having problems with IPExpert #31
I have full connectivity when all circuits are up, but if I fail the r2
serial link to r5 (at the frame switch) the Bri comes up but, my
connecivity goes away, that is routes are not be distributed between
ospf and rip.
I have attached config for r2 and r5 and the the debug ip rip for both
which seem to me to say that all routes are being passed on r5 but not
processed on r2.
r5#r
Building configuration...
Current configuration : 4687 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r5
!
logging buffered 10000 debugging
enable password radnor
!
username r2 password 0 ctasta
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
ip multicast-routing
isdn switch-type basic-ni
!
key chain chucko
key 1
key-string chucko
!
!
!
!
dlsw local-peer peer-id 192.168.5.5 promiscuous
dlsw icanreach mac-address 0005.0005.0005 mask ffff.ffff.ffff
dlsw bridge-group 1
!
interface Loopback0
ip address 192.168.5.5 255.255.255.0
!
interface BRI0/0
ip address 172.31.25.5 255.255.255.0
ip rip authentication mode md5
ip rip authentication key-chain chucko
encapsulation ppp
dialer idle-timeout 600
dialer map ip 172.31.25.2 name r2
dialer-group 1
isdn switch-type basic-ni
isdn spid1 40822222221
isdn spid2 40822222222
ppp authentication chap
!
interface Ethernet0/0
ip address 172.31.200.5 255.255.255.128
no ip redirects
ip pim sparse-dense-mode
ip igmp join-group 231.1.1.1
bridge-group 1
!
interface TokenRing0/0
no ip address
shutdown
ring-speed 16
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
no frame-relay inverse-arp
frame-relay lmi-type ansi
!
interface Serial1/0.52 point-to-point
ip address 172.31.52.5 255.255.255.252
ip rip authentication mode md5
ip rip authentication key-chain chucko
frame-relay interface-dlci 501
!
interface Serial1/0.546 multipoint
ip address 172.31.100.5 255.255.255.240
ip pim sparse-mode
frame-relay map ip 172.31.100.4 504 broadcast
frame-relay map ip 172.31.100.5 504
frame-relay map ip 172.31.100.6 506 broadcast
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
router-id 192.168.5.5
log-adjacency-changes
area 0 range 172.31.100.0 255.255.255.0
area 1 range 172.31.200.0 255.255.255.0
area 1 virtual-link 192.168.6.6
area 1 virtual-link 192.168.7.7
redistribute connected subnets route-map c2o
redistribute rip subnets route-map r2o
network 172.31.100.0 0.0.0.15 area 0
network 172.31.200.0 0.0.0.127 area 1
network 192.168.5.5 0.0.0.0 area 5
neighbor 172.31.100.6
neighbor 172.31.100.4
!
router rip
version 2
timers basic 30 180 0 240
redistribute connected metric 1 route-map c2r
redistribute ospf 1 metric 2 route-map o2r
passive-interface Ethernet0/0
passive-interface Serial1/0.546
network 172.31.0.0
default-information originate route-map conditional-default
no auto-summary
!
router bgp 5678
no synchronization
bgp log-neighbor-changes
aggregate-address 192.168.112.0 255.255.252.0
neighbor pg567 peer-group
neighbor pg567 remote-as 5678
neighbor pg567 update-source Loopback0
neighbor pg567 send-community
neighbor 192.168.2.2 remote-as 12
neighbor 192.168.2.2 ebgp-multihop 2
neighbor 192.168.2.2 update-source Loopback0
neighbor 192.168.2.2 prefix-list to2 out
neighbor 192.168.4.4 remote-as 4
neighbor 192.168.4.4 ebgp-multihop 2
neighbor 192.168.4.4 update-source Loopback0
neighbor 192.168.4.4 prefix-list to4 out
neighbor 192.168.6.6 peer-group pg567
neighbor 192.168.7.7 peer-group pg567
no auto-summary
!
ip classless
ip http server
ip pim rp-address 192.168.5.5
!
!
ip prefix-list to2 seq 10 deny 192.168.112.0/24
ip prefix-list to2 seq 15 deny 192.168.112.0/22
ip prefix-list to2 seq 20 permit 0.0.0.0/0 le 32
!
ip prefix-list to4 seq 25 permit 192.168.112.0/22
access-list 1 permit 192.168.8.8
access-list 2 permit 192.168.1.0 0.0.0.255
access-list 2 permit 172.31.12.0 0.0.0.255
access-list 2 permit 192.168.2.0 0.0.0.255
access-list 2 permit 172.31.10.0 0.0.0.255
access-list 3 permit 192.168.5.5
access-list 3 permit 172.31.25.0 0.0.0.255
access-list 3 permit 172.31.52.4 0.0.0.3
access-list 3 permit 172.31.100.0 0.0.0.128
access-list 4 permit 172.31.0.0 0.0.255.255
access-list 4 permit 192.168.0.0 0.0.255.255
dialer-list 1 protocol ip permit
route-map c2r permit 10
match ip address 3
!
route-map r2o permit 10
match ip address 2
!
route-map o2r permit 10
match ip address 4
!
route-map conditional-default permit 10
match ip address 1
set interface Serial1/0.52
!
route-map c2o permit 10
match ip address 3
!
!
bridge 1 protocol ieee
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
!
line con 0
exec-timeout 0 0
logging synchronous
escape-character 27
line aux 0
line vty 0 4
exec-timeout 0 0
password bp
login
!
end
r5#
r5#
21:34:54: RIP: received packet with MD5 authentication
21:34:54: RIP: received v2 update from 172.31.25.2 on BRI0/0
21:34:54: 172.31.10.0/24 via 0.0.0.0 in 2 hops
21:34:54: 172.31.12.0/24 via 0.0.0.0 in 1 hops
21:34:54: 192.168.1.0/24 via 0.0.0.0 in 2 hops
21:34:54: 192.168.2.2/32 via 0.0.0.0 in 1 hops
21:34:54: RIP: Update contains 4 routes
r5#
21:35:06: RIP: sending v2 update to 224.0.0.9 via BRI0/0 (172.31.25.5)
21:35:06: RIP: build update entries
21:35:06: 172.31.40.0/24 via 0.0.0.0, metric 2, tag 0
21:35:06: 172.31.69.0/24 via 0.0.0.0, metric 2, tag 0
21:35:06: 172.31.78.0/24 via 0.0.0.0, metric 2, tag 0
21:35:06: 172.31.80.0/24 via 0.0.0.0, metric 2, tag 0
21:35:06: 172.31.90.128/28 via 0.0.0.0, metric 2, tag 0
21:35:06: 172.31.100.0/24 via 0.0.0.0, metric 2, tag 0
21:35:06: 172.31.100.0/28 via 0.0.0.0, metric 1, tag 0
21:35:06: 172.31.200.0/24 via 0.0.0.0, metric 2, tag 0
21:35:06: 172.31.200.0/25 via 0.0.0.0, metric 1, tag 0
21:35:06: 192.168.4.4/32 via 0.0.0.0, metric 2, tag 0
r5#
21:35:06: 192.168.6.6/32 via 0.0.0.0, metric 2, tag 0
21:35:06: 192.168.7.7/32 via 0.0.0.0, metric 2, tag 0
21:35:06: 192.168.8.8/32 via 0.0.0.0, metric 2, tag 0
21:35:06: 192.168.9.9/32 via 0.0.0.0, metric 2, tag 0
21:35:06: RIP: Update contains 14 routes
21:35:06: RIP: Update queued
21:35:06: RIP: Update sent via BRI0/0
r5#
r2#r
Building configuration...
Current configuration : 2915 bytes
!
! Last configuration change at 17:36:21 UTC Thu Mar 4 1993
! NVRAM config last updated at 19:13:33 UTC Thu Mar 4 1993
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
logging buffered 10000 debugging
logging rate-limit console 10 except errors
enable password radnor
!
username r5 password 0 ctasta
ip subnet-zero
no ip finger
no ip domain-lookup
!
no ip dhcp-client network-discovery
isdn switch-type basic-ni
!
key chain chucko
key 1
key-string chucko
!
!
!
!
interface Loopback0
ip address 192.168.2.2 255.255.255.255
!
interface Loopback1
ip address 24.24.24.24 255.255.255.0
!
interface Ethernet0
ip address 172.31.12.2 255.255.255.0
ip rip send version 1
ip rip receive version 1
ip summary-address rip 172.31.52.0 255.255.255.0
!
interface Serial0
backup delay 5 5
backup interface BRI0
ip address 172.31.52.6 255.255.255.252
ip rip authentication mode md5
ip rip authentication key-chain chucko
encapsulation frame-relay
ip split-horizon
frame-relay map ip 172.31.52.5 105 broadcast
frame-relay map ip 172.31.52.6 106
no frame-relay inverse-arp
frame-relay lmi-type ansi
!
interface Serial1
no ip address
shutdown
!
interface BRI0
ip address 172.31.25.2 255.255.255.0
ip rip authentication mode md5
ip rip authentication key-chain chucko
encapsulation ppp
dialer idle-timeout 600
dialer map ip 172.31.25.5 name r5 broadcast 4082222222
dialer-group 1
isdn switch-type basic-ni
isdn spid1 40811111111
isdn spid2 40811111112
cdapi buffers regular 0
cdapi buffers raw 0
cdapi buffers large 0
ppp authentication chap
!
router rip
version 2
timers basic 30 180 0 240
passive-interface Loopback0
network 172.31.0.0
network 192.168.2.0
no auto-summary
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 24.24.24.0 mask 255.255.255.0
neighbor 192.168.1.1 remote-as 12
neighbor 192.168.1.1 update-source Loopback0
neighbor 192.168.5.5 remote-as 5678
neighbor 192.168.5.5 ebgp-multihop 2
neighbor 192.168.5.5 update-source Loopback0
neighbor 192.168.5.5 route-map to24 out
no auto-summary
!
ip kerberos source-interface any
ip classless
ip http server
!
access-list 1 permit 24.24.24.0 0.0.0.255
dialer-list 1 protocol ip permit
route-map to24 permit 10
match ip address 1
set metric 15
set as-path prepend 12 12 12
!
route-map to24 permit 20
!
!
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
!
line con 0
exec-timeout 0 0
logging synchronous
transport input none
escape-character 27
line aux 0
line vty 0 4
exec-timeout 0 0
password bp
login
!
ntp authentication-key 23 md5 13061F0708070B 7
ntp authenticate
ntp trusted-key 23
ntp clock-period 17180006
ntp server 192.168.1.1 key 23
end
r2#
r2#
4d15h: RIP: sending v2 update to 224.0.0.9 via BRI0 (172.31.25.2)
4d15h: RIP: build update entries
4d15h: 172.31.10.0/24 via 0.0.0.0, metric 2, tag 0
4d15h: 172.31.12.0/24 via 0.0.0.0, metric 1, tag 0
4d15h: 192.168.1.0/24 via 0.0.0.0, metric 2, tag 0
4d15h: 192.168.2.2/32 via 0.0.0.0, metric 1, tag 0
4d15h: RIP: Update contains 4 routes
4d15h: RIP: Update queued
4d15h: RIP: sending v1 update to 255.255.255.255 via Ethernet0
(172.31.12.2)
4d15h: RIP: build update entries
4d15h: subnet 172.31.25.0 metric 1
4d15h: subnet 172.31.25.5 metric 1
4d15h: network 192.168.2.0 metric 1
4d15h: RIP: Update contains 3 routes
4d15h: RIP: Update queued
r2#
4d15h: RIP: Update sent via BRI0
4d15h: RIP: Update sent via Ethernet0
r2#
4d15h: RIP: received v1 update from 172.31.12.1 on Ethernet0
4d15h: 172.31.10.0 in 1 hops
4d15h: 192.168.1.0 in 1 hops
4d15h: RIP: Update contains 2 routes
***Get your CCIE and a FREE vacation: Shop.GroupStudy.com***
This archive was generated by hypermail 2.1.4 : Wed Oct 01 2003 - 07:24:39 GMT-3