From: William Lijewski (ccie8642@hotmail.com)
Date: Fri Sep 19 2003 - 17:39:13 GMT-3
I was just playing with this a little. To get it to work so that it dials
when any of the three routes I'm watching dissapears I set up 3 seperate
dialer watch-lists with one network applied to each. I then applied all
three dialer watch-lists to the BRI interface and created dialer maps for
each of the networks. Now it dials if ANY of the three routes dissappers.
Just thought I would post a way around that issue.
CONFIGURATION:
hostname r5
!
!
username r6 password 0 cisco
isdn switch-type basic-net3
!
!
interface Ethernet0
ip address 20.1.1.5 255.255.255.0
!
interface BRI0
ip address 10.1.1.5 255.255.255.0
encapsulation ppp
dialer map ip 1.1.1.0 name r6 broadcast 4930622
dialer map ip 2.2.2.0 name r6 broadcast 4930622
dialer map ip 3.3.3.0 name r6 broadcast 4930622
dialer map ip 10.1.1.6 name r6 broadcast 4930622
dialer watch-group 3
dialer watch-group 2
dialer watch-group 1
isdn switch-type basic-net3
cdapi buffers regular 0
cdapi buffers raw 0
cdapi buffers large 0
ppp authentication chap
!
router ospf 1
router-id 5.5.5.5
log-adjacency-changes
network 10.1.1.5 0.0.0.0 area 0
network 20.1.1.5 0.0.0.0 area 0
!
!
dialer watch-list 3 ip 3.3.3.0 255.255.255.0
dialer watch-list 2 ip 2.2.2.0 255.255.255.0
dialer watch-list 1 ip 1.1.1.0 255.255.255.0
4d07h: DDR: Dialer Watch: watch-group = 3
4d07h: DDR: network 3.3.3.0/255.255.255.0 UP,
4d07h: DDR: primary UP
4d07h: DDR: Dialer Watch: watch-group = 2
4d07h: DDR: network 2.2.2.0/255.255.255.0 UP,
4d07h: DDR: primary UP
4d07h: DDR: Dialer Watch: watch-group = 1
4d07h: DDR: network 1.1.1.0/255.255.255.0 UP,
4d07h: DDR: primary UP
Bill Lijewski
CCIE #8642
>From: "Volkov, Dmitry (IDS Canada)" <dmitry_volkov@ml.com>
>Reply-To: "Volkov, Dmitry (IDS Canada)" <dmitry_volkov@ml.com>
>To: "'Scott Morris'" <swm@emanon.com>, "'Roberts, Larry'"
><Larry.Roberts@expanets.com>, "'seonghui'" <seonghui@vads.com>,
>EToker@secura.com.tr
>CC: ccielab@groupstudy.com
>Subject: RE: question on dialer watch-list
>Date: Fri, 19 Sep 2003 15:25:08 -0400
>
>I'm wondering, why there is only 1 route specified in dialer map and 3
>routes in watch-list
>in Dialer Watch Configuration Example.
>What is correlation between them . I always specified the same number of
>routes in both places.
>Looks like to simplify things you may put ONLY ANY ONE of three to bring
>backup interface
>
>In this case dialer map statement for the route/network being watched by
>the
>dialer watch-list command doesn't make any sense at all.
>What's the point to have 3 watched routes and (assuming that backup int
>will
>dial only when ALL 3 routes are gone)
>to have only any one of those three be specified in dialer map statement
>since You can't chose what to dial based on lost route?
>
>I don't have equipment ready but not so far ago I tested it and backup
>interface was brought up upon loss only one route of two.
>I had also 2 x /24 subnets of the same class B major net. So I got the same
>result as Scott.
>
>Is it bug or feature ?
>
>Also conditions when backup link is disconnected is not clear in this
>article.
>As far as I remember backup int is diconnected when only one watched route
>(specified in watch-list) re-appears in RT
>and this route is learned via interface other than the backup interface. Am
>I correct ?
>
>Thanks,
>Dmitry
>
>
> > -----Original Message-----
> > From: Scott Morris [mailto:swm@emanon.com]
> > Sent: Friday, September 19, 2003 2:23 PM
> > To: 'Roberts, Larry'; 'seonghui'; EToker@secura.com.tr
> > Cc: ccielab@groupstudy.com
> > Subject: RE: question on dialer watch-list
> >
> >
> > Very interesting article... And that does appear to be correct. Even
> > though the semi-unrelated routes in my case (both /28's) did not
> > disappear from the routing table, when I watched the 'debug dialer'
> > output, they were shown as both down and therefore the primary went
> > down.
> >
> > When I added a 1.1.1.1/32 route that I had to the dialer
> > list, and made
> > it go away, the dialer watch noted that the specific route
> > was down, but
> > showed the primary link as being up still and therefore did not react.
> >
> > Sounds like a bug in watching for routes. But otherwise you are
> > correct, it appears to be a logical AND for routes listed on the
> > dialer-watch.
> > That makes it a little less fun then for different callout to
> > different
> > routers. It only attempted to call out the dialer map of the first
> > numeric entry (1.1.1.1) to reestablish a connection.
> >
> > Hmmmm..
> >
> > Good find on the article, by the way.
> >
> > Scott
> >
> >
> >
> > -----Original Message-----
> > From: Roberts, Larry [mailto:Larry.Roberts@expanets.com]
> > Sent: Friday, September 19, 2003 1:40 PM
> > To: 'Scott Morris'; 'seonghui'; EToker@secura.com.tr
> > Cc: ccielab@groupstudy.com
> > Subject: RE: question on dialer watch-list
> >
> >
> > Can you try it with 2 completely unrelated routes that don't have a
> > summary ( /28 in your case ) that points to those network's.
> >
> > It should require ALL routes to be gone.
> >
> > See below...
> >
> > http://www.cisco.com/en/US/partner/products/sw/iosswrel/ps1828
> > /products_
> > configuration_guide_chapter09186a00800872ed.html
> >
> >
> >
> >
> > Thanks
> >
> > Larry
> >
> > -----Original Message-----
> > From: Scott Morris [mailto:swm@emanon.com]
> > Sent: Friday, September 19, 2003 10:47 AM
> > To: 'seonghui'; EToker@secura.com.tr
> > Cc: ccielab@groupstudy.com
> > Subject: RE: question on dialer watch-list
> >
> >
> > The answer is #1. Either route going away will cause it to dial
> > immediately. I set it up briefly on a lab router here, so
> > the output is
> > a bit long but you'll see what you want...
> >
> >
> > Scott Morris, CCIE4 (R&S/ISP-Dial/Security/Service Provider) #4713,
> > CISSP, JNCIS, et al. IPExpert CCIE Program Manager IPExpert Sr.
> > Technical Instructor swm@emanon.com/smorris@ipexpert.net
> > http://www.ipexpert.net
> >
> > ----------Output--------------
> >
> > RouterE#sh dialer
> >
> > BRI1/0 - dialer type = ISDN
> >
> > Dial String Successes Failures Last DNIS Last status
> > 2752002 1 1 22:28:07 successful
> > 2752022 30 22 17:55:34 successful
> > 0 incoming call(s) have been screened.
> > 0 incoming call(s) rejected for callback.
> >
> > BRI1/0:1 - dialer type = ISDN
> > Idle timer (120 secs), Fast idle timer (20 secs)
> > Wait for carrier (30 secs), Re-enable (15 secs)
> > Dialer state is idle
> >
> > BRI1/0:2 - dialer type = ISDN
> > Idle timer (120 secs), Fast idle timer (20 secs)
> > Wait for carrier (30 secs), Re-enable (15 secs)
> > Dialer state is idle
> >
> > RouterE#sh ip ro
> > Codes: C - connected, S - static, I - IGRP, R - RIP, M -
> > mobile, B - BGP
> > D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> > N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> > E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> > i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
> > inter area
> > * - candidate default, U - per-user static route, o - ODR
> > P - periodic downloaded static route
> >
> > Gateway of last resort is 207.49.165.2 to network 0.0.0.0
> >
> > 1.0.0.0/32 is subnetted, 1 subnets
> > O E2 1.1.1.1 [140/0] via 207.49.165.2, 17:54:59, Serial0/1.1
> > 10.0.0.0/24 is subnetted, 1 subnets
> > O IA 10.4.4.0 [110/65] via 207.49.165.2, 17:54:59, Serial0/1.1
> > C 208.158.37.0/24 is directly connected, Ethernet1/0
> > 11.0.0.0/24 is subnetted, 1 subnets
> > C 11.11.11.0 is directly connected, Loopback0
> > 207.49.165.0/24 is variably subnetted, 4 subnets, 2 masks
> > C 207.49.165.64/30 is directly connected, BRI1/0
> > C 207.49.165.0/30 is directly connected, Serial0/1.1
> > O E2 207.49.165.0/28 [110/0] via 207.49.165.2, 17:55:00,
> > Serial0/1.1
> > O IA 207.49.165.128/28 [110/74] via 207.49.165.2, 17:55:00,
> > Serial0/1.1
> > O*E2 0.0.0.0/0 [110/0] via 207.49.165.2, 17:55:00,
> > Serial0/1.1 RouterE#
> >
> > RouterE#conf t
> > Enter configuration commands, one per line. End with CNTL/Z.
> > RouterE(config)#dialer watch-list 1 ip 207.49.165.128 255.255.255.240
> > RouterE(config)#dialer watch-list 1 ip 207.49.165.0 255.255.255.240
> > RouterE(config)#int bri 1/0
> > RouterE(config-if)#dialer map ip 207.49.165.0 name RouterF broadcast
> > 2752022 RouterE(config-if)#dialer map ip 207.49.165.128 name RouterF
> > broadcast
> > 2752022
> > RouterE(config-if)#dialer watch-group 1
> > RouterE(config-if)#^Z
> >
> >
> > RouterE#sh ip ro
> > Codes: C - connected, S - static, I - IGRP, R - RIP, M -
> > mobile, B - BGP
> > D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> > N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> > E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> > i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
> > inter area
> > * - candidate default, U - per-user static route, o - ODR
> > P - periodic downloaded static route
> >
> > Gateway of last resort is 207.49.165.2 to network 0.0.0.0
> >
> > 1.0.0.0/32 is subnetted, 1 subnets
> > O E2 1.1.1.1 [140/0] via 207.49.165.2, 17:58:32, Serial0/1.1
> > 10.0.0.0/24 is subnetted, 1 subnets
> > O IA 10.4.4.0 [110/65] via 207.49.165.2, 17:58:32, Serial0/1.1
> > C 208.158.37.0/24 is directly connected, Ethernet1/0
> > 11.0.0.0/24 is subnetted, 1 subnets
> > C 11.11.11.0 is directly connected, Loopback0
> > 207.49.165.0/24 is variably subnetted, 4 subnets, 2 masks
> > C 207.49.165.64/30 is directly connected, BRI1/0
> > C 207.49.165.0/30 is directly connected, Serial0/1.1
> > O E2 207.49.165.0/28 [110/0] via 207.49.165.2, 17:58:33,
> > Serial0/1.1
> > O IA 207.49.165.128/28 [110/74] via 207.49.165.2, 17:58:33,
> > Serial0/1.1
> > O*E2 0.0.0.0/0 [110/0] via 207.49.165.2, 17:58:33, Serial0/1.1
> >
> > RouterE#
> >
> > <<<At this point, I made a single route (207.49.165.0/28) go away from
> > the other side. It was the second entry from the list.
> > Immediately, it
> > dialed up.>>>>
> >
> > 2d15h: %LINK-3-UPDOWN: Interface BRI1/0:1, changed state to up
> > 2d15h: %ISDN-6-CONNECT: Interface BRI1/0:1 is now connected to 2752022
> > RouterF
> > 2d15h: %ISDN-6-DISCONNECT: Interface BRI1/0:1 disconnected
> > from 2752022
> > RouterF, call lasted 2 seconds
> > 2d15h: %LINK-3-UPDOWN: Interface BRI1/0:1, changed state to
> > downsh ip ro
> >
> > <<<< Callback works too. :) >>>>
> >
> > 2d15h: %LINK-3-UPDOWN: Interface BRI1/0:1, changed state to up
> > 2d15h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
> > 2d15h: %LINEPROTO-5-UPDOWN: Line protocol on Interface
> > BRI1/0:1, changed
> > state to up
> > 2d15h: %LINEPROTO-5-UPDOWN: Line protocol on Interface
> > Virtual-Access1,
> > changed state to up
> > 2d15h: %ISDN-6-CONNECT: Interface BRI1/0:1 is now connected to 2752022
> > RouterF RouterE#sh ip ro
> > Codes: C - connected, S - static, I - IGRP, R - RIP, M -
> > mobile, B - BGP
> > D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> > N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> > E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> > i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
> > inter area
> > * - candidate default, U - per-user static route, o - ODR
> > P - periodic downloaded static route
> >
> > Gateway of last resort is 207.49.165.65 to network 0.0.0.0
> >
> > C 208.158.37.0/24 is directly connected, Ethernet1/0
> > 11.0.0.0/24 is subnetted, 1 subnets
> > C 11.11.11.0 is directly connected, Loopback0
> > 207.49.165.0/24 is variably subnetted, 3 subnets, 2 masks
> > C 207.49.165.64/30 is directly connected, BRI1/0
> > C 207.49.165.0/30 is directly connected, Serial0/1.1
> > O E2 207.49.165.128/28 [110/100] via 207.49.165.2, 00:00:23,
> > Serial0/1.1
> > S* 0.0.0.0/0 [250/0] via 207.49.165.65
> >
> >
> > <<<Then I just restored the route. S0/1.1 is preferred by metric even
> > though BRI is still up for a short while>>>
> >
> > RouterE#sh ip ro
> > Codes: C - connected, S - static, I - IGRP, R - RIP, M -
> > mobile, B - BGP
> > D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> > N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> > E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> > i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
> > inter area
> > * - candidate default, U - per-user static route, o - ODR
> > P - periodic downloaded static route
> >
> > Gateway of last resort is 207.49.165.2 to network 0.0.0.0
> >
> > 1.0.0.0/32 is subnetted, 1 subnets
> > O E2 1.1.1.1 [140/0] via 207.49.165.2, 00:00:04, Serial0/1.1
> > 10.0.0.0/24 is subnetted, 1 subnets
> > O IA 10.4.4.0 [110/65] via 207.49.165.2, 00:00:14, Serial0/1.1
> > C 208.158.37.0/24 is directly connected, Ethernet1/0
> > 11.0.0.0/24 is subnetted, 1 subnets
> > C 11.11.11.0 is directly connected, Loopback0
> > 207.49.165.0/24 is variably subnetted, 4 subnets, 2 masks
> > C 207.49.165.64/30 is directly connected, BRI1/0
> > O E2 207.49.165.0/28 [110/0] via 207.49.165.2, 00:00:05,
> > Serial0/1.1
> > C 207.49.165.0/30 is directly connected, Serial0/1.1
> > O IA 207.49.165.128/28 [110/74] via 207.49.165.2, 00:00:11,
> > Serial0/1.1
> > O*E2 0.0.0.0/0 [110/0] via 207.49.165.2, 00:00:05,
> > Serial0/1.1 RouterE#
> > RouterE#
> >
> >
> > -----Original Message-----
> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On
> > Behalf Of
> > seonghui
> > Sent: Friday, September 19, 2003 11:17 AM
> > To: EToker@secura.com.tr
> > Cc: ccielab@groupstudy.com
> > Subject: RE: question on dialer watch-list
> >
> >
> > Hi EToker,
> >
> > Thanks for your feedback. From your 2nd sentence, I can see that you
> > choose answer 2. I received quite a number of answers offline, they
> > chose answer 1. Has anyone tested this? I would really like to test it
> > out on my lab, but my ISDN simulator has not arrived yet. Can anyone
> > confirm this? Thanks..
> >
> >
> > -----Original Message-----
> > From: EToker@secura.com.tr [mailto:EToker@secura.com.tr]
> > Sent: Friday, September 19, 2003 7:52 PM
> > To: Seonghui@vads.com; ccielab@groupstudy.com
> > Subject: RE: question on dialer watch-list
> >
> >
> > Hi,
> > It checks at least one valid route for the watched networks.
> > It will not
> > trigger if at least one of the routes is still available.
> >
> > -----Original Message-----
> > From: Seonghui [mailto:Seonghui@vads.com]
> > Sent: 19 Eyl|l 2003 Cuma 11:32
> > To: ccielab@groupstudy.com
> > Subject: question on dialer watch-list
> >
> >
> > Hi Group,
> >
> > Sorry to ask this question without testing it. I am still
> > waiting for my
> > ISDN simulator...
> >
> > I was going thru a dialer watch-list scenario and suddenly
> > this question
> > poped up in my head. If I have more than one network in my dialer
> > watch-list to be 'watched' and they are in the same
> > watch-list group 1,
> > will the ISDN trigger based on:-
> >
> > 1) either route lost from the routing table?
> > 2) Or both routes must dissappear from the routing table
> > before the ISDN
> > initiate a call?
> > 3) or will it based on only the first statement in the dialer
> > watch-list? second statement is ignored?
> >
> > Below is the config:
> >
> > interface BRI1/0
> > ip address 172.16.20.2 255.255.255.0
> > encapsulation ppp
> > shutdown
> > dialer map ip 172.16.200.0 name r5 broadcast 77128888
> > dialer map ip 172.16.100.0 name r5 broadcast 77128888
> > dialer map ip 172.16.20.5 name r5 broadcast 77128888
> > dialer watch-group 1
> > isdn switch-type basic-net3
> > ppp authentication chap
> > !
> >
> > dialer watch-list 1 ip 172.16.200.0 255.255.255.128
> > dialer watch-list 1 ip 172.16.100.0 255.255.255.128
> >
> > I tried searching the doc cd but the example is only for watching 1
> > route.
> >
> > Thanks and regards - SH
> >
> > ***Get your CCIE and a FREE vacation: Shop.GroupStudy.com***
> > ______________________________________________________________
> > _________
> > Please help support GroupStudy by purchasing your study
> > materials from:
> > shop.groupstudy.com
> >
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> > [GroupStudy removed an attachment of type application/ms-tnef
> > which had
> > a name of winmail.dat]
> >
> > ***Get your CCIE and a FREE vacation: Shop.GroupStudy.com***
> > ______________________________________________________________
> > _________
> > Please help support GroupStudy by purchasing your study
> > materials from:
> > shop.groupstudy.com
> >
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> > ***Get your CCIE and a FREE vacation: Shop.GroupStudy.com***
> > ______________________________________________________________
> > _________
> > Please help support GroupStudy by purchasing your study
> > materials from:
> > shop.groupstudy.com
> >
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> > ***Get your CCIE and a FREE vacation: Shop.GroupStudy.com***
> > ______________________________________________________________
> > _________
> > Please help support GroupStudy by purchasing your study
> > materials from:
> > shop.groupstudy.com
> >
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
>***Get your CCIE and a FREE vacation: Shop.GroupStudy.com***
>_______________________________________________________________________
>Please help support GroupStudy by purchasing your study materials from:
>shop.groupstudy.com
>
>Subscription information may be found at:
>http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Wed Oct 01 2003 - 07:24:32 GMT-3