Re: Cat3550 voice vlan

From: Charles Ragan (ciscojock2002@yahoo.com)
Date: Wed Sep 17 2003 - 13:23:19 GMT-3


Unfortunately - IMHO - it's a little like call routing and digit
manipulation....it can be done any number of ways....

These effectively cause the same or similar results (you can verify with
'sho int fa0/x swi'). The older configurations for the 3500xl and the
2900xl's were similar to your config (and can still be done on the 3550's):

int fa0/5
switchport trunk encap dot1q
switchport trunk native vlan 1
switchport mode trunk
switchport voice vlan 2
spanning-tree portfast

(you could just as well use the switchport priority here - but appliance
trust is set to none already.)

To use IPE's config you could override the cos setting from the pc attached
to the phone (but they didn't specify an attached pc did they?) - rewrite
the cos to 0 for data frames

interface fa0/5
  switchport mode access
  switchport voice vlan 2
  switchport priority extend cos 0
  no ip address
  spanning-tree portfast

-or-

To trust the cos settings coming from the pc:

interface fa0/5
  switchport mode access
  switchport voice vlan 2
  switchport priority extend trust
  no ip address
  spanning-tree portfast

-or-

mls qos
int fa0/5
mls qos trust cos
switchport voice vlan 2
no ip address
spanning-tree portfast

Without mls enabled, the port will operate in pass through mode, with no
rewrites. All cos values map to queue 1....whereas when mls is enabled,
4 queues are created and cos values are mapped to their respectful queues
(cos 0/1 map to queue 1, cos 0/2 map to queue 2, cos 0/3 to queue 3, etc..)

Charles
At 11:22 AM 9/16/2003 -0700, Shawn Yang wrote:
>Hi, people,
>
>Here is one question in Ipexpert 4.0, appendix H.
>
>(For Cat3550)
>There is a Cisco 7960 IP phone connected to fa 0/15, configure the port as
>if
>the phone will be forwarding its voice traffic with 802.1q information.
>Voice
>vlan is 100.
>
>My answer:
>
>mls qos
>
>int fa 0/15
> swi trunk encap dot1q
> swi mode trunk
> swi voice vlan 100.
> mls qos trust cos
>
>The solution:
>
>int fa 0/15
> swi mode access
> swi voice vlan 100
>
>I am having problem accepting this solution. Should a voice port have to
>be a trunk port? Because it has to carry at least two vlans, voice, and
>data?
>also "mls qos" is not enabled...
>
>Anyone can help me?
>
>Shawn
>
>***Get your CCIE and a FREE vacation: Shop.GroupStudy.com***
>_______________________________________________________________________
>Please help support GroupStudy by purchasing your study materials from:
>shop.groupstudy.com
>
>Subscription information may be found at:
>http://www.groupstudy.com/list/CCIELab.html

Charles Ragan Jr., Technology Consultant
Principal Consultant - CCIE #1764
Cell Phone - 336-442-4361
http://www.geocities.com/ciscojock2002/

***Get your CCIE and a FREE vacation: Shop.GroupStudy.com***



This archive was generated by hypermail 2.1.4 : Wed Oct 01 2003 - 07:24:29 GMT-3