RE: bgp to non-bgp to bgp

From: James Bone (cciehead@yahoo.com)
Date: Mon Sep 08 2003 - 16:20:53 GMT-3


Ok Group.

Sorry I should have posted this before but I was not near the routers
:-). Here's the complete configurations of the routers.I was looking for
another way to prevent the flap without using a static route on routerc.

Thanks

James
 ********************************************

routerf#sh run
Building configuration...

Current configuration : 780 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname routerf
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
!
!
interface Ethernet0
 ip address 172.16.1.2 255.255.255.0
!
interface Serial0
 ip address 192.68.5.1 255.255.255.0
 shutdown
 no fair-queue
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 no ip address
 shutdown
!
router ospf 10
 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
!
router bgp 3
 bgp log-neighbor-changes
 network 172.16.1.0 mask 255.255.255.0
 neighbor 172.16.20.1 remote-as 1
 neighbor 172.16.20.1 ebgp-multihop 2
!
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

routerf#

********************************************************
routera#sh run
Building configuration...

Current configuration : 789 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname routera
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
cns event-service server
!
!
!
!
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0
 no ip address
 shutdown
 no fair-queue
!
interface Serial1
 ip address 172.16.20.2 255.255.255.0
 clockrate 64000
!
interface BRI0
 no ip address
 shutdown
!
router ospf 10
 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
 network 172.16.20.0 0.0.0.255 area 0
!
ip kerberos source-interface any
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

***********************************************************
routerc#sh run
Building configuration...

Current configuration : 709 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname routerc
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
!
!
interface Serial0
 ip address 172.16.20.1 255.255.255.0
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
interface TokenRing0
 no ip address
 shutdown
!
router ospf 10
 log-adjacency-changes
 network 172.16.20.0 0.0.0.255 area 0
!
router bgp 1
 bgp log-neighbor-changes
 neighbor 172.16.1.2 remote-as 3
 neighbor 172.16.1.2 ebgp-multihop 2
!
ip classless
ip route 172.16.1.2 255.255.255.255 172.16.20.2
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

*******************************************************
Routerc table with the static route on routerc
routerc#
routerc#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C 172.16.20.0/24 is directly connected, Serial0
B 172.16.1.0/24 [20/0] via 172.16.1.2, 00:10:20
S 172.16.1.2/32 [1/0] via 172.16.20.2
routerc#

*********************************************************
Router c table without the static route. As can be seen

routerc#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
C 172.16.20.0 is directly connected, Serial0
B 172.16.1.0 [20/0] via 172.16.1.2, 00:00:56 ***************Here
it just about to flap to OSPFas can be seen below

routerc#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 2 subnets
C 172.16.20.0 is directly connected, Serial0
O 172.16.1.0 [110/74] via 172.16.20.2, 00:00:00, Serial0
*********** BGP disappears
routerc#



This archive was generated by hypermail 2.1.4 : Wed Oct 01 2003 - 07:24:24 GMT-3