RE: native vlan and port config for IP phone.

From: Marcus Jensen (marcus@pobox.com)
Date: Wed Sep 03 2003 - 01:21:25 GMT-3


A typical pc/phone port would look more like this.

int fast 0/1
sw host
sw access vlan 100
sw voice vlan 200

Cisco has programmed the IOS to recognize what an engineer is attempting to
accompolish when typing the voice vlan command. With this command, encap
type is ignored/overridden on dynamic or access ports. Think of it like
this, if you have a thousand access ports in place and add voice vlans
across them later in a voip expansion project, you access ports probably
already have these commands...

int fast 0/1
span port-fast
sw mode access
sw access vlan X

You have your access ports separated in dozen different vlans across various
switches and so forth. But you have one new call manager and a thousand new
phones to add. And now you want the easiest quickest way to add same voice
vlan without changing previous parameters. Just add voice vlan 200 to every
port and your done.

> From my understanding, IP phone's packet is always dot1p tagged.
> "switchport voice vlan <vlan_id> is used to tell IP phone to use
> <vlan_id> in dot1q fields. It is because dot1p/dot1q use the same 4-byte.

Not quite. It is not a requirement that a phone tag voice packets. The phone
only tags packets if you tell it to tag packets, and you do this on the
switch with the voice vlan command. If you do not type voice vlan, then your
voice packets arrive at switch untagged. Just need to ensure callmanager
server is off a port that has the same access port vlan that the phone is
on, and your other phones are in same data vlan, and all will work.

Marcus

> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
> Roberts, Larry
> Sent: Wednesday, September 03, 2003 3:13 AM
> To: 'navaid@rogers.com'; ccielab@groupstudy.com
> Subject: RE: native vlan and port config for IP phone.
>
>
> The switchport trunk voice vlan 101 is used to pass the voice
> vlan onto a
> Cisco phone. If your using a non-cisco IP phone you will need
> to manually
> tell the phone what the voice vlan is, and this is assuming
> that the phone
> is trunking.
>
> The switchport trunk native vlan 102 is not needed below,
> because your port
> is hard-coded for access mode, not trunk mode. Native VLAN really only
> applies to trunk ports
>
> A typical voice port, with a cisco IP phone migth look like
> this ( and Im
> doing this for memory so pardon any typos )
>
> Interface f0/16
> Description IP Phone
> Switchport mode trunk
> Switchport trunk encapsulation dot1q
> Switchport trunk native vlan 102
> Switchport voice vlan 101
> Spanning-tree portfast
>
> Here is a breakdown of what each command doesn:
>
> Interface f0/16 = go into the F0/16 interface and apply the
> configuration
> there
> Description IP Phone = adds a description to the port so you
> can look though
> the config and figure out what it is used by
> Switchport mode trunk = force the port to be a trunk port
> Switchport trunk encapsulation dot1q = use 802.1q packet tagging ( as
> opposed to ISL )
> Switchport trunk native vlan 102 = Any untagged packets are
> considered to be
> in this VLAN. On cisco Phones, the ethernet port would be in this VLAN
> Switchport voice vlan 101 = used to tell a cisco IP Phone how
> to tag voice
> packets, ie tag voice packets in vlan 101 ( I believe that
> CDP passes this
> info along to the phone )
> Spanning-tree portfast = skip the normal stp startup procedure, and
> immediately start forwarding packets.
>
> If your using a phone that can't do trunking, you can just
> hard code the
> port to access mode and set the access vlan to what you need
>
> Interface f0/16
> Description Hard-coded IP Phone
> Switchport mode access
> Switchport access vlan 101
>
> This just tells the switch that don't vlan tag packets and
> just put all
> traffic you receive into vlan 101.
>
> Does this help ?
>
> Thanks
>
> Larry
>
> -----Original Message-----
> From: navaid@rogers.com [mailto:navaid@rogers.com]
> Sent: Tuesday, September 02, 2003 12:38 PM
> To: ccielab@groupstudy.com
> Subject: Re: native vlan and port config for IP phone.
>
>
> What if we have following config ?
>
> interface FastEthernet0/16
> switchport access vlan 40
> switchport trunk encapsulation dot1q
> switchport trunk native vlan 102
> switchport voice vlan 101
> no ip address
> spanning-tree portfast
> end
>
> >
> > From: <navaid@rogers.com>
> > Date: 2003/09/02 Tue PM 01:31:05 EDT
> > To: <ccielab@groupstudy.com>
> > Subject: native vlan and port config for IP phone.
> >
> > What is the correct method of configuring native vlan ? Fa0/15 is
> > using "switchport access vlan" command. fa0/16 is using "switchport
> > trunk native vlan" command.
> >
> > interface FastEthernet0/15
> > switchport access vlan 102
> > switchport trunk encapsulation dot1q
> > switchport voice vlan 101
> > no ip address
> > spanning-tree portfast
> > interface FastEthernet0/16
> > switchport trunk encapsulation dot1q
> > switchport trunk native vlan 102
> > switchport voice vlan 101
> > no ip address
> > spanning-tree portfast
> >
> > Thanks,
> >
> > Navaid
> >
> >
>
> 1
>
>
> ______________________________________________________________
> _________
> You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
> ______________________________________________________________
> _________
> You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Wed Oct 01 2003 - 07:24:22 GMT-3