Re: OSPF over Frame Relay

From: miken (miken@sisna.com)
Date: Wed Aug 27 2003 - 13:07:28 GMT-3


Tom,

Use the "show ip ospf neighbor" command to see which router is the DR. It
should be your hub which in this case is R2. non-broadcast and broadcast
network types are going to elect a DR and depending on how you set the
priority, a BDR too. Force router 2 to DR by setting the ip ospf priority on
the serial interface to something higher than 1. You would never want R1 or
R2 to assume DR because they don't have maps to each other so set those
priorities to 0. You also only need to put the router mode neighbor
statements in your hub/DR router. Then clear "ip ospf process" or to be
really sure it works just like the proctor is going to do it, reload the
router. Don't forget to write mem first =)

Router r2
interface Serial0.1 multipoint
 ip address 15.2.34.2 255.255.255.0
 ip ospf network non-broadcast
 ip ospf priority 200
 frame-relay map ip 15.2.34.1 221 broadcast
 frame-relay map ip 15.2.34.3 223 broadcast
!
router ospf 1
 network 15.2.2.2 0.0.0.0 area 0
 network 15.2.34.2 0.0.0.0 area 0
 neighbor 15.2.34.1
 neighbor 15.2.34.3

Router r1
interface Serial0
 ip address 15.2.34.1 255.255.255.0
 encapsulation frame-relay
 ip ospf network non-broadcast
 ip ospf priority 0
 frame-relay map ip 15.2.34.2 122 broadcast
 no frame-relay inverse-arp
 !
router ospf 1
 network 15.2.1.1 0.0.0.0 area 0
 network 15.2.34.1 0.0.0.0 area 0

Router r3
interface Serial0
 ip address 15.2.34.3 255.255.255.0
 encapsulation frame-relay
 ip ospf network non-broadcast
 ip ospf priority 0
 frame-relay map ip 15.2.34.2 322 broadcast
 no frame-relay inverse-arp
!
router ospf 1
 network 15.2.3.3 0.0.0.0 area 0
 network 15.2.34.3 0.0.0.0 area 0

HTH,
Mike N

----- Original Message -----
From: "Thomas Dean" <tj_dean@hotmail.com>
To: <ccielab@groupstudy.com>
Sent: Wednesday, August 27, 2003 6:59 AM
Subject: OSPF over Frame Relay

> Hi All
>
> Got a problem with OSPF over FR.
>
> r1--------r2--------r3
>
> r2 to use a multipoint subinterface, others to use phyiscal interface.
> All are in the same subnet.
> One dlci to each router r1 to/from r2 122/221, r2 to/from r3 223/322.
>
> What is the best way of approaching this problem.
>
> Have configured frame network and all dlci's are active.
> Have configured the interfaces as network type broadcast and got partial
> success - not all routes were exchanged- between r3 and r2 but nothing
> between r1 and r2.
> Tried using non-brd on r1 and r3 and point-to-multi non-brd on r2 and
> neighbours in OSPF, got neighbours up but no routes at all.
> Tried using non-brd and neighbours in OSPF, got neighbours and some
routes -
> between r3 and r2 but nothing between r1 and r2.
>
> Configs for last attempt below
>
> !Router r1
> interface Serial0
> ip address 15.2.34.1 255.255.255.0
> encapsulation frame-relay
> ip ospf network non-broadcast
> frame-relay map ip 15.2.34.2 122 broadcast
> no frame-relay inverse-arp
> !
> router ospf 1
> network 15.2.1.1 0.0.0.0 area 0
> network 15.2.34.1 0.0.0.0 area 0
> neighbor 15.2.34.2 priority 1
> !
> !Router r2
> interface Serial0.1 multipoint
> ip address 15.2.34.2 255.255.255.0
> ip ospf network non-broadcast
> frame-relay map ip 15.2.34.1 221 broadcast
> frame-relay map ip 15.2.34.3 223 broadcast
> !
> router ospf 1
> network 15.2.2.2 0.0.0.0 area 0
> network 15.2.34.2 0.0.0.0 area 0
> neighbor 15.2.34.1 priority 1
> neighbor 15.2.34.3 priority 1
> !
>
> !Router r3
> interface Serial0
> ip address 15.2.34.3 255.255.255.0
> encapsulation frame-relay
> ip ospf network non-broadcast
> frame-relay map ip 15.2.34.2 322 broadcast
> no frame-relay inverse-arp
> !
> router ospf 1
> network 15.2.3.3 0.0.0.0 area 0
> network 15.2.34.3 0.0.0.0 area 0
> neighbor 15.2.34.2 priority 1
> !
>
>
> Many thanks
>
> Tom
>
> _________________________________________________________________
> It's fast, it's easy and it's free. Get MSN Messenger today!
> http://www.msn.co.uk/messenger
>
>
> _______________________________________________________________________
> You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Tue Sep 02 2003 - 18:54:07 GMT-3