RE: Async connect

From: Ken.Farrington@barclayscapital.com
Date: Tue Aug 05 2003 - 03:37:00 GMT-3


Hi William,

I have a problem with async dialup currently

 R1 (Aux 0) -- (modem) ----------(PSTN)-------------- (modem) -- (aux0) R2

From R2, I can ping R1 and it brings up the aync interface on both routers
and everything is fine.
From R1, I try to ping R2, the modem connects and an PSTN session is
established, but The Async interface on R2 will not come up and thus no IP
connectivity.

Like I say, it works one way round R2 -> R1 but not R1 -> R2

Configs:-

R1
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname host_router
!
!
username remote_router password 0 cisco
!
chat-script dialremote "" "atz&f" OK "atdt 1234" TIMEOUT 60 CONNECT
!
interface Async1
 ip address 172.16.128.1 255.255.255.252
 encapsulation ppp
 async mode interactive
 dialer in-band
 dialer idle-timeout 305
 dialer map ip 172.16.128.2 name remote_router broadcast 1234
 dialer-group 1
 ppp authentication chap
!
router eigrp 666
 passive-interface Ethernet0
 network 10.0.0.0
 no auto-summary
!
ip route 21.21.21.0 255.255.255.0 172.16.128.2
!
!
dialer-list 1 protocol ip permit
!
line con 0
line aux 0
 autoselect ppp
 script dialer dialremote
 modem InOut
 modem autoconfigure discovery
 transport input all
 rxspeed 38400
 txspeed 38400
line vty 0 4
 exec-timeout 0 30
 password cisco
 login
!

Configs - R2

!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname remote_router
!
!
username host_router password 0 cisco
!
!
!
chat-script dialhost "" "ATZ&F" OK "ATDT5678" TIMEOUT 60 CONNECT
!
!
!
interface Loopback21
 ip address 21.21.21.21 255.255.255.0
 no ip directed-broadcast
!
interface Async65
 ip address 172.16.128.2 255.255.255.252
 no ip directed-broadcast
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 305
 dialer map ip 172.16.128.1 name host_router broadcast 5678
 dialer-group 1
 async mode interactive
 fair-queue 64 16 0
 ppp authentication chap
!
ip route 22.22.22.0 255.255.255.0 172.16.128.1
dialer-list 1 protocol ip permit
!
line con 0
 transport input none
line aux 0
 autoselect ppp
 script dialer dialhost
 modem InOut
 modem autoconfigure discovery
 transport input all
 speed 115200
line vty 0 4
 password cisco
 login

-----Original Message-----
From: wing_lam@jossynergy.com [mailto:wing_lam@jossynergy.com]
Sent: 01 July 2003 10:57
To: Chen Kwong Wai William
Cc: ccielab@groupstudy.com
Subject: Re: Async connect

Hi William,

Still no luck, this time I even cannot get the async interface us.

The following is the debug in both side.

REMOTEGW#p 192.168.20.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds: ...
8w6d: CHAT8: Chat script dial finished, status = Connection timed out;
remote ho st not responding
8w6d: TTY8: Line reset by "Async dialer"
8w6d: Async8 DDR: disconnecting call
8w6d: TTY8: Modem: READY->HANGUP
8w6d: TTY8: destroy timer type 0
8w6d: TTY8: destroy timer type 1
8w6d: TTY8: destroy timer type 3
8w6d: TTY8: destroy timer type 4
8w6d: TTY8: destroy timer type 2

I have the following question:

1) I find the modem response after three rings, and I feel it may be too
long to get response, am I need to use chat script to change it's behaviour?
2) I heart about some guys mentioning "auto-answer" mode, is it true that my
modem should in this mode so that it can running routing on it?
3) If 2) true, how can I know whether it's in this mode? How can I change
it?

Can anybody help by send me some config to make this work?

Thx,
BBD (Big Black Dog)

 

                      "Chen Kwong Wai

                      William" To:
<wing_lam@jossynergy.com>

                      <kwchen@netvigato cc:
<ccielab@groupstudy.com>

                      r.com> Subject: Re: Async connect

                      Sent by:

                      nobody@groupstudy

                      .com

 

 

                      07/01/2003 08:12

                      AM

                      Please respond to

                      "Chen Kwong Wai

                      William"

 

 

Dear BBD,

   Maybe you need to put "autoselect ppp" in the line configuration, since
you have the command "async mode interactive" in you interface
configuration. I am not sure if "autodetect encapsulation ppp" has the same
function. Tell me if it works.

Best,
Will

----- Original Message -----
From: <wing_lam@jossynergy.com>
To: <ccielab@groupstudy.com>
Sent: Monday, June 30, 2003 10:44 PM
Subject: Async connect

> Hi group,
>
> I am just entry in async dialup, sorry to ask the following simple
> question:
>
> -- I am setting the following lab scenario, I have a router "R26" and
> a router "REMOTEGW":
>
> R26 (Aux 0) -- (modem) ----------(PSTN)-------------- (modem) -- (Line
tty
> 8) Remote
> phone no 5413
> phone no 5001
>
>
> And I would like to setup routing by async dialup, I have tested at
> each router by reverse telnet that the remote modems can be reached,
> by "ATDT5001" & "ATDT5413"
>
> The following is my two routers config, I cannot get it to be worked
> (I cannot ping the other end)
>
> 1) R26
>
> chat-script dial "" "ATZ&F" OK "ATDT 5413" TIMEOUT 60 CONNECT
>
> interface Async65
> ip address 192.168.20.1 255.255.255.0
> encapsulation ppp
> dialer in-band
> dialer map ip 192.168.20.2 name REMOTEGW broadcast 5413 dialer-group
> 1 autodetect encapsulation ppp
> async dynamic routing
> async mode interactive
> ppp authentication chap
> !
> line aux 0
> script dialer dial
> modem InOut
> modem autoconfigure discovery
> no exec
> transport input all
> speed 115200
> flowcontrol hardware
>
>
> 2) REMOTEGW
>
> chat-script dial "" "ATZ&F" OK "ATDT5001" TIMEOUT 60 CONNECT
>
> interface Async8
> ip address 192.168.20.2 255.255.255.0
> no ip directed-broadcast
> encapsulation ppp
> dialer in-band
> dialer map ip 192.168.20.1 name R26 broadcast 5001 dialer-group 1
> autodetect encapsulation ppp
> async dynamic routing
> async mode interactive
> ppp authentication chap
>
> line 8
> no exec
> script dialer dial
> modem InOut
> modem autoconfigure discovery
> transport input all
> speed 115200
>
> The following is my debug, you can see that even the async interface
> is
up
> (it takes aroung 30 secounds so I keep ping it), PING still not
> success.
>
> REMOTEGW#p 192.168.20.1
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
>
> 8w5d: Async8 DDR: Dialing cause ip (s=192.168.20.2, d=192.168.20.1)
> 8w5d: Async8 DDR: Attempting to dial 5001
> 8w5d: CHAT8: Attempting async line dialer script
> 8w5d: CHAT8: Dialing using Modem script: dial & System script: none
> 8w5d: CHAT8: process started
> 8w5d: CHAT8: Asserting DTR
> 8w5d: CHAT8: Chat script dial started.....
> Success rate is 0 percent (0/5)
> REMOTEGW#p 192.168.20.1
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
> ..... Success rate is 0 percent (0/5)
> REMOTEGW#
> 8w5d: CHAT8: Chat script dial finished, status = Success
> 8w5d: TTY8: destroy timer type 1
> 8w5d: TTY8: destroy timer type 0
> 8w5d: %LINK-3-UPDOWN: Interface Async8, changed state to up
> REMOTEGW#p 192.168.20.1
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
> ..... Success rate is 0 percent (0/5)
> REMOTEGW#
>
> Any insight about this? I find that the modem will ring three times
before
> response to the call, is it the fatal problem? Or I have to make the
modem
> to certain operation mode so that for async routing to work?
>
> Thx a lot!
> BBD (Big Black Dog)
>
>
>
>
> DISCLAIMER:- This email is confidential and intended only for the use
> of the individual or entity named above and may contain information
> that is privileged. If you are not the intended recipient, you are
> notified that any dissemination, distribution or copying of this email
> is strictly prohibited. If you have received this email in error,
> please notify us immediately by return email or telephone and destroy
> the original
message.
> Thank you.
>
>
> ______________________________________________________________________
> _
> You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Tue Sep 02 2003 - 18:53:53 GMT-3