Cat 3550 - Multicast problems

From: Paul Chen (cpjchen@starhub.net.sg)
Date: Thu Jul 31 2003 - 03:33:54 GMT-3


Hi Everyone,

Appreciate any help from anyone on this problem.

The lab requirement is to configure vlan 50, 60 for multicast routing
with the catalyst switch.

Configs are show below:

Q1. How do you go about configuring multicast routing for the cat 3550
? Are my configs correct

Q2. Do you use igmp snooping since cgmp is not supported ? you can
configure igmp snooping only in global config mode

Q3. Why can't I ping 224.100.100.100 from the Cat 3550s if the rp
address is configured ? If you remove the rp address you
will no longer see it in 'sh ip mroute' , however you can ping
224.100.100.100 ?

----------------------------------------------------------------------------------------------------------------------

R4 is the static RP - 150.50.4.4 , RPs configured on R8, R7,R2,R1 , CAT
3550-1, CAT3550-2

R2 is a member of the multicast group 224.100.100.100

R7
||
vlan trunking for vlan 50,60
||
Cat 3550-2 ----------etherchannel ---------- Cat3550-1

On R7
-------------------------------------------------------------------------------------------------------------------

> interface Ethernet1/0.50
> encapsulation dot1q 50
> ip address 150.50.50.7 255.255.255.0
> ip router isis
> ip pim sparse-mode
> ip rsvp bandwidth 128 128
> !
> interface Ethernet1/0.60
> encapsulation dot1q 60
> ip address 150.50.60.7 255.255.255.0
> ip router isis
> ip pim sparse-mode

r7#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, Z - Multicast
Tunnel
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 01:41:01/00:02:51, RP 150.50.4.4, flags: SJCL
  Incoming interface: FastEthernet0/0.50, RPF nbr 150.50.50.5
  Outgoing interface list:
    Serial0/0, Forward/Sparse-Dense, 00:10:38/00:02:51

(*, 224.100.100.100), 00:44:02/00:02:04, RP 150.50.4.4, flags: SJPC
  Incoming interface: FastEthernet0/0.50, RPF nbr 150.50.50.5
  Outgoing interface list: Null

r7# sh ip pim rp
Group: 224.0.1.40, RP: 150.50.4.4, uptime 00:04:40, expires never
Group: 224.100.100.100, RP: 150.50.4.4, uptime 00:04:40, expires

r7#ping 224.100.100.100

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.100.100.100, timeout is 2 seconds:

Reply to request 0 from 150.50.100.2, 177 ms
Reply to request 0 from 150.50.100.2, 197 ms

On Cat
3550-2:-----------------------------------------------------------------------------------------------------

interface FastEthernet0/6
 switchport access vlan 60
 switchport mode access
 no ip address
!
interface FastEthernet0/7
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 50,60,1002-1005
 switchport mode trunk

interface Vlan50
 ip address 150.50.50.50 255.255.255.0
 ip pim sparse-dense-mode
 ip igmp join-group 224.100.100.100 --------- YOU CAN'T DO THIS IN
INTERFACE MODE ONLY INT VLAN
!
interface Vlan60
 ip address 150.50.60.60 255.255.255.0
 ip pim sparse-dense-mode
 ip igmp join-group 224.100.100.100

ip pim rp-address 150.50.4.4

cat3550-2# sh ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter
224.100.100.100 Vlan60 00:56:12 00:02:15 150.50.60.60
224.100.100.100 Vlan50 00:56:17 00:02:19 150.50.50.51
224.0.1.40 Vlan50 00:40:47 00:02:17 150.50.50.7

cat3550-2#ping 224.100.100.100 ------------------ > you can't ping this

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.100.100.100, timeout is 2 seconds:
.
cat3550-2#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, s - SSM Group, C - Connected, L - Local,
       P - Pruned, R - RP-bit set, F - Register flag, T - SPT-bit set,
       J - Join SPT, M - MSDP created entry, X - Proxy Join Timer Running
       A - Advertised via MSDP, U - URD, I - Received Source Specific Host
           Report
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 00:41:00/00:02:05, RP 150.50.4.4, flags: SJPCL
  Incoming interface: Null, RPF nbr 0.0.0.0 --------------------->
 Can't see neighbor ?
  Outgoing interface list: Null

(*, 224.100.100.100), 00:40:58/00:02:06, RP 150.50.4.4, flags: SJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Vlan60, Forward/Sparse-Dense, 00:40:53/00:02:02

cat3550-2#ping 224.100.100.100

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.100.100.100, timeout is 2 seconds:
.
cat3550-2#conf t
Enter configuration commands, one per line. End with CNTL/Z.

cat3550-2(config)#no ip pim rp-address 150.50.4.4 -----------> after
you remove the rp address, you can ping 224.100.100.100 ? Why ?

cat3550-2#ping 224.100.100.100

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.100.100.100, timeout is 2 seconds:

Reply to request 0 from 150.50.50.50, 4 ms
Reply to request 0 from 150.50.60.60, 4 ms

NOW YOU CAN'T SEE THE RP ANYMORE

cat3550-2#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, s - SSM Group, C - Connected, L - Local,
       P - Pruned, R - RP-bit set, F - Register flag, T - SPT-bit set,
       J - Join SPT, M - MSDP created entry, X - Proxy Join Timer Running
       A - Advertised via MSDP, U - URD, I - Received Source Specific Host
           Report
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 00:00:17/00:02:42, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Vlan60, Forward/Sparse-Dense, 00:00:17/00:00:00
    Vlan50, Forward/Sparse-Dense, 00:00:17/00:00:00

(*, 224.100.100.100), 00:00:17/stopped, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Vlan60, Forward/Sparse-Dense, 00:00:17/00:00:00
    Vlan50, Forward/Sparse-Dense, 00:00:17/00:00:00

(150.50.50.50, 224.100.100.100), 00:00:10/00:02:49, flags: LT
  Incoming interface: Vlan50, RPF nbr 0.0.0.0
  Outgoing interface list:
    Vlan60, Forward/Sparse-Dense, 00:00:14/00:00:00, H

(150.50.60.60, 224.100.100.100), 00:00:14/00:02:45, flags: LT
  Incoming interface: Vlan60, RPF nbr 0.0.0.0
  Outgoing interface list:
    Vlan50, Forward/Sparse-Dense, 00:00:14/00:00:00, H

cat3550-2#ping 224.100.100.100

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.100.100.100, timeout is 2 seconds:

Reply to request 0 from 150.50.50.50, 4 ms
Reply to request 0 from 150.50.60.60, 4 ms
cat3550-2#

cat3550-2#sh ip igmp snooping
vlan 1
----------
 IGMP snooping is globally enabled
 IGMP snooping is enabled on this Vlan
 IGMP snooping immediate-leave is disabled on this Vlan
 IGMP snooping mrouter learn mode is pim-dvmrp on this Vlan
 IGMP snooping is running in IGMP_ONLY mode on this Vlan
vlan 11
----------
 IGMP snooping is globally enabled
 IGMP snooping is enabled on this Vlan
 IGMP snooping immediate-leave is disabled on this Vlan
 IGMP snooping mrouter learn mode is pim-dvmrp on this Vlan
 IGMP snooping is running in IGMP_ONLY mode on this Vlan
vlan 50
----------
 IGMP snooping is globally enabled
 IGMP snooping is enabled on this Vlan
 IGMP snooping immediate-leave is disabled on this Vlan
 IGMP snooping mrouter learn mode is pim-dvmrp on this Vlan
 IGMP snooping is running in IGMP_ONLY mode on this Vlan
vlan 60
----------
 IGMP snooping is globally enabled
 IGMP snooping is enabled on this Vlan
 IGMP snooping immediate-leave is disabled on this Vlan
 IGMP snooping mrouter learn mode is pim-dvmrp on this Vlan
 IGMP snooping is running in IGMP_ONLY mode on this Vlan

On Cat
3550-1----------------------------------------------------------------------------------------------------

interface FastEthernet0/5
 switchport access vlan 50
 switchport mode access
 no ip address

interface Vlan50
 ip address 150.50.50.51 255.255.255.0
 ip pim sparse-dense-mode
 ip igmp join-group 224.100.100.100

ip pim rp-address 150.50.4.4

Same results - after removing the rp address you can ping
224.100.100.100 but can no longer see the rp in show ip mroute.

-----------------------------------------------------------------------------------------------------------------

Questions again : --

The lab requirement is to configure vlan 50, 60 for multicast routing
with the catalyst switch.

Q1. How do you go about configuring multicast routing for the cat 3550
? Are my configs correct

Q2. Do you use igmp snooping since cgmp is not supported ? you can
configure igmp snooping only in global config mode

Q3. Why can't I ping 224.100.100.100 from the Cat 3550s if the rp
address is configured ? If you remove the rp address you
will no longer see it in 'sh ip mroute' , however you can ping
224.100.100.100 ?

Thanks,
Paul



This archive was generated by hypermail 2.1.4 : Wed Aug 06 2003 - 06:52:59 GMT-3