RE: Problem pinging thru redist point

From: Jonathan V Hays (jhays@jtan.com)
Date: Tue Jul 15 2003 - 13:41:58 GMT-3


For a successful ping, the source host needs a route to the destination.
And the destination needs a route back to the source host, which looks
to be your problem here (see the routing table on r4).

When you ping through r6 your source address on r9 will be Serial 0 or
150.20.69.9. Naturally r6 has this route since it is directly connected.
But r4 does NOT have a route to 150.20.69.0/24. Why?

It looks like you are running EIGRP 30 between r9 and r6. On r9 you have
"no auto-summary" under "router eigrp 30" but on r6 you are missing "no
auto summary" which may not have the effect you want.

Another problem on r6:

> router ospf 1
> redistribute connected subnets route-map c2o
> redistribute eigrp 30 subnets

You don't have a metric specified for "red eigrp 30" which may not be a
showstopper but it's a good practice to always assign metrics for
redistribution.

You are only allowing loopback 0 in your "red connected". If playing
around with these other parameters doesn't get 150.20.69.0/24
redistributed into OSPF (and show up on r4) then you will have to add it
to your "redistribute connected" list.

HTH,

Jonathan

> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On
> Behalf Of Charles T. Alexander
> Sent: Tuesday, July 15, 2003 11:08 AM
> To: ccielab@groupstudy.com
> Subject: Problem pinging thru redist point
>
>
> Having a problem pinging from r9 to anywhere beyond r6 or to
> r6 loopback.
>
> r9-serial-r6-frame-r4 et. al.
>
> R6 is only able to run 11.3 R6 has the ATM as a shadow
> config in that there is no ATM at the other end, actually using s1.
>
> r9 config
> r9#r
> Building configuration...
>
> Current configuration : 1286 bytes
> !
> version 12.2
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname r9
> !
> logging buffered 10000 debugging
> enable password radnor
> !
> ip subnet-zero
> no ip domain-lookup
> ip host tbb3 150.50.6.210
> !
> !
> !
> !
> interface Loopback0
> ip address 150.10.9.9 255.255.255.255
> !
> interface Ethernet0
> ip address 150.50.6.209 255.255.255.128
> !
> interface Serial0
> bandwidth 64
> ip address 150.20.69.9 255.255.255.0
> ip summary-address eigrp 30 5.0.0.0 255.0.0.0 5
> ip summary-address eigrp 30 4.0.0.0 255.0.0.0 5
> no fair-queue
> clockrate 64000
> !
> interface Serial1
> no ip address
> shutdown
> !
> router eigrp 30
> redistribute eigrp 100 metric 64 60 254 1 1500
> network 150.20.0.0
> no auto-summary
> no eigrp log-neighbor-changes
> !
> router eigrp 100
> redistribute eigrp 30 metric 64 60 254 1 1500
> network 150.10.0.0
> network 150.50.0.0
> no auto-summary
> no eigrp log-neighbor-changes
> !
> ip classless
> ip http server
> ip pim bidir-enable
> !
> !
> alias exec i show ip route
> alias exec r show run
> alias exec c config t
> alias exec u undebug all
> alias exec b show ip bgp
> alias exec bs show ip bgp sum
> alias exec s show ip int brief
> !
> line con 0
> exec-timeout 0 0
> logging synchronous
> escape-character 27
> line aux 0
> line vty 0 4
> exec-timeout 0 0
> password bp
> login
> !
> end
>
> r9#
>
> r9 ip route
> r9#i
> Codes: C - connected, S - static, I - IGRP, R - RIP, M -
> mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia
> - IS-IS inter area
> * - candidate default, U - per-user static route, o - ODR
> P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 187.227.0.0/24 is subnetted, 1 subnets
> D EX 187.227.32.0 [170/40522240] via 150.20.69.6, 00:58:01, Serial0
> 168.17.0.0/24 is subnetted, 1 subnets
> D EX 168.17.1.0 [170/40522240] via 150.20.69.6, 00:58:01, Serial0
> 4.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
> D 4.0.0.0/8 is a summary, 00:58:04, Null0
> D 4.1.1.0/24 [90/409600] via 150.50.6.210, 00:58:04, Ethernet0
> D 4.2.1.0/24 [90/409600] via 150.50.6.210, 00:58:04, Ethernet0
> D 4.1.2.0/24 [90/409600] via 150.50.6.210, 00:58:05, Ethernet0
> 5.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
> D 5.0.0.0/8 is a summary, 00:58:05, Null0
> D 5.1.1.0/24 [90/409600] via 150.50.6.210, 00:58:05, Ethernet0
> D 5.221.101.0/24 [90/409600] via 150.50.6.210,
> 00:58:05, Ethernet0
> 188.5.0.0/24 is subnetted, 1 subnets
> D EX 188.5.254.0 [170/40522240] via 150.20.69.6, 00:58:02, Serial0
> D EX 193.100.5.0/24 [170/40522240] via 150.20.69.6, 00:58:02, Serial0
> 40.0.0.0/24 is subnetted, 1 subnets
> D EX 40.193.4.0 [170/40522240] via 150.20.69.6, 00:58:02, Serial0
> D EX 192.168.1.0/24 [170/40522240] via 150.20.69.6, 00:58:02, Serial0
> 150.50.0.0/16 is variably subnetted, 2 subnets, 2 masks
> C 150.50.6.128/25 is directly connected, Ethernet0
> D EX 150.50.200.0/24 [170/40522240] via 150.20.69.6,
> 00:58:03, Serial0
> D EX 193.100.2.0/24 [170/40522240] via 150.20.69.6, 00:58:03, Serial0
> 150.10.0.0/32 is subnetted, 7 subnets
> D EX 150.10.8.8 [170/40522240] via 150.20.69.6, 00:58:03, Serial0
> D EX 150.10.2.2 [170/40522240] via 150.20.69.6, 00:58:03, Serial0
> D EX 150.10.1.1 [170/40522240] via 150.20.69.6, 00:58:03, Serial0
> D EX 150.10.7.7 [170/40522240] via 150.20.69.6, 00:58:03, Serial0
> D EX 150.10.4.4 [170/40522240] via 150.20.69.6, 00:58:04, Serial0
> D EX 150.10.5.5 [170/40522240] via 150.20.69.6, 00:58:04, Serial0
> C 150.10.9.9 is directly connected, Loopback0
> 150.20.0.0/16 is variably subnetted, 10 subnets, 4 masks
> D EX 150.20.12.0/24 [170/40522240] via 150.20.69.6,
> 00:58:04, Serial0
> D EX 150.20.25.0/24 [170/40522240] via 150.20.69.6,
> 00:58:04, Serial0
> D EX 150.20.40.0/24 [170/40522240] via 150.20.69.6,
> 00:58:04, Serial0
> D 150.20.50.0/26 [90/40537600] via 150.20.69.6,
> 00:58:04, Serial0
> C 150.20.69.0/24 is directly connected, Serial0
> D EX 150.20.78.0/24 [170/40522240] via 150.20.69.6,
> 00:58:04, Serial0
> D EX 150.20.100.4/32 [170/40522240] via 150.20.69.6,
> 00:58:04, Serial0
> D EX 150.20.100.5/32 [170/40522240] via 150.20.69.6,
> 00:58:04, Serial0
> D EX 150.20.100.2/32 [170/40522240] via 150.20.69.6,
> 00:58:04, Serial0
> D 150.20.100.0/27 [90/41024000] via 150.20.69.6,
> 00:58:04, Serial0
> r9#
> r6 config
> r6#r
> Building configuration...
>
> Current configuration:
> !
> version 12.0
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname r6
> !
> logging buffered 10000 debugging
> enable password radnor
> !
> ip subnet-zero
> no ip domain-lookup
> !
> ip cef
> !
> !
> !
> interface Loopback0
> ip address 150.10.6.6 255.255.255.255
> no ip directed-broadcast
> !
> interface Ethernet0/0
> ip address 150.20.50.6 255.255.255.192
> no ip directed-broadcast
> ip ospf priority 0
> !
> interface Ethernet0/1
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface Ethernet0/2
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface Ethernet0/3
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface Serial1/0
> ip address 150.20.100.6 255.255.255.224
> no ip directed-broadcast
> encapsulation frame-relay
> ip ospf message-digest-key 1 md5 ctasta
> ip ospf network point-to-multipoint
> ip ospf priority 0
> no ip mroute-cache
> frame-relay map ip 150.20.100.2 604 broadcast
> frame-relay map ip 150.20.100.4 604 broadcast
> frame-relay map ip 150.20.100.5 604 broadcast
> frame-relay map ip 150.20.100.6 604
> no frame-relay inverse-arp
> frame-relay lmi-type ansi
> !
> interface Serial1/1
> bandwidth 64
> ip address 150.20.69.6 255.255.255.0
> no ip directed-broadcast
> !
> interface Serial1/2
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface Serial1/3
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface ATM2/0
> no ip address
> no ip directed-broadcast
> !
> interface ATM2/0.1 point-to-point
> ip address 151.20.69.6 255.255.255.0
> no ip directed-broadcast
> atm pvc 1 0 100 aal5snap
> !
> router eigrp 30
> redistribute ospf 1 metric 64 40 254 1 1500
> network 150.20.0.0
> !
> router ospf 1
> redistribute connected subnets route-map c2o
> redistribute eigrp 30 subnets
> network 150.20.50.0 0.0.0.63 area 30
> network 150.20.100.0 0.0.0.31 area 0
> area 0 authentication message-digest
> area 0 range 150.20.100.0 255.255.255.0
> area 30 range 150.20.50.0 255.255.255.0
> area 30 virtual-link 150.10.7.7 message-digest-key 1 md5 ctasta
> !
> ip classless
> no ip http server
> !
> access-list 1 permit 150.10.6.6
> route-map c2o permit 10
> match ip address 1
> !
> !
> alias exec i show ip route
> alias exec r show run
> alias exec c config t
> alias exec u undebug all
> alias exec b show ip bgp
> alias exec bs show ip bgp sum
> alias exec s show ip int brief
> !
> line con 0
> exec-timeout 0 0
> logging synchronous
> transport input none
> escape-character 27
> line aux 0
> line vty 0 4
> exec-timeout 0 0
> password bp
> login
> !
> end
>
> r6#
> r6 ip route
> r6#i
> Codes: C - connected, S - static, I - IGRP, R - RIP, M -
> mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * -
> candidate default
> U - per-user static route, o - ODR, P - periodic
> downloaded static route
> T - traffic engineered route
>
> Gateway of last resort is not set
>
> 187.227.0.0/24 is subnetted, 1 subnets
> O E2 187.227.32.0 [110/20] via 150.20.50.7, Ethernet0/0
> 168.17.0.0/24 is subnetted, 1 subnets
> O E2 168.17.1.0 [110/20] via 150.20.50.7, Ethernet0/0
> D 4.0.0.0/8 [90/40527360] via 150.20.69.9, Serial1/1
> D 5.0.0.0/8 [90/40527360] via 150.20.69.9, Serial1/1
> 188.5.0.0/24 is subnetted, 1 subnets
> O E2 188.5.254.0 [110/20] via 150.20.50.5, Ethernet0/0
> O E2 193.100.5.0/24 [110/20] via 150.20.100.4, Serial1/0
> 40.0.0.0/24 is subnetted, 1 subnets
> O E2 40.193.4.0 [110/20] via 150.20.50.7, Ethernet0/0
> O E2 192.168.1.0/24 [110/20] via 150.20.100.4, Serial1/0
> 151.20.0.0/24 is subnetted, 1 subnets
> C 151.20.69.0 is directly connected, ATM2/0.1
> 150.50.0.0/16 is variably subnetted, 2 subnets, 2 masks
> D EX 150.50.6.128/25 [170/40527360] via 150.20.69.9, Serial1/1
> O E2 150.50.200.0/24 [110/20] via 150.20.100.4, Serial1/0
> O E2 193.100.2.0/24 [110/20] via 150.20.100.4, Serial1/0
> 150.10.0.0/32 is subnetted, 8 subnets
> D EX 150.10.9.9 [170/40527360] via 150.20.69.9, Serial1/1
> O E2 150.10.8.8 [110/20] via 150.20.50.7, Ethernet0/0
> O E2 150.10.2.2 [110/20] via 150.20.100.4, Serial1/0
> O E2 150.10.1.1 [110/20] via 150.20.100.4, Serial1/0
> O IA 150.10.7.7 [110/11] via 150.20.50.7, Ethernet0/0
> O IA 150.10.4.4 [110/65] via 150.20.100.4, Serial1/0
> O E2 150.10.5.5 [110/20] via 150.20.50.5, Ethernet0/0
> C 150.10.6.6 is directly connected, Loopback0
> 150.20.0.0/16 is variably subnetted, 10 subnets, 4 masks
> O E2 150.20.12.0/24 [110/20] via 150.20.100.4, Serial1/0
> O E2 150.20.25.0/24 [110/20] via 150.20.100.4, Serial1/0
> O IA 150.20.40.0/24 [110/74] via 150.20.100.4, Serial1/0
> C 150.20.50.0/26 is directly connected, Ethernet0/0
> C 150.20.69.0/24 is directly connected, Serial1/1
> O IA 150.20.78.0/24 [110/1572] via 150.20.50.7, Ethernet0/0
> O 150.20.100.4/32 [110/64] via 150.20.100.4, Serial1/0
> O 150.20.100.5/32 [110/20] via 150.20.50.7, Ethernet0/0
> O 150.20.100.2/32 [110/128] via 150.20.100.4, Serial1/0
> C 150.20.100.0/27 is directly connected, Serial1/0
> r6#
> r4 config
> r4#r
> Building configuration...
>
> Current configuration : 1582 bytes
> !
> version 12.2
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname r4
> !
> logging buffered 10000 debugging
> enable password radnor
> !
> ip subnet-zero
> no ip domain-lookup
> !
> !
> !
> !
> interface Loopback0
> ip address 150.10.4.4 255.255.255.255
> !
> interface Ethernet0
> ip address 150.20.40.4 255.255.255.0
> !
> interface Serial0
> ip address 150.20.100.4 255.255.255.224
> encapsulation frame-relay
> ip ospf message-digest-key 1 md5 ctasta
> ip ospf network point-to-multipoint
> ip ospf priority 10
> frame-relay map ip 150.20.100.2 401 broadcast
> frame-relay map ip 150.20.100.4 401
> frame-relay map ip 150.20.100.5 405 broadcast
> frame-relay map ip 150.20.100.6 406 broadcast
> no frame-relay inverse-arp
> frame-relay lmi-type ansi
> !
> interface Serial1
> no ip address
> shutdown
> !
> interface TokenRing0
> no ip address
> shutdown
> !
> router ospf 1
> router-id 150.10.4.4
> log-adjacency-changes
> area 0 authentication message-digest
> area 0 range 150.20.100.0 255.255.255.0
> area 22 stub no-summary
> network 150.10.4.4 0.0.0.0 area 22
> network 150.20.40.0 0.0.0.255 area 22
> network 150.20.100.0 0.0.0.31 area 0
> neighbor 150.20.100.2
> neighbor 150.20.100.5
> neighbor 150.20.100.6
> !
> ip classless
> ip http server
> ip pim bidir-enable
> !
> !
> alias exec i show ip route
> alias exec r show run
> alias exec c config t
> alias exec u undebug all
> alias exec b show ip bgp
> alias exec bs show ip bgp sum
> alias exec s show ip int brief
> !
> line con 0
> exec-timeout 0 0
> logging synchronous
> escape-character 27
> line aux 0
> line vty 0 4
> exec-timeout 0 0
> password bp
> login
> !
> end
>
> r4#
> r4 ip route
> r4#i
> Codes: C - connected, S - static, I - IGRP, R - RIP, M -
> mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia
> - IS-IS inter area
> * - candidate default, U - per-user static route, o - ODR
> P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 187.227.0.0/24 is subnetted, 1 subnets
> O E2 187.227.32.0 [110/20] via 150.20.100.5, 01:20:31, Serial0
> [110/20] via 150.20.100.6, 01:20:31, Serial0
> 168.17.0.0/24 is subnetted, 1 subnets
> O E2 168.17.1.0 [110/20] via 150.20.100.5, 01:20:31, Serial0
> [110/20] via 150.20.100.6, 01:20:31, Serial0
> O E2 4.0.0.0/8 [110/20] via 150.20.100.6, 00:55:57, Serial0
> O E2 5.0.0.0/8 [110/20] via 150.20.100.6, 00:55:58, Serial0
> 188.5.0.0/24 is subnetted, 1 subnets
> O E2 188.5.254.0 [110/20] via 150.20.100.5, 01:20:32, Serial0
> O E2 193.100.5.0/24 [110/20] via 150.20.100.2, 01:20:32, Serial0
> 40.0.0.0/24 is subnetted, 1 subnets
> O E2 40.193.4.0 [110/20] via 150.20.100.5, 01:20:32, Serial0
> [110/20] via 150.20.100.6, 01:20:32, Serial0
> O E2 192.168.1.0/24 [110/20] via 150.20.100.2, 01:20:33, Serial0
> 150.50.0.0/16 is variably subnetted, 2 subnets, 2 masks
> O E2 150.50.6.128/25 [110/20] via 150.20.100.6, 00:55:55, Serial0
> O E2 150.50.200.0/24 [110/20] via 150.20.100.2, 01:20:33, Serial0
> O E2 193.100.2.0/24 [110/20] via 150.20.100.2, 01:20:33, Serial0
> 150.10.0.0/32 is subnetted, 8 subnets
> O E2 150.10.9.9 [110/20] via 150.20.100.6, 00:55:56, Serial0
> O E2 150.10.6.6 [110/20] via 150.20.100.6, 01:20:33, Serial0
> O E2 150.10.8.8 [110/20] via 150.20.100.5, 01:20:33, Serial0
> [110/20] via 150.20.100.6, 01:20:33, Serial0
> O IA 150.10.7.7 [110/75] via 150.20.100.5, 01:20:33, Serial0
> [110/75] via 150.20.100.6, 01:20:33, Serial0
> O E2 150.10.5.5 [110/20] via 150.20.100.5, 01:20:33, Serial0
> O E2 150.10.2.2 [110/20] via 150.20.100.2, 01:20:33, Serial0
> O E2 150.10.1.1 [110/20] via 150.20.100.2, 01:20:34, Serial0
> C 150.10.4.4 is directly connected, Loopback0
> 150.20.0.0/16 is variably subnetted, 10 subnets, 3 masks
> O E2 150.20.12.0/24 [110/20] via 150.20.100.2, 01:20:34, Serial0
> O E2 150.20.25.0/24 [110/20] via 150.20.100.2, 01:20:34, Serial0
> C 150.20.40.0/24 is directly connected, Ethernet0
> O IA 150.20.50.0/24 [110/74] via 150.20.100.5, 01:20:34, Serial0
> [110/74] via 150.20.100.6, 01:20:34, Serial0
> O IA 150.20.78.0/24 [110/1636] via 150.20.100.5, 01:20:35, Serial0
> [110/1636] via 150.20.100.6, 01:20:35, Serial0
> O 150.20.100.6/32 [110/64] via 150.20.100.6, 01:20:35, Serial0
> O 150.20.100.5/32 [110/64] via 150.20.100.5, 01:20:35, Serial0
> O 150.20.100.2/32 [110/64] via 150.20.100.2, 01:20:35, Serial0
> O 150.20.100.0/24 is a summary, 01:20:35, Null0
> C 150.20.100.0/27 is directly connected, Serial0
> r4#
>
>
> ______________________________________________________________
> _________
> You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Wed Aug 06 2003 - 06:52:39 GMT-3