From: Jason Cash (cash2001@swbell.net)
Date: Wed Jul 09 2003 - 16:17:20 GMT-3
If a requirement is stated as "Only one routing protocol can be active on
any interface"; is redistributing that interface into another protocol a
violation of the requirement? From reading a previous thread, I was curious
and concerned about this. For instance, in the example below, E0 is part of
the Rip process and the S0.24 is redistributed into it and vice versa for
EIGRP. Is this an acceptable solution or does this create the instance of
having two routing protocol active on an interface?
interface Ethernet0
description to R1 E0 (crossover)
ip address 172.16.12.2 255.255.255.0
!
interface Serial0.24 point-to-point
ip address 172.16.24.1 255.255.255.252
!
router rip
redistribute connected metric 2 route-map ripc
network 172.16.0.0
!
router eigrp 40
redistribute connected route-map eigrpc
network 172.16.24.0 0.0.0.3
no auto-summary
no eigrp log-neighbor-changes
!
ip access-list standard conn
permit 172.16.12.0 0.0.0.255
permit 172.16.24.0 0.0.0.3
!
route-map ripc permit 10
match ip address conn
!
route-map eigrpc permit 10
match ip address conn
This archive was generated by hypermail 2.1.4 : Wed Aug 06 2003 - 06:52:31 GMT-3