RE: mismatch area in header

From: Snow, Tim (timothy.snow@eds.com)
Date: Tue Jul 08 2003 - 23:26:01 GMT-3


I seem to have a faint memory of this type of issue happening with Frame
Relay Inverse arp automagically mapping addresses that I didn't want mapped.

Which is why I usually turn on "no arp frame", "no frame inverse-arp" always
now. Take a look at that and see if that could be causing any issues.

Tim

-----Original Message-----
From: John Matijevic [mailto:matijevi@bellsouth.net]
Sent: Tuesday, July 08, 2003 10:12 PM
To: John Matijevic; ccielab@groupstudy.com
Subject: Re: mismatch area in header

Hello Team,
Still working on this....
Here are configs so you can have a better idea of whats going on, again
adjacencies are established, and i can ping across network.
Sincerely,
Matijevic
r2#wr t
Building configuration...

Current configuration : 1415 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
!
cns event-service server
!
!
!
!
!
interface Loopback0
 description management-loopback-interface
 ip address 172.16.102.1 255.255.255.255
!
interface Ethernet0
 ip address 172.16.20.2 255.255.255.0
!
interface Serial0
 ip address 172.16.123.2 255.255.255.0
 encapsulation frame-relay
 ip ospf network non-broadcast
 ip ospf priority 0
 frame-relay map ip 172.16.123.1 201 broadcast
 frame-relay map ip 172.16.123.2 201 broadcast
 frame-relay map ip 172.16.123.3 201 broadcast
 frame-relay lmi-type ansi
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 no ip address
 shutdown
!
router ospf 1
 router-id 172.16.102.1
 log-adjacency-changes
 summary-address 172.16.50.0 255.255.255.0
 redistribute rip subnets route-map rip2ospf
 network 172.16.102.1 0.0.0.0 area 20
 network 172.16.123.0 0.0.0.255 area 0
!
router rip
 redistribute ospf 1 metric 2
 passive-interface default
 no passive-interface Ethernet0
 network 172.16.0.0
!
ip kerberos source-interface any
ip classless
no ip http server
!
access-list 1 permit 172.16.20.0 0.0.0.255
route-map rip2ospf permit 10
 match ip address 1
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

r2#
comm-server#1
[Resuming connection 1 to r1 ... ]

r1>en
r1#wr t
Building configuration...

Current configuration : 1396 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
!
cns event-service server
!
!
!
!
!
interface Loopback0
 description loopback-management-interface
 ip address 172.16.101.1 255.255.255.255
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no fair-queue
 frame-relay lmi-type ansi
!
interface Serial0.1 multipoint
 ip address 172.16.123.1 255.255.255.0
 ip ospf network non-broadcast
 frame-relay map ip 172.16.123.1 102 broadcast
 frame-relay map ip 172.16.123.2 102 broadcast
 frame-relay map ip 172.16.123.3 103 broadcast
 no frame-relay inverse-arp
!
interface Serial0.2 point-to-point
 ip address 172.16.14.1 255.255.255.0
 ip ospf network point-to-point
 frame-relay interface-dlci 104
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 no ip address
 shutdown
!
router ospf 1
 router-id 172.16.101.1
 log-adjacency-changes
 network 172.16.14.0 0.0.0.255 area 14
 network 172.16.101.1 0.0.0.0 area 10
 network 172.16.123.0 0.0.0.255 area 0
 neighbor 172.16.123.3
 neighbor 172.16.123.2
!
ip kerberos source-interface any
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

r1#
comm-server#4
[Resuming connection 4 to r4 ... ]

r4>en
r4#wr t
Building configuration...

Current configuration : 1211 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r4
!
!
!
!
!
!
ip subnet-zero
!
ip audit notify log
ip audit po max-events 100
!
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
!
!
interface Loopback0
 description management-loopback-interface
 ip address 172.16.104.1 255.255.255.255
!
interface Loopback1
 ip address 4.4.4.4 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.16.34.4 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 172.16.14.4 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-point
 frame-relay map ip 172.16.14.1 401 broadcast
 frame-relay map ip 172.16.14.4 401 broadcast
 frame-relay lmi-type ansi
!
interface Serial0/1
 no ip address
 shutdown
!
router ospf 1
 router-id 172.16.104.1
 log-adjacency-changes
 redistribute rip subnets
 network 172.16.14.0 0.0.0.255 area 14
!
router rip
 version 2
 redistribute ospf 1 metric 2
 passive-interface default
 no passive-interface FastEthernet0/0
 network 4.0.0.0
 network 172.16.0.0
 no auto-summary
!
ip classless
ip http server
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

r4#
----- Original Message -----
From: "John Matijevic" <matijevi@bellsouth.net>
To: <ccielab@groupstudy.com>
Sent: Tuesday, July 08, 2003 9:42 PM
Subject: mismatch area in header

> Hello Team,
> I have the following scenerio:
> I have area 0 and area 14,
> R1, R2 and R3 is in Area 0
> R1 and R4 area in area 14
> I can establish adjacencies fine.
> But for some reason when I turn on deb ip ospf adj,
> I get the following:
> mismatch area 0.0.0.14 in the header,
> Again, I can ping and form adjacencys, everything looks ok, but I want to
> resove this mismatch message I keep getting on R2, and R3,
> Any assistance would be greatly appreciated!
> Sincerely,
> Matijevic
>
>
> _______________________________________________________________________
> You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Wed Aug 06 2003 - 06:52:28 GMT-3