Re: OSPF<->EIGRP Mutual Redistribution - little long

From: Glenn Johnson (GJcomcast@comcast.net)
Date: Sun Jul 06 2003 - 20:26:32 GMT-3


Badger,

        Your scenario seems to work ok for me using redistribute connected.
Is this similar to your config?

R1
-------------------------------------
interface Loopback0
 ip address 200.0.0.8 255.255.255.255
 ip ospf network point-to-point
!
interface Loopback1
 ip address 150.50.24.8 255.255.255.0
 ip ospf network point-to-point
!
interface Ethernet0
 ip address 150.50.12.8 255.255.255.0
!
interface Serial0
 ip address 150.50.100.8 255.255.255.0
!
interface Serial1
 no ip address
 shutdown
!
router eigrp 1
 redistribute ospf 1 metric 10000 100 255 1 1500
 network 150.50.12.0 0.0.0.255
 no auto-summary
 no eigrp log-neighbor-changes
!
router ospf 1
 log-adjacency-changes
 redistribute connected metric 20 subnets
 redistribute eigrp 1 subnets
 network 150.50.24.0 0.0.0.255 area 0
 network 150.50.100.0 0.0.0.255 area 0
!

R2
--------------------------------------
interface Loopback0
 ip address 200.0.0.11 255.255.255.255
!
interface Loopback1
 ip address 150.50.77.11 255.255.255.0
!
interface Ethernet0
 ip address 150.50.12.11 255.255.255.0
!
interface Serial0
 no ip address
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
router eigrp 1
 redistribute connected metric 10000 100 255 1 1500
 network 150.50.12.0 0.0.0.255
 network 150.50.77.0 0.0.0.255
 no auto-summary
 no eigrp log-neighbor-changes

R8 (connected to R1 via the 150.50.100.0 network)
-------------------------------------------------
interface Serial0/0
 ip address 150.50.100.7 255.255.255.0
 no fair-queue
 clockrate 128000
!
router ospf 1
 log-adjacency-changes
 network 150.50.100.0 0.0.0.255 area 0

R8's routing table:
-------------------------------------------------
R8#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     200.0.0.0/32 is subnetted, 2 subnets
O E2 200.0.0.8 [110/20] via 150.50.100.8, 00:39:14, Serial0/0
O E2 200.0.0.11 [110/20] via 150.50.100.8, 00:38:41, Serial0/0
     150.50.0.0/24 is subnetted, 4 subnets
O E2 150.50.12.0 [110/20] via 150.50.100.8, 00:39:14, Serial0/0
O 150.50.24.0 [110/65] via 150.50.100.8, 00:39:14, Serial0/0
C 150.50.100.0 is directly connected, Serial0/0
O E2 150.50.77.0 [110/20] via 150.50.100.8, 00:38:41, Serial0/0
R8#ping 150.50.12.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.50.12.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
badger
Sent: Sunday, July 06, 2003 11:21 AM
To: badger
Cc: ccielab@groupstudy.com
Subject: Re: OSPF<->EIGRP Mutual Redistribution - little long

Hello badger,

Saturday, July 5, 2003, 9:29:31 AM, you wrote:

b> Hello ccielab,

b> I need a little help in understanding the stated lab requirements
b> concerning "must be able to ping every router from every router," -
b> I think it goes something like that.

b> Here is my point...I've been doing various lab scenarios that have
b> those same basic stated requirements and find that, at least to my
b> understanding, their solutions do not always meet the requirements.
b> Here is an example and maybe someone can tell me what I'm missing.

b> For example, when doing mutual redistribution between OSPF and
b> EIGRP, I notice that the connected networks under the respective
b> routing processes get redistributed between the processes - here is
b> a graphic - hope it comes out correct:

b> OSPF EIGRP
b> |
b> Lo 200.0.0.1 |
b> | |
b> | |
b> 150.50.100.x-------R1--------|----150.50.12.x-----R2------150.50.77.x
b> | | |
b> | | |
b> 150.50.24.x | Lo 200.0.0.2
b> |
b> When doing redistribution in the above case, the OSPF connected
b> networks, 100.x and 24.x, and the EIGRP connected networks, 12.x and
b> 77.x, are mutually seen by both processes. So, if I'm on say another
b> OSPF router, say R8, then I can ping the EIGRP 12.x interface -
b> everything is great.

b> Now here's the catch and something I've observed in doing my
b> scenarios. If I now redistribute my connected loopbacks into their
b> respective routing processes, the loopsbacks get their mutual
b> redistribution between OSPF and EIGRP, but now the connected networks
b> disappear from the mutual redistribution. In other words, if I'm on
b> the OSPF router R8 now and try to ping the 12.x (EIGRP) interface, I
b> can't because it has been dropped for the redistribution.

b> My solution would be to add the 12.x network under my OSPF
b> "redistribute connected" of R1, but the lab solutions don't do this and
b> I'm not certain if my solution violates the requirement of putting
b> this network under a routing process to which it doesn't belong. The
b> lab scenario solutions to seem to care about not having a route to
b> this 12.x network.

b> So, what's wrong here?

b> Thanks

b> -
b> Best regards,
b> badger mailto:badger@pongo.org

b> _______________________________________________________________________
b> You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.

b> Subscription information may be found at:
b> http://www.groupstudy.com/list/CCIELab.html

Still no response to my question. Bottom line is that whenever I'm
doing mutual redistribution and throw the "redistribute connected"
under with eigrp or ospf, their actual connect routes are dropped from
redistribution. This is driving me nuts, is my question that bad?

-- 
Best regards,
 badger                            mailto:badger@pongo.org


This archive was generated by hypermail 2.1.4 : Wed Aug 06 2003 - 06:52:26 GMT-3