From: John Underhill (stepnwlf@magma.ca)
Date: Thu Jul 03 2003 - 23:00:59 GMT-3
Because you are using loopbacks and not directly connected interfaces
between EGP neighbors, you will need to add the 'neighbor x.x.x.x
ebgp-multihop' command, also, you should be creating the peering between the
bgp router ids, I also don't see an IGP or static route passing the loopback
routes between routers.. Here is an example of a working config..
R1
interface Loopback100
description BGP loopback
ip address 10.10.100.1 255.255.255.0
!
interface Ethernet0
ip address 150.50.17.1 255.255.255.0
router bgp 100
no synchronization
bgp router-id 10.10.100.1
bgp log-neighbor-changes
network 10.10.100.1 mask 255.255.255.255
neighbor 10.10.150.1 remote-as 150
neighbor 10.10.150.1 ebgp-multihop 255
neighbor 10.10.150.1 update-source Loopback100
no auto-summary
!
ip classless
ip route 10.10.150.0 255.255.255.0 Ethernet0
r1#sh ip bgp
BGP table version is 2, local router ID is 10.10.100.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.10.150.0/24 10.10.150.1 0 0 150 i
R2
interface Loopback150
description BGP loopback
ip address 10.10.150.1 255.255.255.0
!
interface Ethernet0
ip address 150.50.17.2 255.255.255.0
!
router bgp 150
no synchronization
bgp router-id 10.10.150.1
bgp log-neighbor-changes
network 10.10.150.0 mask 255.255.255.0
neighbor 10.10.100.1 remote-as 100
neighbor 10.10.100.1 ebgp-multihop 255
neighbor 10.10.100.1 update-source Loopback150
no auto-summary
!
ip classless
ip route 10.10.100.0 255.255.255.0 Ethernet0
----- Original Message -----
From: "Richard L. Pickard" <nettable_walker@comcast.net>
To: "Ccielab@Groupstudy. Com" <ccielab@groupstudy.com>
Sent: Thursday, July 03, 2003 8:32 PM
Subject: pure eBGP set up will not pass routes
> Fiestahostname R_25
> !
>
> interface Loopback100
> description BGP loopback
> ip address 10.10.100.1 255.255.255.0
> !
>
> !
> interface Serial0/1
> ip address 172.16.1.2 255.255.255.252
>
> !
> interface Ethernet3/0
> ip address 11.11.11.1 255.255.255.0
> ip accounting output-packets
> full-duplex
>
> router bgp 100
> no synchronization
> bgp router-id 10.10.100.1
> bgp log-neighbor-changes
> network 10.10.100.1
> network 11.11.11.0
> network 172.16.1.2
> redistribute connected
> neighbor 11.11.11.11 remote-as 11
> neighbor 172.16.1.1 remote-as 150
> neighbor 172.16.1.1 update-source Loopback100
> no auto-summary
>
>
> R_25#sh ip route
> Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2
> i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
level-2
> ia - IS-IS inter area, * - candidate default, U - per-user static
> route
> o - ODR, P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 172.16.0.0/30 is subnetted, 1 subnets
> C 172.16.1.0 is directly connected, Serial0/1
> 10.0.0.0/24 is subnetted, 1 subnets
> C 10.10.100.0 is directly connected, Loopback100
> 11.0.0.0/24 is subnetted, 1 subnets
> C 11.11.11.0 is directly connected, Ethernet3/0
> R_25#sh ip bgp
> BGP table version is 4, local router ID is 10.10.100.1
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal,
> r RIB-failure, S Stale
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> *> 10.10.100.0/24 0.0.0.0 0 32768 ?
> *> 11.11.11.0/24 0.0.0.0 0 32768 ?
> *> 172.16.1.0/30 0.0.0.0 0 32768 ?
> R_25#
>
> =======================================================================
>
> hostname Expresso__
>
> !
> interface Loopback150
> description BGP loopback
> ip address 10.10.150.1 255.255.255.0
> !
> interface Loopback151
> ip address 10.150.150.1 255.255.255.0
> !
>
> !
> interface Ethernet0/0
> ip address 111.111.111.11 255.255.255.0
> ip accounting output-packets
> full-duplex
> ipx accounting
>
> !
> interface Serial0/0
> ip address 172.16.0.1 255.255.255.252
> ip accounting output-packets
> clockrate 128000
> !
>
> interface Serial0/1
> ip address 172.16.1.1 255.255.255.252
> ip accounting output-packets
> clockrate 128000
>
>
> router bgp 150
> no synchronization
> bgp router-id 10.10.150.1
> bgp log-neighbor-changes
> network 10.10.150.1
> network 10.150.150.1
> network 111.111.111.111
> network 172.16.0.1
> network 172.16.1.1
> redistribute connected
> neighbor 172.16.0.2 remote-as 200
> neighbor 172.16.0.2 update-source Loopback150
> neighbor 172.16.1.2 remote-as 100
> neighbor 172.16.1.2 update-source Loopback150
> no auto-summary
>
>
> Expresso__#sh ip route
> Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2
> i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
level-2
> ia - IS-IS inter area, * - candidate default, U - per-user static
> route
> o - ODR, P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 172.16.0.0/30 is subnetted, 2 subnets
> C 172.16.0.0 is directly connected, Serial0/0
> C 172.16.1.0 is directly connected, Serial0/1
> 111.0.0.0/24 is subnetted, 1 subnets
> C 111.111.111.0 is directly connected, FastEthernet0/0
> 10.0.0.0/24 is subnetted, 2 subnets
> C 10.150.150.0 is directly connected, Loopback151
> C 10.10.150.0 is directly connected, Loopback150
> Expresso__#sh ip bgp
> BGP table version is 6, local router ID is 10.10.150.1
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal,
> r RIB-failure, S Stale
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> *> 10.10.150.0/24 0.0.0.0 0 32768 ?
> *> 10.150.150.0/24 0.0.0.0 0 32768 ?
> *> 111.111.111.0/24 0.0.0.0 0 32768 ?
> *> 172.16.0.0/30 0.0.0.0 0 32768 ?
> *> 172.16.1.0/30 0.0.0.0 0 32768 ?
> Expresso__#
>
> ==========================================================================
>
>
> Starbucks#sh run
>
> !
> hostname Starbucks
> !
>
> interface Loopback121
> ip address 10.121.150.1 255.255.255.0
> !
> interface Loopback200
> description BGP loopback
> ip address 10.10.200.1 255.255.255.0
>
>
> interface Serial0/0
> ip address 172.16.0.2 255.255.255.252
>
>
> router bgp 200
> no synchronization
> bgp router-id 10.10.200.1
> bgp log-neighbor-changes
> network 10.10.200.1
> network 10.121.150.1
> network 172.16.0.2
> redistribute connected
> neighbor 172.16.0.1 remote-as 150
> neighbor 172.16.0.1 update-source Loopback200
> no auto-summary
>
>
> Starbucks#sh ip route
> Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2
> i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
level-2
> ia - IS-IS inter area, * - candidate default, U - per-user static
> route
> o - ODR, P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 172.16.0.0/30 is subnetted, 1 subnets
> C 172.16.0.0 is directly connected, Serial0/0
> 10.0.0.0/24 is subnetted, 2 subnets
> C 10.10.200.0 is directly connected, Loopback200
> C 10.121.150.0 is directly connected, Loopback121
> Starbucks#sh ip bgp
> BGP table version is 4, local router ID is 10.10.200.1
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal,
> r RIB-failure, S Stale
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> *> 10.10.200.0/24 0.0.0.0 0 32768 ?
> *> 10.121.150.0/24 0.0.0.0 0 32768 ?
> *> 172.16.0.0/30 0.0.0.0 0 32768 ?
> Starbucks#
>
> [GroupStudy removed an attachment of type image/jpeg which had a name of
Fiesta Bkgrd.jpg]
>
>
> _______________________________________________________________________
> You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Wed Aug 06 2003 - 06:52:22 GMT-3