Re: Voice VLAN and data traffic with and without trunking

From: ccie2002@tampabay.rr.com
Date: Fri Jun 27 2003 - 11:58:03 GMT-3


Both "switchport mode trunk" and "switchport access VLAN" do not have to be in
the config. But here is why we do it.

Ths data from the PC connected to the IP phone will use the trunk native VLAN.
We use the switcport access VLAN 6 so if this port is used with a PC and no IP
phone, we can just change from "switchport mode trunk" to switchport mode
access" and the VLAN is already there. Just our preference.

Or we can just leave the config as is and the PC will use the trunk native
VLAN.

The port has to be a trunk port to carry both voice and data in seperate VLAN's
with dot1q tagging.

Here is a couple of scenarios and configs.

First: IP Phone and PC with native VLAN configured

The PC uses the configured native VLAN
interface FastEthernet0/11
 switchport access vlan 253
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 253
 switchport mode trunk
 switchport voice vlan 30
 spanning-tree portfast

Hibay-3524-1#sho mac-address-table int fa0/11
Non-static Address Table:
Destination Address Address Type VLAN Destination Port
------------------- ------------ ---- --------------------
0001.0334.2c43 Dynamic 253 FastEthernet0/11 <<PC
0009.b7f9.c93e Dynamic 30 FastEthernet0/11 <<IP Phone
0009.b7f9.c93e Dynamic 253 FastEthernet0/11

Second: IP Phone with PC and no native VLAN configured

The PC will use the default native VLAN which is 1
interface FastEthernet0/12
 switchport access vlan 10
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport voice vlan 30
 spanning-tree portfast

Hibay-3524-1#sho mac-address-table int fa0/12
Non-static Address Table:
Destination Address Address Type VLAN Destination Port
------------------- ------------ ---- --------------------
0001.0334.19d2 Dynamic 1 FastEthernet0/12 <<PC
0009.b7f7.60b6 Dynamic 1 FastEthernet0/12
0009.b7f7.60b6 Dynamic 30 FastEthernet0/12 <<IP Phone

Third: No IP Phone, just PC

PC use trunk native VLAN

interface FastEthernet0/1
 switchport access vlan 116
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 116
 switchport mode trunk
 switchport voice vlan 30
 spanning-tree portfast

Hibay-3524-2#sho mac-address-table int fa0/1
Non-static Address Table:
Destination Address Address Type VLAN Destination Port
------------------- ------------ ---- --------------------
0080.450d.e0c6 Dynamic 116 FastEthernet0/1 << PC

Even though this port does not have a phone it is still in trunk mode.

Hibay-3524-2#sho int fa0/1 switc
Name: Fa0/1
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive)) <<<<Notice Access is disabled.
Trunking Native Mode VLAN: 116 (MFG-116)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2,7,8,10,12,22,30,32,41,44,47,53,62,75,76,99-101,104,
     106,116,118,120,140,142,200,232,252-254
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: 30
Appliance trust: none

 

But, why are you using "switchport access vlan 75" and "switchport trunk
> native vlan 75" together, Don't both ones do the same?, Are there any
> problem using "switchport access ..." and "switchport mode trunk"?
>
> I think the command "switchport trunk native vlan 6" on Cat3350 is wrong
> because the interface isn't a trunk, Am I in right?
>
>
> MMoniz ha escrito:
> >
> > Actually you can also just specify "switchport voice vlan dot1p" and it will
> > use VLAN 0 as default
> > and 802.1P as it's tagging with a COS of 5. I wouldn't recommend this
> > though.
> >
> > VDL-CAT(config-if)#switch voice vlan dot1p ?
> > <cr>
> >
> > I would specify a specific voice VLAN and use 802.1Q. But it has been my
> > experience that you must
> > also specify info for the data VLAN. I know this for a fact on the 3524
> > PWR...Have not tried it
> > on the 3550 with an IP phone. (3550 in lab, Call Manager in Production)
> >
> > This is the working config I use on a 3524 PWR
> >
> > interface FastEthernet0/19
> > switchport access vlan 75
> > switchport trunk encapsulation dot1q
> > switchport trunk native vlan 75
> > switchport mode trunk
> > switchport voice vlan 30
> > spanning-tree portfast
> >
> > This is what I would use on a 3550
> >
> > interface FastEthernet0/10
> > switchport access vlan 6
> > switchport trunk encapsulation dot1q
> > switchport trunk native vlan 6
> > switchport mode access
> > switchport voice vlan 30
> > switchport priority extend trust
> > no ip address
> > mls qos trust device cisco-phone
> > mls qos trust cos
> > spanning-tree portfast
> >
> > -----Original Message-----
> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
> > Scott Morris
> > Sent: Thursday, June 26, 2003 8:56 PM
> > To: 'Cristian Henry H'; James.Jackson@broadwing.com
> > Cc: bpjain@cisco.com; ccielab@groupstudy.com
> > Subject: RE: Voice VLAN and data traffic with and without trunking
> > modeco nfigured
> >
> > It will be dot1q by default. That's the only thing the IP phones listen
> > to, and the whole concept of auxilliary vlans or voice vlans revolved
> > around Cisco's IP phones... Therefore... :)
> >
> > -----Original Message-----
> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> > Cristian Henry H
> > Sent: Thursday, June 26, 2003 4:28 PM
> > To: James.Jackson@broadwing.com
> > Cc: bpjain@cisco.com; ccielab@groupstudy.com
> > Subject: Re: Voice VLAN and data traffic with and without trunking
> > modeco nfigured
> >
> > But, Do I need to add the command "switchport trunk encapsulation dot1q"
> > in order to be sure that the IP Phone use 802.1Q encapsulation? or it
> > will be 802.1q by default?
> >
> > James.Jackson@broadwing.com ha escrito:
> > >
> > > The access port does not become a trunk port. Instead of accepting
> > > untagged and 802.1Q with a tag that matches its Access VLAN, it now
> > > additionally accepts 802.1Q with a tag that matches Voice VLAN.
> > >
> > > HTH
> > > James
> > >
> > > -----Original Message-----
> > > From: Cristian Henry H [mailto:chenry@reuna.cl]
> > > Sent: Thursday, June 26, 2003 2:57 PM
> > > To: beda jain
> > > Cc: Jackson, James (DS Engineering); ccielab@groupstudy.com
> > > Subject: Re: Voice VLAN and data traffic with and without trunking
> > > modeco nfigured
> > >
> > > But, in the case 2 the "switchport voice vlan 101" command instruct
> > > the IP Phone to forward all voice traffic through the VLAN 101 using
> > > 802.1q frames, so, Does it mean the port get mode trunking with encap
> > > 802.1q automatically?
> > >
> > > beda jain ha escrito:
> > > >
> > > > If you do switchport mode access in case 2, it will block all 802.1q
> > > packet.
> > > >
> > > > so both the config will work fine, but in lab i will go for case 1.
> > > because
> > > > some extra line is ok.
> > > > and i will do spanning-tree port-fast trunk
> > > >
> > > > Thanks,
> > > > Beda
> > > >
> > > > At 12:57 PM 6/26/2003 -0500, James.Jackson@broadwing.com wrote:
> > > > >The two options look fine. As I understand it, in case 2, the port
> > > > >is not configured as a trunk however it is still able to process
> > > > >the 802.1Q
> > > packets
> > > > >coming from IPphone.
> > > > >
> > > > >James
> > > > >
> > > > >-----Original Message-----
> > > > >From: Cristian Henry H [mailto:chenry@reuna.cl]
> > > > >Sent: Thursday, June 26, 2003 12:48 PM
> > > > >Cc: ccielab@groupstudy.com
> > > > >Subject: Voice VLAN and data traffic with and without trunking mode
> >
> > > > >configured
> > > > >
> > > > >
> > > > >Dear all,
> > > > >
> > > > >If the requirement is to put the voice traffic (from IP Phone) in
> > > > >VLAN 101 and the data traffic (from behind IP Pone)in VLAN 102,
> > > > >what do you think about the following cases/configurations?, Do
> > > > >both ones the same?
> > > > >
> > > > >
> > > > >1) With 802.1q trunking mode configured
> > > > >
> > > > >interface FastEthernet0/10
> > > > > switchport trunk encapsulation dot1q
> > > > > switchport trunk native vlan 102
> > > > > switchport mode trunk
> > > > > switchport voice vlan 101
> > > > > no ip address
> > > > > spanning-tree portfast
> > > > >!
> > > > >
> > > > >2) Without 802.1q trunking mode configured
> > > > >
> > > > >interface FastEthernet0/10
> > > > > switchport access vlan 102
> > > > > switchport voice vlan 101
> > > > > spanning-tree portfast
> > > > >!
> > > > >In this 2) case, Does the port get automatically trunking mode
> > > > >802.1q?, is necesary to add " switchport trunk encapsulation
> > > > >dot1q"?, and if the port is trunk, does the "switchport access vlan
> >
> > > > >102" works well?
> > > > >
> > > > >
> > > > >Thanks in advance.
> > > > >
> > > > >--
> > > > >Cristian E. Henry
> > > > >REUNA
> > > > >
> > > > >E-mail: chenry@reuna.cl
> > > > >Fono: 56-2-3370336
> > > > >
> > > > >
> > > > >___________________________________________________________________
> > > > >____
> > > > >You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
> > > > >
> > > > >Subscription information may be found at:
> > > > >http://www.groupstudy.com/list/CCIELab.html
> > > > > +++The information transmitted is intended only for the person or
> > > entity to
> > > > >which it is addressed and may contain confidential and/or
> > > > >privileged material. Any review, retransmission, dissemination or
> > > > >other use of, or taking of any action in reliance upon, this
> > information by persons or
> > > > >entities other than the intended recipient is prohibited. If you
> > > received
> > > > >this in error, please contact the sender and destroy any copies of
> > > > >this document.+++
> > > > >
> > > > >
> > > > >___________________________________________________________________
> > > > >____
> > > > >You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
> > > > >
> > > > >Subscription information may be found at:
> > > > >http://www.groupstudy.com/list/CCIELab.html
> > >
> > > --
> > > Cristian E. Henry
> > > REUNA
> > >
> > > E-mail: chenry@reuna.cl
> > > Fono: 56-2-3370336
> > > +++The information transmitted is intended only for the person or
> > > entity to which it is addressed and may contain confidential and/or
> > > privileged material. Any review, retransmission, dissemination or
> > > other use of, or taking of any action in reliance upon, this
> > information by persons or
> > > entities other than the intended recipient is prohibited. If you
> > received
> > > this in error, please contact the sender and destroy any copies of
> > > this document.+++
> >
> > --
> > Cristian E. Henry
> > REUNA
> >
> > E-mail: chenry@reuna.cl
> > Fono: 56-2-3370336
> >
> > _______________________________________________________________________
> > You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
> >
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> > _______________________________________________________________________
> > You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
> >
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> --
> Cristian E. Henry
> REUNA
>
> E-mail: chenry@reuna.cl
> Fono: 56-2-3370336
>
>
> _______________________________________________________________________
> You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Fri Jul 04 2003 - 11:11:12 GMT-3