From: Peng Zheng (zpnist@yahoo.com)
Date: Thu Jun 26 2003 - 18:47:22 GMT-3
I use Legacy DDR dirst:
on r3:
interface BRI0
ip address 192.168.1.3 255.255.255.248
encapsulation ppp
ip ospf demand-circuit
dialer map ip 192.168.1.4 name r4 4081111111
dialer-group 1
isdn switch-type basic-ni
isdn spid1 40822222221 4082222222
isdn spid2 40822222222 4082222222
no peer neighbor-route
ppp authentication chap
on r4:
interface BRI0
ip address 192.168.1.4 255.255.255.248
encapsulation ppp
dialer map ip 192.168.1.3 name r3 4082222222
dialer-group 1
isdn switch-type basic-ni
isdn spid1 40811111111 4081111111
isdn spid2 40811111112 4081111111
no peer neighbor-route
ppp authentication chap
It works well. Then I changed r3 to use dialer
profile.
r3:
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-ni
isdn spid1 40822222221 4082222222
isdn spid2 40822222222 4082222222
ppp authentication chap
!
interface Dialer0
ip address 192.168.1.3 255.255.255.248
encapsulation ppp
ip ospf demand-circuit
dialer pool 1
dialer remote-name r4
dialer string 4081111111
dialer-group 1
no peer neighbor-route
ppp authentication chap
Then I got a message on r4:
00:17:06: %OSPF-5-ADJCHG: Process 1, Nbr 10.34.1.1 on
BRI0 from INIT to DOWN, Neighbor Down: Dead timer
expired
10.34.1.1 is router id of r3.
on r3, I run show dialer:
BRI0:1 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: ip (s=192.168.1.3, d=224.0.0.5)
Interface bound to profile Di0
Time until disconnect 96 secs
Current call connected 00:00:23
Connected to 4081111111 (r4)
WHat's the reason?
--- Jonathan V Hays <jhays@jtan.com> wrote:
> I've configured "ip ospf demand-circuit" recently
> both with legacy DDR
> and dialer profiles and it worked fine, without any
> problems, either
> way. Please post your configurations, with and
> without dialer profiles,
> and maybe we can see what you have been doing wrong.
>
>
> > -----Original Message-----
> > From: nobody@groupstudy.com
> [mailto:nobody@groupstudy.com] On
> > Behalf Of Peng Zheng
> > Sent: Thursday, June 26, 2003 4:26 PM
> > To: ccielab@groupstudy.com
> > Subject: ip ospf demand-circuit under interface
> dialer 0 doesn't work
> >
> >
> > I have two routers, r3 and r4. If I do not use
> dialer
> > interface on both them, ip ospf demand-circuit
> works
> > well. But if I user dialer profile on r3, After a
> > while, it bring up the link because ospf from init
> to
> > down.
> > How can I config ip ospf demand-circuit with
> dialer
> > profile?
> >
> > Thanks.
> >
> > __________________________________
> > Do you Yahoo!?
> > SBC Yahoo! DSL - Now only $29.95 per month!
> > http://sbc.yahoo.com
> >
> >
> >
>
This archive was generated by hypermail 2.1.4 : Fri Jul 04 2003 - 11:11:11 GMT-3