RE: Police command confusion

From: Daniel Cisco Group Study (danielcgs@imc.net.au)
Date: Tue May 27 2003 - 07:28:50 GMT-3


Hunt,

Firstly, this is my interpretation of the doco, and has not been handed down to me by an "authority".

From what I can gather, the aggregate policer is a quick way to apply the same "policing paramters" to multple classes. For example, the policy map "NOAGG" will do exactly the same as "WITHAGG" in the example below.

Anyone agree with this???????

If I'm correct, I'd probably not use an aggregate policer in the exam, unless it was a requirement, or I didn't want to type in the same thing 10 times........sorry.. 8 times. (max no. of policers = 8 on FE)

Daniel

Example:

mls qos aggregate-policer MrPoliceman 128000 8000 exceed-action drop
mls qos
!
class-map match-all class4
  match access-group 103
class-map match-all class2
  match access-group 101
class-map match-all class3
  match access-group 102
class-map match-all class1
  match access-group 100
!
!
policy-map NOAGG
  class class1
    police 128000 8000 exceed-action drop
  class class2
    police 128000 8000 exceed-action drop
  class class3
    police 128000 8000 exceed-action drop
  class class4
    police 128000 8000 exceed-action drop
!
policy-map WITHAGG
  class class1
    police aggregate MrPoliceman
  class class2
    police aggregate MrPoliceman
  class class3
    police aggregate MrPoliceman
  class class4
    police aggregate MrPoliceman
!

-----Original Message-----
From: lg01 [mailto:lg01@myway.com]
Sent: Sunday, 25 May 2003 22:29
To: ccielab@groupstudy.com
Subject: Police command confusion

Hi Team,

Can someone please explain to me, for policy map, when should one just use the "police" command, and when should we use the "aggregate policer" command?

Or is there any particular "wording" that hints when I should use each?

In my exercise that I'm working on, it goes like "Police port 0/13 of switch1. Limit the speed on this port to 1Mbps, with burst set to 32kps. Drop all packets that exceed this policy"... and the answer ended up using "aggregate policer".

As an e.g., for the "police" command...

mls qos
!
class-map match-all class1
match access-group 102
!
!
policy-map pol1
class class1
police 1000000 32000 exceed-action drop
!
interface FastEthernet0/13
switchport access vlan 813
no ip address
service-policy input pol1
!
access-list 102 permit ip any any

Just for completeness, here comes the "aggregate policer" e.g.

mls qos
!
mls qos aggregate-policer PolicyA 1000000 32000 exceed-action drop
!
class-map match-all All
  match access-group 102
!
!
policy-map Test
  class All
    police aggregate PolicyA

interface FastEthernet0/12
 switchport access vlan 800
 switchport mode access
 no ip address
 service-policy input Test
 spanning-tree portfast

access-list 102 permit ip any any

And one last question I have got for you guys before heading to bed.
For police OR aggregate-policer, does it work like CAR where the burst value is in bytes? (rather than in bits)

Meaning should my command become.. (to change 32000bits into bytes?)

mls qos aggregate-policer PolicyA 1000000 4000 exceed-action drop

Any help would be greatly appreciated.

Regards,
Hunt



This archive was generated by hypermail 2.1.4 : Mon Jun 02 2003 - 15:13:48 GMT-3