BGP help!!!

From: lg01 (lg01@myway.com)
Date: Tue May 20 2003 - 09:51:07 GMT-3


Hi Team,

I am working for some BGP Sync. scenarios

- R5 ---- R1 - 192.168.100.0 /24
  |

Ok, the link between R1 & R5 are covered by both EBGP & EIGRP.

And I wanted to just redistribute R1's 192.168.100.0/24 into IGP (via EIGRP), so my routers (attahced to R5) can get it to sync. within BGP.

Since EBGP has lower Admin Dist than EIGRP, I used the BGP's "network x.x.x.x backdoor" command so R5 will get it's route via EIGRP.

Now, my question is that does this "backdoor" command works / takes effect indefinitely... or does it only work for the current BGP session...

Coz I find that if I don't do anything (as in don't kill the BGP session, nor reboot the routers), then that 192.168.100.0/24 will stay in at R5's RT forever as EIGRP route.

However, if I reboot or do a "clear ip bgp *", then the BGP would change itself back to 20 & takes over my EIGRP route, and hence all my other routers attached to R1 can no longer sync with that route...

Also, if I do a "no network" command and re-put in that backdoor command, it will work again until the next reboot or clear ip bgp...

Any help would be greatly appreciated.

And just for completeness, I have attached the config for R5 & R1 as follows:

r5#sh run
Building configuration...

!
ip multicast-routing
no ip dhcp-client network-discovery
isdn switch-type basic-net3
!
interface Loopback0
 ip address 10.5.5.5 255.255.255.0
!
interface Ethernet0
 ip address 172.150.8.5 255.255.255.0
 ip rsvp bandwidth 32 32
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
 no fair-queue
 clockrate 64000
 ip rsvp bandwidth 87 87
!
interface Serial0.1 point-to-point
 ip address 172.150.1.5 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 frame-relay interface-dlci 101
!
interface Serial0.2 multipoint
 ip address 172.150.5.5 255.255.255.240
 ip pim nbma-mode
 ip pim sparse-mode
 no ip route-cache
 ip ospf message-digest-key 1 md5 cisco
 no ip mroute-cache
 frame-relay map ip 172.150.5.2 16 broadcast
 frame-relay map ip 172.150.5.5 16 broadcast
 frame-relay map ip 172.150.5.6 17 broadcast
 no frame-relay inverse-arp
 ip rsvp bandwidth 32 32
!
interface BRI0
 bandwidth 128
 ip address 172.150.9.5 255.255.255.252
 encapsulation ppp
 ip ospf message-digest-key 1 md5 cisco
 ip ospf cost 9999
 dialer idle-timeout 180
 dialer map ip 172.150.9.6 name r6 broadcast 1111
 dialer-group 1
 isdn switch-type basic-net3
 cdapi buffers regular 0
 cdapi buffers raw 0
 cdapi buffers large 0
 no peer neighbor-route
 ppp authentication chap callin
 ppp multilink
!
router eigrp 100
 redistribute ospf 1
 network 172.150.1.0 0.0.0.255
 default-metric 10000 1000 255 1 1500
 no auto-summary
 no eigrp log-neighbor-changes
!
router ospf 1
 log-adjacency-changes
 area 0 authentication message-digest
 area 1 nssa default-information-originate
 redistribute eigrp 100 subnets
 network 10.5.5.5 0.0.0.0 area 0
 network 172.150.5.0 0.0.0.255 area 0
 network 172.150.8.0 0.0.0.255 area 1
 network 172.150.9.0 0.0.0.255 area 0
 neighbor 172.150.5.6
 neighbor 172.150.5.2
!
router bgp 64126
 bgp log-neighbor-changes
 bgp confederation identifier 100
 network 192.168.100.0 backdoor
 neighbor 10.3.3.3 remote-as 64126
 neighbor 10.3.3.3 ebgp-multihop 2
 neighbor 10.3.3.3 update-source Loopback0
 neighbor 10.3.3.3 route-reflector-client
 neighbor 10.6.6.6 remote-as 64126
 neighbor 10.6.6.6 ebgp-multihop 2
 neighbor 10.6.6.6 update-source Loopback0
 neighbor 10.6.6.6 route-reflector-client
 neighbor 172.150.1.1 remote-as 65200
!
map-class frame-relay keepalive
 frame-relay end-to-end keepalive mode bidirectional
access-list 100 deny ospf any any
access-list 100 permit ip any any
access-list 110 permit tcp any any eq 2065
access-list 110 permit tcp any eq 2065 any
dialer-list 1 protocol ip list 100
dialer-list 2 protocol ip permit
!
menu MenuA command 4 menu-exit
!
end

r5#

And as for R1:

r1#sh run
Building configuration...

hostname r1
!
enable secret 5 $1$/F5u$DXlDu5T1rQIaJm.Fr1TlI/
!
username r2 password 0 cisco
interface Loopback0
 ip address 10.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 192.168.100.1 255.255.255.0
!
interface Ethernet0
 mac-address d0d0.d0d0.d0d0
 ip address 192.168.0.8 255.255.255.0
 ip nat inside
!
interface Virtual-Template1
 bandwidth 128
 ip address 172.150.2.1 255.255.255.0
 ip bandwidth-percent eigrp 100 25
 ppp authentication chap
!
interface Serial0
 no ip address
 encapsulation frame-relay
 clockrate 125000
 frame-relay lmi-type cisco
 frame-relay intf-type dce
!
interface Serial0.1 point-to-point
 frame-relay interface-dlci 16 ppp Virtual-Template1
!
interface Serial1
 ip address 172.150.1.1 255.255.255.0
 ip nat outside
 encapsulation frame-relay
 frame-relay map ip 172.150.1.1 101 broadcast
 frame-relay map ip 172.150.1.5 101 broadcast
 no frame-relay inverse-arp
!
router eigrp 100
 redistribute connected route-map forBGP
 network 10.0.0.0
 network 172.150.0.0
 no auto-summary
!
router bgp 65200
 bgp log-neighbor-changes
 network 192.168.100.0
 neighbor 172.150.1.5 remote-as 100
 neighbor 172.150.2.2 remote-as 65200
 no auto-summary
!
ip nat pool PoolA 172.150.1.100 172.150.1.149 prefix-length 24
ip nat inside source list 5 pool PoolA
ip nat inside source static 192.168.1.10 172.150.1.10
ip classless
ip http server
!
!
ip prefix-list BGProute seq 5 permit 192.168.100.0/24
ip prefix-list BGProute seq 10 deny 0.0.0.0/0 le 32
access-list 5 permit 192.168.1.0 0.0.0.255
route-map forBGP permit 10
 match ip address prefix-list BGProute
!
end

Any help would be greatly appreciated.

Regards,
Hunt



This archive was generated by hypermail 2.1.4 : Mon Jun 02 2003 - 15:13:45 GMT-3