demand-circuit command

From: Tom Young (gitsyoung@yahoo.co.jp)
Date: Tue May 13 2003 - 06:52:42 GMT-3


Hi, group

 I had set the r5 and r6 for isdn dialer peer, I can't
stop the dialer-up for 224.0.0.5. Even I set the ip os
demand-circuit on one side or both sides,I confused !

Thanks alot

#r5
Building configuration...

Current configuration : 2739 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r5
!
logging rate-limit console 10 except errors
!
username r6 password 0 ccie
ip subnet-zero
no ip finger
no ip domain-lookup
!
ip multicast-routing
isdn switch-type basic-net3
cns event-service server
!
!
!
interface Loopback0
 ip address 137.1.5.5 255.255.255.0
!
interface Ethernet0
 ip address 137.20.20.10 255.255.255.0
 ip irdp
 ip pim sparse-mode
 ip ospf authentication-key ccie
 ip ospf priority 100
 ip igmp join-group 224.1.1.1
 standby 1 timers 2 20
 standby 1 priority 200
 standby 1 authentication ccie
 standby 1 ip 137.20.20.5
!
interface Serial0
 no ip address
 encapsulation frame-relay
!
interface Serial0.1 multipoint
 ip address 172.168.100.5 255.255.255.0
 ip ospf message-digest-key 1 md5 ccie
 ip ospf network point-to-multipoint
 ip ospf priority 100
 frame-relay map ip 172.168.100.3 503 broadcast
 frame-relay map ip 172.168.100.6 506 broadcast
!
interface Serial0.2 point-to-point
 ip address 172.168.200.1 255.255.255.0
 frame-relay interface-dlci 504
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 ip address 172.168.65.5 255.255.255.252
 encapsulation ppp
 ip ospf demand-circuit
 dialer idle-timeout 30
 dialer-group 1
 isdn switch-type basic-net3
 no peer neighbor-route
 no cdp enable
 ppp authentication chap
 ppp chap hostname ccie
 ppp chap password 7 121A061E17
!
router ospf 1
 router-id 172.168.100.5
 log-adjacency-changes
 area 0 authentication
 area 10 authentication message-digest
 area 10 virtual-link 172.168.60.1 authentication-key ccie
 area 10 virtual-link 172.168.30.97 authentication-key
ccie
 redistribute igrp 1 metric 200 metric-type 1 subnets
 network 137.20.20.10 0.0.0.0 area 0
 network 172.168.65.5 0.0.0.0 area 10
 network 172.168.100.5 0.0.0.0 area 10
!
router igrp 1
 redistribute ospf 1
 passive-interface BRI0
 passive-interface Serial0.1
 network 172.168.0.0
 default-metric 10000 100 255 1 1500
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 neighbor 172.168.100.3 remote-as 1
 neighbor 172.168.100.3 route-reflector-client
 neighbor 172.168.100.6 remote-as 1
 neighbor 172.168.100.6 route-reflector-client
 neighbor 172.168.200.2 remote-as 1
 neighbor 172.168.200.2 route-reflector-client
 neighbor 200.200.200.1 remote-as 2
 neighbor 200.200.200.1 ebgp-multihop 255
!
ip kerberos source-interface any
ip classless
no ip http server
ip pim rp-address 137.20.20.1
!
dialer-list 1 protocol ip permit
!
alias exec i sh ip route
alias exec ci clear ip route *
alias exec ib sh ip bgp
alias exec cib clear ip bgp * soft
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

-------------------------------------------------
r6#sh ru
Building configuration...

Current configuration : 2029 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r6
!
logging rate-limit console 10 except errors
!
username ccie password 0 ccie
ip subnet-zero
no ip finger
no ip domain-lookup
!
ip accounting-threshold 200
isdn switch-type basic-net3
cns event-service server
!
!
!
interface Loopback0
 ip address 172.168.60.1 255.255.255.0
 ip ospf network point-to-point
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 bandwidth 64
 ip address 172.168.100.6 255.255.255.0
 ip router isis
 encapsulation frame-relay
 ip ospf message-digest-key 1 md5 ccie
 ip ospf network point-to-multipoint
 frame-relay map ip 172.168.100.3 605 broadcast
 frame-relay map ip 172.168.100.5 605 broadcast
 no frame-relay inverse-arp
!
interface Serial0.1 multipoint
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 ip address 172.168.65.6 255.255.255.252
 ip accounting output-packets
 encapsulation ppp
 ip ospf cost 9999
 ip ospf demand-circuit
 dialer idle-timeout 30
 dialer string 6002
 dialer-group 1
 isdn switch-type basic-net3
 no peer neighbor-route
 no cdp enable
 ppp authentication chap
!
router ospf 1
 log-adjacency-changes
 area 0 authentication
 area 10 authentication message-digest
 area 10 virtual-link 172.168.100.5 authentication-key
ccie
 network 172.168.60.1 0.0.0.0 area 6
 network 172.168.65.6 0.0.0.0 area 10
 network 172.168.100.6 0.0.0.0 area 10
 default-information originate
!
router isis
 redistribute ospf 1
 net 49.0001.6666.6666.6666.00
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 172.168.60.0 mask 255.255.255.0
 neighbor 172.168.100.5 remote-as 1
!
ip kerberos source-interface any
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
!
bridge 1 protocol ieee
alias exec i sh ip route
alias exec ci clear ip route *
alias exec ib sh ip bgp
alias exec cib clear ip bgp * soft
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

r6# sh dia

BRI0 - dialer type = ISDN

Dial String Successes Failures Last DNIS Last
status
6002 102 1 00:00:24
successful Default
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI0:1 - dialer type = ISDN
Idle timer (30 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

BRI0:2 - dialer type = ISDN
Idle timer (30 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: ip (s=172.168.65.6, d=224.0.0.5)
Time until disconnect 26 secs
Current call connected 00:00:25
Connected to 6002 (ccie)



This archive was generated by hypermail 2.1.4 : Mon Jun 02 2003 - 15:13:41 GMT-3