From: Jason Cash (cash2001@swbell.net)
Date: Tue Apr 29 2003 - 12:57:33 GMT-3
OK I added the following to R4:
R4
ip pim rp-address 150.50.24.4 4
!
access-list 4 permit 224.44.44.44
However, the exercise states "that
Also when I ping 224.44.44.44 from R2, why is it responded to by R5 when
R4 is directly attached to it (and multiple times at that!):
r2#ping
Protocol [ip]:
Target IP address: 224.44.44.44
Repeat count [1]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.44.44.44, timeout is 2 seconds:
Reply to request 0 from 150.50.100.5, 72 ms
Reply to request 0 from 150.50.100.5, 1932 ms
Reply to request 0 from 150.50.100.5, 1820 ms
Reply to request 0 from 150.50.100.5, 1720 ms
Also, when I ping from R5, it is responded to by r5!
r5#ping
Protocol [ip]:
Target IP address: 224.44.44.44
Repeat count [1]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.44.44.44, timeout is 2 seconds:
Reply to request 0 from 150.50.7.5, 16 ms
-----Original Message-----
From: FATHALLAH [mailto:sfathallah@mail.cbi.net.ma]
Sent: Tuesday, April 29, 2003 4:50 AM
To: Jason Cash; ccielab@groupstudy.com
Subject: RE: Multicast - a bit clueless!
Jason,
Your RP ( R4 ) need to know that it is the RP. so the command "ip pim rp
add" is requiered in R4. also the multucast ping work because you are
configuring pim sparse-dense-mode. so when R4 can't use the sparse mode
for
multicast routing because it does'nt know the RP it use the dense mode.
Said FATHALLAH
-----Message d'origine-----
De : nobody@groupstudy.com [mailto:nobody@groupstudy.com]De la part de
Jason Cash
Envoyi : lundi 28 avril 2003 22:48
@ : ccielab@groupstudy.com
Objet : Multicast - a bit clueless!
Ok, I am now into multicasting, and I am having trouble confirming my
work. This is IPE Section 17 (for anyone who has it). Here is the
topo:
/-----R4
R1-R2
| \
| \
R5---R6
| /
| /
R7
|
R8
Routers 1and 2 are connected via Ethernet segment. R5,6,7 are as well
(different segment).
Problem 1
This error message appears on R4:
r4# %PIM-6-INVALID_RP_JOIN: Received (*, 224.44.44.44) Join from
150.50.24.2 for invalid RP 150.50.24.4
Also, when I ping 224.44.44.44 from R2, it looks as though R5 is
responding:
r2#ping
Protocol [ip]:
Target IP address: 224.44.44.44
Repeat count [1]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.44.44.44, timeout is 2 seconds:
Reply to request 0 from 150.50.100.5, 80 ms
Reply to request 0 from 150.50.100.5, 176 ms
Below are the configs:
hostname r2
!
ip multicast-routing
!
interface Ethernet0
description to R1 E0 (crossover)
ip address 150.50.17.2 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 224.11.11.11
ip igmp join-group 224.11.11.12
ip igmp join-group 224.11.11.13
!
interface Serial0
no ip address
encapsulation frame-relay
no fair-queue
frame-relay lmi-type cisco
!
interface Serial0.24 point-to-point
ip address 150.50.24.2 255.255.255.0
ip pim sparse-dense-mode
frame-relay interface-dlci 104
!
interface Serial0.256 multipoint
ip address 150.50.100.2 255.255.255.224
ip pim sparse-dense-mode
frame-relay map ip 150.50.100.2 105
frame-relay map ip 150.50.100.5 105 broadcast
frame-relay map ip 150.50.100.6 106 broadcast
!
ip classless
no ip http server
ip pim rp-address 150.50.24.4 4
ip pim rp-address 150.50.7.7 7
!
access-list 4 permit 224.44.44.44
access-list 7 permit 224.88.88.88
============================
hostname r4
!
no ip domain-lookup
!
ip multicast-routing
!
interface Loopback0
ip address 200.0.0.4 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.1.4 255.255.255.0
ip pim sparse-dense-mode
no keepalive
speed 10
half-duplex
!
interface Serial0/0
ip address 150.50.24.4 255.255.255.0
ip pim sparse-dense-mode
encapsulation frame-relay
ip ospf network point-to-point
frame-relay map ip 150.50.24.2 401 broadcast
frame-relay map ip 150.50.24.4 401
==============================
hostname r5
!
ip multicast-routing
!
interface Ethernet0
ip address 150.50.7.5 255.255.255.128
ip pim sparse-dense-mode
ip igmp join-group 224.44.44.44
ip cgmp
!
interface Serial0
ip address 150.50.100.5 255.255.255.224
ip pim sparse-dense-mode
encapsulation frame-relay
ip ospf priority 0
no fair-queue
frame-relay map ip 150.50.100.2 501 broadcast
frame-relay map ip 150.50.100.5 501
frame-relay map ip 150.50.100.6 501 broadcast
!
ip classless
no ip http server
ip pim rp-address 150.50.24.4 4
ip pim rp-address 150.50.7.7 7
!
access-list 4 permit 224.44.44.44
access-list 7 permit 224.88.88.88
=================================
hostname r6
!
ip multicast-routing
!
interface FastEthernet0/1/0
ip address 150.50.7.6 255.255.255.128
ip pim sparse-dense-mode
ip ospf priority 0
ip igmp static-group 224.88.88.88
ip cgmp
speed 10
half-duplex
!
interface Serial1/0
ip address 150.50.100.6 255.255.255.224
ip pim sparse-dense-mode
encapsulation frame-relay
ip ospf priority 0
no fair-queue
serial restart-delay 0
frame-relay map ip 150.50.100.2 601 broadcast
frame-relay map ip 150.50.100.5 601 broadcast
frame-relay map ip 150.50.100.6 601
!
ip classless
no ip http server
ip pim rp-address 150.50.24.4 4
ip pim rp-address 150.50.7.7 7
!
access-list 4 permit 224.44.44.44
access-list 7 permit 224.88.88.88
===================================
hostname r7
!
ip multicast-routing
!
interface FastEthernet0/0
ip address 150.50.7.7 255.255.255.128
ip pim sparse-dense-mode
ip ospf priority 0
ip igmp query-interval 120
ip cgmp
duplex auto
speed auto
!
interface Serial0/0
ip address 150.50.5.68 255.255.255.224
ip pim neighbor-filter 8
ip pim sparse-dense-mode
no fair-queue
!
ip classless
no ip http server
ip pim rp-address 150.50.24.4 4
ip pim rp-address 150.50.7.7 7
!
access-list 4 permit 224.44.44.44
access-list 7 permit 224.88.88.88
access-list 8 deny 150.50.5.69
This archive was generated by hypermail 2.1.4 : Thu May 01 2003 - 13:36:09 GMT-3